Ion (based on PWM) is a new kind of window manager that brings a
text-editorish, keyboard friendly user interface to window management. This is a development series of ion-3. PR: ports/82378 Submitted by: Ed Schouten <ed@fxq.nl>
This commit is contained in:
parent
db1bde434f
commit
2c1eae3a13
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139666
13 changed files with 521 additions and 0 deletions
|
@ -54,6 +54,7 @@
|
|||
SUBDIR += icewm
|
||||
SUBDIR += ion
|
||||
SUBDIR += ion-2
|
||||
SUBDIR += ion-3ds
|
||||
SUBDIR += jewel
|
||||
SUBDIR += kahakai
|
||||
SUBDIR += kappdock
|
||||
|
|
45
x11-wm/ion-3/Makefile
Normal file
45
x11-wm/ion-3/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# New ports collection makefile for: ion3-ds
|
||||
# Date created: 18 June 2005
|
||||
# Whom: Ed Schouten <ed@fxq.nl>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ion-3ds
|
||||
PORTVERSION= 20050625
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
|
||||
|
||||
MAINTAINER= ed@fxq.nl
|
||||
COMMENT= The development version of the Ion window manager
|
||||
|
||||
LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
|
||||
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
|
||||
|
||||
CONFLICTS= ion-2002* pwm-* ion-2*
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= DEFINES="${IONDEFINES}"
|
||||
|
||||
.if !defined(WITH_XINERAMA)
|
||||
IONDEFINES+= -DCF_NO_XINERAMA
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_NLS)
|
||||
IONDEFINES+= -DCF_NO_LOCALE
|
||||
.endif
|
||||
|
||||
MAN1= ion3.1 pwm3.1
|
||||
DOCSDIR= share/doc/ion3
|
||||
|
||||
# NO, I don't want to use configure but ion's author system.mk
|
||||
do-configure:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
IGNORE= needs wide character string functions in libc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
x11-wm/ion-3/distinfo
Normal file
2
x11-wm/ion-3/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (ion-3ds-20050625.tar.gz) = 5eba98afb32ce8448698a84ca9f2f960
|
||||
SIZE (ion-3ds-20050625.tar.gz) = 583363
|
11
x11-wm/ion-3/files/patch-load
Normal file
11
x11-wm/ion-3/files/patch-load
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- mod_statusbar/ion-statusd/statusd_load.lua.orig Sat Jun 25 17:13:32 2005
|
||||
+++ mod_statusbar/ion-statusd/statusd_load.lua Mon Jul 4 01:22:09 2005
|
||||
@@ -46,7 +46,7 @@
|
||||
end
|
||||
local s=f:read('*l')
|
||||
f:close()
|
||||
- local st, en, load=string.find(s, 'load average:%s*(.*)')
|
||||
+ local st, en, load=string.find(s, 'load averages?:%s*(.*)')
|
||||
return (load or "")
|
||||
end
|
||||
|
96
x11-wm/ion-3/files/patch-system.mk
Normal file
96
x11-wm/ion-3/files/patch-system.mk
Normal file
|
@ -0,0 +1,96 @@
|
|||
--- system.mk.orig Sat Jun 25 17:13:43 2005
|
||||
+++ system.mk Sat Jul 16 18:56:28 2005
|
||||
@@ -7,7 +7,7 @@
|
||||
## Installation paths
|
||||
##
|
||||
|
||||
-PREFIX=/usr/local
|
||||
+#PREFIX=/usr/local
|
||||
|
||||
# Unless you are creating a package conforming to some OS's standards, you
|
||||
# probably do not want to modify the following directories:
|
||||
@@ -19,7 +19,7 @@
|
||||
# Some .lua files and ion-* shell scripts
|
||||
SHAREDIR=$(PREFIX)/share/ion3
|
||||
# Manual pages
|
||||
-MANDIR=$(PREFIX)/share/man
|
||||
+MANDIR=$(MANPREFIX)/man
|
||||
# Some documents
|
||||
DOCDIR=$(PREFIX)/share/doc/ion3
|
||||
# Nothing at the moment
|
||||
@@ -47,7 +47,7 @@
|
||||
#PRELOAD_MODULES=1
|
||||
|
||||
# Flags to link with libdl.
|
||||
-DL_LIBS=-ldl
|
||||
+#DL_LIBS=-ldl
|
||||
|
||||
|
||||
##
|
||||
@@ -56,7 +56,7 @@
|
||||
|
||||
# If you have installed Lua 5.0 from the official tarball without changing
|
||||
# paths, this should do it.
|
||||
-LUA_DIR=/usr/local
|
||||
+LUA_DIR=$(LOCALBASE)
|
||||
LUA_LIBS = -L$(LUA_DIR)/lib -llua -llualib
|
||||
LUA_INCLUDES = -I$(LUA_DIR)/include
|
||||
LUA=$(LUA_DIR)/bin/lua
|
||||
@@ -74,7 +74,7 @@
|
||||
## X libraries, includes and options
|
||||
##
|
||||
|
||||
-X11_PREFIX=/usr/X11R6
|
||||
+X11_PREFIX=$(X11BASE)
|
||||
# SunOS/Solaris
|
||||
#X11_PREFIX=/usr/openwin
|
||||
|
||||
@@ -107,7 +107,7 @@
|
||||
# asprintf and vasprintf in the c library. (gnu libc has.)
|
||||
# If HAS_SYSTEM_ASPRINTF is not defined, an implementation
|
||||
# in sprintf_2.2/ is used.
|
||||
-#HAS_SYSTEM_ASPRINTF=1
|
||||
+HAS_SYSTEM_ASPRINTF=1
|
||||
|
||||
|
||||
# If you're on an archaic system (such as relatively recent *BSD releases)
|
||||
@@ -116,24 +116,24 @@
|
||||
#DEFINES += -DCF_NO_LOCALE
|
||||
|
||||
# On some other systems you may something like this:
|
||||
-#EXTRA_LIBS += -lintl
|
||||
-#EXTRA_INCLUDES +=
|
||||
+EXTRA_LIBS += -L$(LOCALBASE)/lib -lintl
|
||||
+EXTRA_INCLUDES += -I$(LOCALBASE)/include
|
||||
|
||||
|
||||
##
|
||||
## C compiler
|
||||
##
|
||||
|
||||
-CC=gcc
|
||||
+CC?=gcc
|
||||
|
||||
# Same as '-Wall -pedantic' without '-Wunused' as callbacks often
|
||||
# have unused variables.
|
||||
WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
|
||||
-Wtrigraphs -Wformat -Wchar-subscripts \
|
||||
- -Wparentheses -pedantic -Wuninitialized
|
||||
+ -Wparentheses
|
||||
|
||||
-CFLAGS=-g -Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
|
||||
-LDFLAGS=-g -Os $(EXTRA_LIBS) $(LIBS)
|
||||
+CFLAGS=$(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
|
||||
+LDFLAGS=$(EXTRA_LIBS) $(LIBS)
|
||||
EXPORT_DYNAMIC=-Xlinker --export-dynamic
|
||||
|
||||
# The following options are mainly for development use and can be used
|
||||
@@ -147,7 +147,7 @@
|
||||
#POSIX_SOURCE=-D_POSIX_SOURCE
|
||||
|
||||
# Most systems
|
||||
-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
|
||||
+XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
|
||||
# SunOS, (Irix)
|
||||
#XOPEN_SOURCE=-D__EXTENSIONS__
|
||||
|
20
x11-wm/ion-3/pkg-descr
Normal file
20
x11-wm/ion-3/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
|||
Ion (based on PWM) is a new kind of window manager that brings a
|
||||
text-editorish, keyboard friendly user interface to window management.
|
||||
|
||||
Modern GUIs are unusable. Overlapping windows are hard to manage, especially
|
||||
from the keyboard, and the user often ends up in a jungle. Not to mention the
|
||||
application programs, which are even worse. Mouse-based search-and-click
|
||||
interfaces are slow - keyboard is fast having learnt the commands. Ion (the
|
||||
last three letters of vision =-) was written as an example and an experiment of
|
||||
something presumably better (just the window manager, though).
|
||||
|
||||
Ion simply divides the screen into frames that take the whole screen. Big
|
||||
displays have so much space that this is convenient and smaller displays
|
||||
couldn't show more than one window at a time anyway. The frames can be split
|
||||
and growing the size of one will shrink others. Alike in PWM, clients can be
|
||||
moved between frames and multiple clients can be attached to one frame.
|
||||
|
||||
With Ion you will hardly ever have to touch the mouse again for navigation
|
||||
between windows and the windows are always in order.
|
||||
|
||||
WWW: http://modeemi.cs.tut.fi/~tuomov/ion/
|
86
x11-wm/ion-3/pkg-plist
Normal file
86
x11-wm/ion-3/pkg-plist
Normal file
|
@ -0,0 +1,86 @@
|
|||
bin/ion3
|
||||
bin/pwm3
|
||||
etc/ion3/cfg_bindings.lua
|
||||
etc/ion3/cfg_dock.lua
|
||||
etc/ion3/cfg_floatws.lua
|
||||
etc/ion3/cfg_ion.lua
|
||||
etc/ion3/cfg_ionws.lua
|
||||
etc/ion3/cfg_kludges.lua
|
||||
etc/ion3/cfg_menu.lua
|
||||
etc/ion3/cfg_menus.lua
|
||||
etc/ion3/cfg_panews.lua
|
||||
etc/ion3/cfg_pwm.lua
|
||||
etc/ion3/cfg_pwm_bindings.lua
|
||||
etc/ion3/cfg_pwm_menus.lua
|
||||
etc/ion3/cfg_query.lua
|
||||
etc/ion3/cfg_sp.lua
|
||||
etc/ion3/cfg_statusbar.lua
|
||||
etc/ion3/dock-draw.lua
|
||||
etc/ion3/look.lua
|
||||
etc/ion3/look_brownsteel.lua
|
||||
etc/ion3/look_clean.lua
|
||||
etc/ion3/look_cleanios.lua
|
||||
etc/ion3/look_cleanviolet.lua
|
||||
etc/ion3/look_dusky.lua
|
||||
etc/ion3/look_greyviolet.lua
|
||||
etc/ion3/look_ios.lua
|
||||
etc/ion3/look_simpleblue.lua
|
||||
etc/ion3/look_wheat2.lua
|
||||
etc/ion3/lookcommon_clean.lua
|
||||
etc/ion3/lookcommon_emboss.lua
|
||||
lib/ion3/bin/ion-completefile
|
||||
lib/ion3/bin/ion-statusd
|
||||
lib/ion3/lc/de.lc
|
||||
lib/ion3/lc/ext_statusbar.lc
|
||||
lib/ion3/lc/ioncore_bindings.lc
|
||||
lib/ion3/lc/ioncore_efbb.lc
|
||||
lib/ion3/lc/ioncore_ext.lc
|
||||
lib/ion3/lc/ioncore_luaext.lc
|
||||
lib/ion3/lc/ioncore_misc.lc
|
||||
lib/ion3/lc/ioncore_wd.lc
|
||||
lib/ion3/lc/ioncore_winprops.lc
|
||||
lib/ion3/lc/mod_dock.lc
|
||||
lib/ion3/lc/mod_floatws.lc
|
||||
lib/ion3/lc/mod_ionws.lc
|
||||
lib/ion3/lc/mod_menu.lc
|
||||
lib/ion3/lc/mod_mgmtmode.lc
|
||||
lib/ion3/lc/mod_panews.lc
|
||||
lib/ion3/lc/mod_query.lc
|
||||
lib/ion3/lc/mod_query_chdir.lc
|
||||
lib/ion3/lc/mod_sm.lc
|
||||
lib/ion3/lc/mod_sp.lc
|
||||
lib/ion3/lc/mod_statusbar.lc
|
||||
lib/ion3/lc/statusd_date.lc
|
||||
lib/ion3/lc/statusd_load.lc
|
||||
lib/ion3/lc/statusd_mail.lc
|
||||
lib/ion3/mod/de.so
|
||||
lib/ion3/mod/mod_dock.so
|
||||
lib/ion3/mod/mod_floatws.so
|
||||
lib/ion3/mod/mod_ionws.so
|
||||
lib/ion3/mod/mod_menu.so
|
||||
lib/ion3/mod/mod_mgmtmode.so
|
||||
lib/ion3/mod/mod_panews.so
|
||||
lib/ion3/mod/mod_query.so
|
||||
lib/ion3/mod/mod_sm.so
|
||||
lib/ion3/mod/mod_sp.so
|
||||
lib/ion3/mod/mod_statusbar.so
|
||||
share/doc/ion3/ChangeLog
|
||||
share/doc/ion3/LICENSE
|
||||
share/doc/ion3/README
|
||||
share/doc/ion3/RELNOTES
|
||||
share/ion3/ion-completeman
|
||||
share/ion3/ion-runinxterm
|
||||
share/ion3/welcome.cs.txt
|
||||
share/ion3/welcome.de.txt
|
||||
share/ion3/welcome.fi.txt
|
||||
share/ion3/welcome.txt
|
||||
share/locale/cs/LC_MESSAGES/ion3.mo
|
||||
share/locale/de/LC_MESSAGES/ion3.mo
|
||||
share/locale/fi/LC_MESSAGES/ion3.mo
|
||||
@dirrm lib/ion3/bin
|
||||
@dirrm lib/ion3/lc
|
||||
@dirrm lib/ion3/mod
|
||||
@dirrm lib/ion3
|
||||
@dirrm share/ion3
|
||||
@dirrm share/doc/ion3
|
||||
@unexec rmdir %D/etc/ion3 2>/dev/null || true
|
45
x11-wm/ion-3ds/Makefile
Normal file
45
x11-wm/ion-3ds/Makefile
Normal file
|
@ -0,0 +1,45 @@
|
|||
# New ports collection makefile for: ion3-ds
|
||||
# Date created: 18 June 2005
|
||||
# Whom: Ed Schouten <ed@fxq.nl>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= ion-3ds
|
||||
PORTVERSION= 20050625
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= http://modeemi.fi/~tuomov/ion/dl/
|
||||
|
||||
MAINTAINER= ed@fxq.nl
|
||||
COMMENT= The development version of the Ion window manager
|
||||
|
||||
LIB_DEPENDS= lua.5:${PORTSDIR}/lang/lua
|
||||
RUN_DEPENDS= run-mailcap:${PORTSDIR}/misc/mime-support
|
||||
|
||||
CONFLICTS= ion-2002* pwm-* ion-2*
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
MAKE_ENV= DEFINES="${IONDEFINES}"
|
||||
|
||||
.if !defined(WITH_XINERAMA)
|
||||
IONDEFINES+= -DCF_NO_XINERAMA
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_NLS)
|
||||
IONDEFINES+= -DCF_NO_LOCALE
|
||||
.endif
|
||||
|
||||
MAN1= ion3.1 pwm3.1
|
||||
DOCSDIR= share/doc/ion3
|
||||
|
||||
# NO, I don't want to use configure but ion's author system.mk
|
||||
do-configure:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
IGNORE= needs wide character string functions in libc
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
2
x11-wm/ion-3ds/distinfo
Normal file
2
x11-wm/ion-3ds/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (ion-3ds-20050625.tar.gz) = 5eba98afb32ce8448698a84ca9f2f960
|
||||
SIZE (ion-3ds-20050625.tar.gz) = 583363
|
11
x11-wm/ion-3ds/files/patch-load
Normal file
11
x11-wm/ion-3ds/files/patch-load
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- mod_statusbar/ion-statusd/statusd_load.lua.orig Sat Jun 25 17:13:32 2005
|
||||
+++ mod_statusbar/ion-statusd/statusd_load.lua Mon Jul 4 01:22:09 2005
|
||||
@@ -46,7 +46,7 @@
|
||||
end
|
||||
local s=f:read('*l')
|
||||
f:close()
|
||||
- local st, en, load=string.find(s, 'load average:%s*(.*)')
|
||||
+ local st, en, load=string.find(s, 'load averages?:%s*(.*)')
|
||||
return (load or "")
|
||||
end
|
||||
|
96
x11-wm/ion-3ds/files/patch-system.mk
Normal file
96
x11-wm/ion-3ds/files/patch-system.mk
Normal file
|
@ -0,0 +1,96 @@
|
|||
--- system.mk.orig Sat Jun 25 17:13:43 2005
|
||||
+++ system.mk Sat Jul 16 18:56:28 2005
|
||||
@@ -7,7 +7,7 @@
|
||||
## Installation paths
|
||||
##
|
||||
|
||||
-PREFIX=/usr/local
|
||||
+#PREFIX=/usr/local
|
||||
|
||||
# Unless you are creating a package conforming to some OS's standards, you
|
||||
# probably do not want to modify the following directories:
|
||||
@@ -19,7 +19,7 @@
|
||||
# Some .lua files and ion-* shell scripts
|
||||
SHAREDIR=$(PREFIX)/share/ion3
|
||||
# Manual pages
|
||||
-MANDIR=$(PREFIX)/share/man
|
||||
+MANDIR=$(MANPREFIX)/man
|
||||
# Some documents
|
||||
DOCDIR=$(PREFIX)/share/doc/ion3
|
||||
# Nothing at the moment
|
||||
@@ -47,7 +47,7 @@
|
||||
#PRELOAD_MODULES=1
|
||||
|
||||
# Flags to link with libdl.
|
||||
-DL_LIBS=-ldl
|
||||
+#DL_LIBS=-ldl
|
||||
|
||||
|
||||
##
|
||||
@@ -56,7 +56,7 @@
|
||||
|
||||
# If you have installed Lua 5.0 from the official tarball without changing
|
||||
# paths, this should do it.
|
||||
-LUA_DIR=/usr/local
|
||||
+LUA_DIR=$(LOCALBASE)
|
||||
LUA_LIBS = -L$(LUA_DIR)/lib -llua -llualib
|
||||
LUA_INCLUDES = -I$(LUA_DIR)/include
|
||||
LUA=$(LUA_DIR)/bin/lua
|
||||
@@ -74,7 +74,7 @@
|
||||
## X libraries, includes and options
|
||||
##
|
||||
|
||||
-X11_PREFIX=/usr/X11R6
|
||||
+X11_PREFIX=$(X11BASE)
|
||||
# SunOS/Solaris
|
||||
#X11_PREFIX=/usr/openwin
|
||||
|
||||
@@ -107,7 +107,7 @@
|
||||
# asprintf and vasprintf in the c library. (gnu libc has.)
|
||||
# If HAS_SYSTEM_ASPRINTF is not defined, an implementation
|
||||
# in sprintf_2.2/ is used.
|
||||
-#HAS_SYSTEM_ASPRINTF=1
|
||||
+HAS_SYSTEM_ASPRINTF=1
|
||||
|
||||
|
||||
# If you're on an archaic system (such as relatively recent *BSD releases)
|
||||
@@ -116,24 +116,24 @@
|
||||
#DEFINES += -DCF_NO_LOCALE
|
||||
|
||||
# On some other systems you may something like this:
|
||||
-#EXTRA_LIBS += -lintl
|
||||
-#EXTRA_INCLUDES +=
|
||||
+EXTRA_LIBS += -L$(LOCALBASE)/lib -lintl
|
||||
+EXTRA_INCLUDES += -I$(LOCALBASE)/include
|
||||
|
||||
|
||||
##
|
||||
## C compiler
|
||||
##
|
||||
|
||||
-CC=gcc
|
||||
+CC?=gcc
|
||||
|
||||
# Same as '-Wall -pedantic' without '-Wunused' as callbacks often
|
||||
# have unused variables.
|
||||
WARN= -W -Wimplicit -Wreturn-type -Wswitch -Wcomment \
|
||||
-Wtrigraphs -Wformat -Wchar-subscripts \
|
||||
- -Wparentheses -pedantic -Wuninitialized
|
||||
+ -Wparentheses
|
||||
|
||||
-CFLAGS=-g -Os $(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
|
||||
-LDFLAGS=-g -Os $(EXTRA_LIBS) $(LIBS)
|
||||
+CFLAGS=$(WARN) $(DEFINES) $(EXTRA_INCLUDES) $(INCLUDES)
|
||||
+LDFLAGS=$(EXTRA_LIBS) $(LIBS)
|
||||
EXPORT_DYNAMIC=-Xlinker --export-dynamic
|
||||
|
||||
# The following options are mainly for development use and can be used
|
||||
@@ -147,7 +147,7 @@
|
||||
#POSIX_SOURCE=-D_POSIX_SOURCE
|
||||
|
||||
# Most systems
|
||||
-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
|
||||
+XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
|
||||
# SunOS, (Irix)
|
||||
#XOPEN_SOURCE=-D__EXTENSIONS__
|
||||
|
20
x11-wm/ion-3ds/pkg-descr
Normal file
20
x11-wm/ion-3ds/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
|||
Ion (based on PWM) is a new kind of window manager that brings a
|
||||
text-editorish, keyboard friendly user interface to window management.
|
||||
|
||||
Modern GUIs are unusable. Overlapping windows are hard to manage, especially
|
||||
from the keyboard, and the user often ends up in a jungle. Not to mention the
|
||||
application programs, which are even worse. Mouse-based search-and-click
|
||||
interfaces are slow - keyboard is fast having learnt the commands. Ion (the
|
||||
last three letters of vision =-) was written as an example and an experiment of
|
||||
something presumably better (just the window manager, though).
|
||||
|
||||
Ion simply divides the screen into frames that take the whole screen. Big
|
||||
displays have so much space that this is convenient and smaller displays
|
||||
couldn't show more than one window at a time anyway. The frames can be split
|
||||
and growing the size of one will shrink others. Alike in PWM, clients can be
|
||||
moved between frames and multiple clients can be attached to one frame.
|
||||
|
||||
With Ion you will hardly ever have to touch the mouse again for navigation
|
||||
between windows and the windows are always in order.
|
||||
|
||||
WWW: http://modeemi.cs.tut.fi/~tuomov/ion/
|
86
x11-wm/ion-3ds/pkg-plist
Normal file
86
x11-wm/ion-3ds/pkg-plist
Normal file
|
@ -0,0 +1,86 @@
|
|||
bin/ion3
|
||||
bin/pwm3
|
||||
etc/ion3/cfg_bindings.lua
|
||||
etc/ion3/cfg_dock.lua
|
||||
etc/ion3/cfg_floatws.lua
|
||||
etc/ion3/cfg_ion.lua
|
||||
etc/ion3/cfg_ionws.lua
|
||||
etc/ion3/cfg_kludges.lua
|
||||
etc/ion3/cfg_menu.lua
|
||||
etc/ion3/cfg_menus.lua
|
||||
etc/ion3/cfg_panews.lua
|
||||
etc/ion3/cfg_pwm.lua
|
||||
etc/ion3/cfg_pwm_bindings.lua
|
||||
etc/ion3/cfg_pwm_menus.lua
|
||||
etc/ion3/cfg_query.lua
|
||||
etc/ion3/cfg_sp.lua
|
||||
etc/ion3/cfg_statusbar.lua
|
||||
etc/ion3/dock-draw.lua
|
||||
etc/ion3/look.lua
|
||||
etc/ion3/look_brownsteel.lua
|
||||
etc/ion3/look_clean.lua
|
||||
etc/ion3/look_cleanios.lua
|
||||
etc/ion3/look_cleanviolet.lua
|
||||
etc/ion3/look_dusky.lua
|
||||
etc/ion3/look_greyviolet.lua
|
||||
etc/ion3/look_ios.lua
|
||||
etc/ion3/look_simpleblue.lua
|
||||
etc/ion3/look_wheat2.lua
|
||||
etc/ion3/lookcommon_clean.lua
|
||||
etc/ion3/lookcommon_emboss.lua
|
||||
lib/ion3/bin/ion-completefile
|
||||
lib/ion3/bin/ion-statusd
|
||||
lib/ion3/lc/de.lc
|
||||
lib/ion3/lc/ext_statusbar.lc
|
||||
lib/ion3/lc/ioncore_bindings.lc
|
||||
lib/ion3/lc/ioncore_efbb.lc
|
||||
lib/ion3/lc/ioncore_ext.lc
|
||||
lib/ion3/lc/ioncore_luaext.lc
|
||||
lib/ion3/lc/ioncore_misc.lc
|
||||
lib/ion3/lc/ioncore_wd.lc
|
||||
lib/ion3/lc/ioncore_winprops.lc
|
||||
lib/ion3/lc/mod_dock.lc
|
||||
lib/ion3/lc/mod_floatws.lc
|
||||
lib/ion3/lc/mod_ionws.lc
|
||||
lib/ion3/lc/mod_menu.lc
|
||||
lib/ion3/lc/mod_mgmtmode.lc
|
||||
lib/ion3/lc/mod_panews.lc
|
||||
lib/ion3/lc/mod_query.lc
|
||||
lib/ion3/lc/mod_query_chdir.lc
|
||||
lib/ion3/lc/mod_sm.lc
|
||||
lib/ion3/lc/mod_sp.lc
|
||||
lib/ion3/lc/mod_statusbar.lc
|
||||
lib/ion3/lc/statusd_date.lc
|
||||
lib/ion3/lc/statusd_load.lc
|
||||
lib/ion3/lc/statusd_mail.lc
|
||||
lib/ion3/mod/de.so
|
||||
lib/ion3/mod/mod_dock.so
|
||||
lib/ion3/mod/mod_floatws.so
|
||||
lib/ion3/mod/mod_ionws.so
|
||||
lib/ion3/mod/mod_menu.so
|
||||
lib/ion3/mod/mod_mgmtmode.so
|
||||
lib/ion3/mod/mod_panews.so
|
||||
lib/ion3/mod/mod_query.so
|
||||
lib/ion3/mod/mod_sm.so
|
||||
lib/ion3/mod/mod_sp.so
|
||||
lib/ion3/mod/mod_statusbar.so
|
||||
share/doc/ion3/ChangeLog
|
||||
share/doc/ion3/LICENSE
|
||||
share/doc/ion3/README
|
||||
share/doc/ion3/RELNOTES
|
||||
share/ion3/ion-completeman
|
||||
share/ion3/ion-runinxterm
|
||||
share/ion3/welcome.cs.txt
|
||||
share/ion3/welcome.de.txt
|
||||
share/ion3/welcome.fi.txt
|
||||
share/ion3/welcome.txt
|
||||
share/locale/cs/LC_MESSAGES/ion3.mo
|
||||
share/locale/de/LC_MESSAGES/ion3.mo
|
||||
share/locale/fi/LC_MESSAGES/ion3.mo
|
||||
@dirrm lib/ion3/bin
|
||||
@dirrm lib/ion3/lc
|
||||
@dirrm lib/ion3/mod
|
||||
@dirrm lib/ion3
|
||||
@dirrm share/ion3
|
||||
@dirrm share/doc/ion3
|
||||
@unexec rmdir %D/etc/ion3 2>/dev/null || true
|
Loading…
Reference in a new issue