Okay, here's a Perl 5.00503-friendly version.
This commit is contained in:
parent
d844b23ecd
commit
2c6ade3eb4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112527
3 changed files with 63 additions and 3 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= Time-Human
|
||||
PORTVERSION= 1.02
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= textproc perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Time
|
||||
|
@ -22,7 +23,7 @@ MAN3= Time::Human.3
|
|||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500600
|
||||
BROKEN= Does not build with Perl 5.005.
|
||||
EXTRA_PATCHES+= ${PATCHDIR}/Human.pm-5005.patch
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
59
textproc/p5-Time-Human/files/Human.pm-5005.patch
Normal file
59
textproc/p5-Time-Human/files/Human.pm-5005.patch
Normal file
|
@ -0,0 +1,59 @@
|
|||
--- Human.pm.orig Thu May 30 14:01:27 2002
|
||||
+++ Human.pm Tue Jun 29 11:52:35 2004
|
||||
@@ -1,12 +1,15 @@
|
||||
+#!/usr/bin/perl -w
|
||||
+
|
||||
package Time::Human;
|
||||
|
||||
-require 5.005_62;
|
||||
+require 5.005_03;
|
||||
use strict;
|
||||
-use warnings;
|
||||
|
||||
require Exporter;
|
||||
|
||||
-our @ISA = qw(Exporter);
|
||||
+use vars qw/@ISA $VERSION %EXPORT_TAGS @EXPORT_OK @EXPORT
|
||||
+ %templates $Language $Evening $Night/;
|
||||
+@ISA = qw(Exporter);
|
||||
|
||||
# Items to export into callers namespace by default. Note: do not export
|
||||
# names by default without a very good reason. Use EXPORT_OK instead.
|
||||
@@ -15,19 +18,19 @@
|
||||
# This allows declaration use Time::Human ':all';
|
||||
# If you do not need this, moving things directly into @EXPORT or @EXPORT_OK
|
||||
# will save memory.
|
||||
-our %EXPORT_TAGS = ( 'all' => [ qw(
|
||||
+%EXPORT_TAGS = ( 'all' => [ qw(
|
||||
humantime
|
||||
) ] );
|
||||
|
||||
-our @EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
|
||||
+@EXPORT_OK = ( @{ $EXPORT_TAGS{'all'} } );
|
||||
|
||||
-our @EXPORT = qw(
|
||||
+@EXPORT = qw(
|
||||
humanize
|
||||
|
||||
);
|
||||
-our $VERSION = '1.02';
|
||||
+$VERSION = '1.02';
|
||||
|
||||
-our %templates = (
|
||||
+%templates = (
|
||||
|
||||
English => {
|
||||
numbers => [ qw(one two three four five six seven eight nine ten eleven twelve) ],
|
||||
@@ -43,9 +46,9 @@
|
||||
}
|
||||
);
|
||||
|
||||
-our $Language = "English";
|
||||
-our $Evening = 18;
|
||||
-our $Night = 22;
|
||||
+$Language = "English";
|
||||
+$Evening = 18;
|
||||
+$Night = 22;
|
||||
|
||||
# Preloaded methods go here.
|
||||
|
|
@ -1,5 +1,5 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Human/.packlist
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time/Human
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Time
|
||||
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Time 2>/dev/null || true
|
||||
%%SITE_PERL%%/Time/Human.pm
|
||||
@dirrm %%SITE_PERL%%/Time
|
||||
@unexec rmdir %D/%%SITE_PERL%%/Time 2>/dev/null || true
|
||||
|
|
Loading…
Reference in a new issue