Update to latest version.

Add option to enable PF support

PR:	ports/151394
Submitted by:	Eric F Crist <ecrist@secure-computing.net>
Approved by:	Maintainer (Tor Halvard Furulund <squat@squat.no>)
Sponsored by:	ClaimLynx, Inc
This commit is contained in:
Josh Paetzel 2010-10-12 14:29:11 +00:00
parent 7ebaa7f5d7
commit 2c88af2d64
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=262898
3 changed files with 22 additions and 4 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= miniupnpd
PORTVERSION= 1.4.20100511
PORTVERSION= 1.4.20100921
CATEGORIES= net
MASTER_SITES= http://miniupnp.tuxfamily.org/files/ \
http://miniupnp.free.fr/files/
@ -25,6 +25,13 @@ MAN8= miniupnpd.8
USE_RC_SUBR= miniupnpd.sh
OPTIONS= PF_ENABLE_FILTER_RULES "Enable pf generation of filter rules" off \
.include <bsd.port.options.mk>
.if defined(WITH_PF_ENABLE_FILTER_RULES)
EXTRA_PATCHES= ${PATCHDIR}/pf_enable_filter_rules.patch
.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/miniupnpd ${PREFIX}/sbin/miniupnpd
@${INSTALL_DATA} ${WRKDIR}/miniupnpd.conf.sample ${PREFIX}/etc/miniupnpd.conf.sample

View file

@ -1,3 +1,3 @@
MD5 (miniupnpd-1.4.20100511.tar.gz) = fa3491d4de8dbfdee55dc7ff7f0b2b3c
SHA256 (miniupnpd-1.4.20100511.tar.gz) = 1fce907ecaeb49d8a58524c000536a6b6e79789a952e137c9141d50936ea4f0a
SIZE (miniupnpd-1.4.20100511.tar.gz) = 93281
MD5 (miniupnpd-1.4.20100921.tar.gz) = 8840fefae59ad3859f9212dcd780d3bf
SHA256 (miniupnpd-1.4.20100921.tar.gz) = 4f974a123866819c968bcf2162067a59d6b9776bb77d543cc183f3e357084526
SIZE (miniupnpd-1.4.20100921.tar.gz) = 95483

View file

@ -0,0 +1,11 @@
--- work/miniupnpd-1.4.20100921/genconfig.sh 2010-09-21 10:36:12.000000000 -0500
+++ genconfig.sh 2010-10-11 10:23:44.000000000 -0500
@@ -209,7 +209,7 @@
echo "/* Uncomment the following line to enable generation of" >> ${CONFIGFILE}
echo " * filter rules with pf */" >> ${CONFIGFILE}
-echo "/*#define PF_ENABLE_FILTER_RULES*/">> ${CONFIGFILE}
+echo "#define PF_ENABLE_FILTER_RULES">> ${CONFIGFILE}
echo "" >> ${CONFIGFILE}
echo "/* Uncomment the following line to enable caching of results of" >> ${CONFIGFILE}