Update to version 2.4d7.

PR:		25222
Submitted by:	Bernd Luevelsmeyer <bdluevel@heitec.net>
This commit is contained in:
Steve Price 2001-02-26 05:00:12 +00:00
parent 86735d2cda
commit 2ca9383e73
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38767
8 changed files with 76 additions and 58 deletions

View file

@ -6,10 +6,10 @@
#
PORTNAME= xitami
PORTVERSION= 2.3d
PORTVERSION= 2.4d7
CATEGORIES= www
MASTER_SITES= http://www.imatix.com/pub/xitami/
DISTNAME= xiuni23d
MASTER_SITES= http://users.skynet.be/sky37432/
DISTNAME= suni24d7
EXTRACT_SUFX= .tgz
MAINTAINER= i.vaudrey@cableinet.co.uk
@ -24,18 +24,18 @@ do-install:
@${MKDIR} ${PREFIX}/xitami/cgi-bin
@${MKDIR} ${PREFIX}/xitami/webpages
@${CAT} ${FILESDIR}/defaults.cfg.tmpl | ${SED} s:PREFIX:${PREFIX}: > ${WRKDIR}/defaults.cfg
@${INSTALL_DATA} ${WRKDIR}/defaults.cfg ${PREFIX}/xitami
@${INSTALL_DATA} ${WRKDIR}/defaults.cfg ${PREFIX}/xitami/defaults.cfg.sample
@${INSTALL_DATA} ${FILESDIR}/xitami.aut ${PREFIX}/xitami
@${CHMOD} u+w ${PREFIX}/xitami/*
@${INSTALL_DATA} ${WRKSRC}/src/smt/xitami.cfg ${PREFIX}/xitami
@${INSTALL_PROGRAM} ${WRKSRC}/src/smt/xitami ${PREFIX}/xitami
@${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/testcgi ${PREFIX}/xitami/cgi-bin
@${CAT} ${FILESDIR}/xitami.sh.tmpl | ${SED} s:PREFIX:${PREFIX}: > ${WRKDIR}/xitami.sh
@${INSTALL_SCRIPT} ${WRKDIR}/xitami.sh ${PREFIX}/etc/rc.d
@${INSTALL_SCRIPT} ${WRKDIR}/xitami.sh ${PREFIX}/etc/rc.d/xitami.sh.sample
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xitami/html
@${INSTALL_MAN} ${WRKSRC}/webpages/xitami/* ${PREFIX}/share/doc/xitami/html
@${INSTALL_MAN} ${FILESDIR}/default.html ${PREFIX}/xitami/webpages
@${INSTALL_MAN} ${FILESDIR}/default.html ${PREFIX}/xitami/webpages/default.html.sample
.endif
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (xiuni23d.tgz) = aa5d9505d03241e89095e6b6bae744bb
MD5 (suni24d7.tgz) = 5240c334ebc993be8847c8af7c64e9fe

View file

@ -1,5 +1,5 @@
--- xibuild.orig Sat Aug 8 15:42:27 1998
+++ xibuild Sat Aug 8 15:44:23 1998
--- xibuild.original Tue Nov 7 09:32:29 2000
+++ xibuild Tue Nov 7 09:39:53 2000
@@ -8,7 +8,6 @@
# This script builds the SFL and SMT packages, then installs XITAMI ready
# for use. XITAMI is installed in the current directory.
@ -8,21 +8,19 @@
SRCDIR=$TOPDIR/src
SFLDIR=$TOPDIR/src/sfl
SMTDIR=$TOPDIR/src/smt
@@ -52,18 +51,13 @@
echo "--------------------------------------------------------------------"
echo "Welcome to the Xitami web server, copyright (c) 1991-97 iMatix."
@@ -53,17 +52,12 @@
echo "Welcome to the Xitami web server, copyright (c) 1991-99 iMatix."
echo "This script will compile and link XITAMI, ready for use on this"
-echo "$SYSTEM system. Please confirm this information:"
+echo "$SYSTEM system."
echo "$SYSTEM system. Nothing is installed in any system directories."
-echo "Please confirm this information:"
echo " System . . . . . .: $SYSTEM"
echo " ANSI C compiler. .: $COMPILE"
echo ""
-echo "If the ANSI C compile command is wrong, you will have to modify the"
-echo "'c' scripts in these directories:"
-echo " $SFLDIR"
-echo " $SMTDIR"
-echo " $SFLDIR, $SMTDIR"
-echo ""
-echo "If this information looks okay, press [Enter] to start installation."
-echo "If this information looks okay, press [Enter] to build Xitami."
+echo " SFL Source Path...: $SFLDIR"
+echo " SMT Source Path...: $SMTDIR"
echo "--------------------------------------------------------------------"
@ -30,7 +28,7 @@
# Now, rebuild the SFL package
@@ -103,14 +97,4 @@
@@ -103,18 +97,4 @@
fi
cd $TOPDIR
@ -41,8 +39,12 @@
-cp $CGISRC/testcgi $CGIBIN
-cp $CGISRC/testcgi? $CGIBIN
-
-echo xibuild completed. Please see 'readme' file for info on using
-echo Xitami. The Xitami web pages are the main source of information.
-echo You can run Xitami now by typing 'xitami' or 'xitami -b 5000'.
-echo browser and the URL http://hostname or http://hostname:5080.
+echo xibuild completed.
-chmod +x xiconfig
-test ! -f defaults.cfg && ./xiconfig
-
-echo ""
-echo "xibuild completed. Please see 'readme' file for info on using"
-echo "Xitami. The Xitami web pages are the main source of information."
-echo "You can run Xitami now by typing 'xitami' or 'xitami -b 5000'."
-echo "browser and the URL http://hostname or http://hostname:5080."
+echo "xibuild completed."

View file

@ -1,21 +1,20 @@
--- src/smt/xitami.c.orig Sat Aug 8 15:48:29 1998
+++ src/smt/xitami.c Sat Aug 8 15:50:15 1998
@@ -163,13 +163,17 @@
--- src/smt/.vimbk/xitami.c.vimbk Sat Apr 1 18:11:39 2000
+++ src/smt/xitami.c Tue Nov 7 10:01:40 2000
@@ -168,7 +168,7 @@
fclose (stdout); /* Kill standard output */
fclose (stderr); /* and standard error */
}
- else
+ else if (*background == '0')
+ {
puts (COPYRIGHT);
+ }
if (*background == '1')
{
@@ -177,7 +177,7 @@
*background_args [] = { "-s", NULL };
puts ("Moving into the background");
process_server (NULL, NULL); /* Put process into background */
+ if (process_server (NULL, "/var/run/xitami.pid") != 0)
+ exit (EXIT_FAILURE);
}
/* Initialise SMT and run the HTTP agent until it has finished */
server_name = "Xitami";
- if (process_server (NULL, NULL, argc, argv, background_args) != 0)
+ if (process_server (NULL, "/var/run/xitami.pid", argc, argv, background_args) != 0)
{
puts ("Backgrounding failed. Giving up.");
exit (EXIT_FAILURE);

View file

@ -1,15 +1,15 @@
--- src/sfl/sflproc.c.orig Tue Sep 30 02:52:30 1997
+++ src/sfl/sflproc.c Sun Oct 12 18:39:01 1997
@@ -1021,8 +1021,6 @@
--- src/sfl/.vimbk/sflproc.c.vimbk Sat Apr 1 18:11:24 2000
+++ src/sfl/sflproc.c Tue Nov 7 11:29:34 2000
@@ -1711,8 +1711,6 @@
file_handle;
char
pid_buffer [10];
- struct flock
- lock_file; /* flock() argument block */
/* We recreate our process as a child of init. The process continues */
/* to exit in the background. UNIX calls wait() for all children of */
@@ -1065,17 +1063,21 @@
#endif
int
argi = 0, /* Input arguments iterator */
@@ -1787,17 +1785,21 @@
if (lockfile && strused (lockfile))
{
@ -37,4 +37,3 @@
+ sprintf (pid_buffer, "%ld\n", (long)getpid ());
write (file_handle, pid_buffer, strlen (pid_buffer));
}

18
www/xitami/files/patch-ad Normal file
View file

@ -0,0 +1,18 @@
--- src/sfl/.vimbk/prelude.h.vimbk Sat Apr 1 18:11:21 2000
+++ src/sfl/prelude.h Tue Nov 7 11:33:15 2000
@@ -532,12 +532,15 @@
# endif
#elif (defined (__UTYPE_BSDOS))
+# undef TIMEZONE
# define TIMEZONE 0 /* timezone is not available */
#elif (defined (__UTYPE_FREEBSD))
+# undef TIMEZONE
# define TIMEZONE 0 /* timezone is not available */
#elif (defined (__UTYPE_NETBSD))
+# undef TIMEZONE
# define TIMEZONE 0 /* timezone is not available */
#elif (defined (__VMS__))

View file

@ -7,6 +7,10 @@ then
rm /var/run/xitami.pid
fi
if [ x$2 != xDEINSTALL ]; then
exit
fi
echo "When pkg_delete has completed, you should examine ${PKG_PREFIX}/xitami"
echo "and it's subdirectories for content that you may wish to keep. Once you"
echo "have determined that it is safe to do so, you may nuke the entire tree"

View file

@ -1,8 +1,13 @@
etc/rc.d/xitami.sh
share/doc/xitami/html/horizon.gif
share/doc/xitami/html/im0096c.gif
etc/rc.d/xitami.sh.sample
share/doc/xitami/html/index.htm
share/doc/xitami/html/index1.htm
share/doc/xitami/html/index10.htm
share/doc/xitami/html/index11.htm
share/doc/xitami/html/index12.htm
share/doc/xitami/html/index13.htm
share/doc/xitami/html/index14.htm
share/doc/xitami/html/index15.htm
share/doc/xitami/html/index16.htm
share/doc/xitami/html/index2.htm
share/doc/xitami/html/index3.htm
share/doc/xitami/html/index4.htm
@ -11,22 +16,13 @@ share/doc/xitami/html/index6.htm
share/doc/xitami/html/index7.htm
share/doc/xitami/html/index8.htm
share/doc/xitami/html/index9.htm
share/doc/xitami/html/index10.htm
share/doc/xitami/html/index11.htm
share/doc/xitami/html/index12.htm
share/doc/xitami/html/index13.htm
share/doc/xitami/html/index14.htm
share/doc/xitami/html/index15.htm
share/doc/xitami/html/index16.htm
share/doc/xitami/html/license.htm
share/doc/xitami/html/newstone.gif
share/doc/xitami/html/xitami1.gif
xitami/defaults.cfg
xitami/cgi-bin/testcgi
xitami/defaults.cfg.sample
xitami/webpages/default.html.sample
xitami/xitami
xitami/xitami.aut
xitami/xitami.cfg
xitami/cgi-bin/testcgi
xitami/webpages/default.html
@dirrm share/doc/xitami/html
@dirrm share/doc/xitami
@unexec rmdir %D/xitami/webpages 2>/dev/null || true