Update to 0.07.13
PR: 215728 Submitted by: luca.pizzamiglio@gmail.com (maintainer) Approved by: jadawin (mentor) Differential Revision: https://reviews.freebsd.org/D9028
This commit is contained in:
parent
4b6360c05c
commit
2cb1bcf551
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=430471
4 changed files with 5 additions and 33 deletions
|
@ -1,7 +1,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= stress-ng
|
||||
PORTVERSION= 0.07.11
|
||||
PORTVERSION= 0.07.13
|
||||
CATEGORIES= benchmarks
|
||||
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/
|
||||
|
||||
|
@ -18,15 +18,8 @@ ALL_TARGET= # empty
|
|||
|
||||
PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 1000000
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-stress-cpu.h \
|
||||
${FILESDIR}/extrapatch-Makefile
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/stress-ng ${STAGEDIR}${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/stress-ng.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1482269395
|
||||
SHA256 (stress-ng-0.07.11.tar.gz) = cd75a64c585dc47e71641e4e654d7689ede0294b6beca7eec174a42462f57381
|
||||
SIZE (stress-ng-0.07.11.tar.gz) = 345544
|
||||
TIMESTAMP = 1483386553
|
||||
SHA256 (stress-ng-0.07.13.tar.gz) = 1fc8e60653ab75f288ce58b63ed162eedda2d5a2b254f0ad47ed6283deeddfe8
|
||||
SIZE (stress-ng-0.07.13.tar.gz) = 349935
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- Makefile.orig 2016-11-28 10:42:07.029535000 +0100
|
||||
+++ Makefile 2016-11-28 10:42:33.403489000 +0100
|
||||
@@ -392,7 +392,7 @@
|
||||
@$(CC) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
stress-ng: $(OBJS)
|
||||
- $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -lc -o $@
|
||||
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm -lstdc++ $(LDFLAGS) -lc -o $@
|
||||
|
||||
#
|
||||
# check if we can build against AppArmor
|
|
@ -1,10 +0,0 @@
|
|||
--- stress-ng.h.orig 2016-11-28 10:45:15.430051000 +0100
|
||||
+++ stress-ng.h 2016-11-28 10:45:25.621013000 +0100
|
||||
@@ -27,6 +27,7 @@
|
||||
#define __STRESS_NG_H__
|
||||
|
||||
#define _GNU_SOURCE
|
||||
+#define _DECLARE_C99_LDBL_MATH 1
|
||||
|
||||
#include <stdarg.h>
|
||||
#include <stdint.h>
|
Loading…
Reference in a new issue