The SASql SquirrelMail plugin lets users change a pre-defined set of
SpamAssassin settings when those settings are stored in a SQL DB rather than a config file. This is very useful in a virtual user setting when the users don't have home directories or access to them. WWW: http://www.squirrelmail.org PR: ports/106562 Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
This commit is contained in:
parent
8e250796f2
commit
2cc744a224
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179435
7 changed files with 163 additions and 0 deletions
|
@ -548,6 +548,7 @@
|
|||
SUBDIR += squirrelmail-pupdate-plugin
|
||||
SUBDIR += squirrelmail-qmailadmin_login-plugin
|
||||
SUBDIR += squirrelmail-quota_usage-plugin
|
||||
SUBDIR += squirrelmail-sasql-plugin
|
||||
SUBDIR += squirrelmail-secure_login-plugin
|
||||
SUBDIR += squirrelmail-timeout_user-plugin
|
||||
SUBDIR += squirrelmail-tmda-plugin
|
||||
|
|
79
mail/squirrelmail-sasql-plugin/Makefile
Normal file
79
mail/squirrelmail-sasql-plugin/Makefile
Normal file
|
@ -0,0 +1,79 @@
|
|||
# New ports collection makefile for: squirrelmail-sasql-plugin
|
||||
# Date created: 9 Dec 2006
|
||||
# Whom: Gerrit Beine <gerrit.beine@gmx.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= squirrelmail-${SQUIRREL_PLUGIN_NAME}-plugin
|
||||
PORTVERSION= 3.2.0
|
||||
CATEGORIES= mail www
|
||||
MASTER_SITES= http://www.squirrelmail.org/plugins/
|
||||
DISTNAME= ${SQUIRREL_PLUGIN_NAME}-${PORTVERSION}
|
||||
DIST_SUBDIR= squirrelmail
|
||||
|
||||
MAINTAINER= gerrit.beine@gmx.de
|
||||
COMMENT= Edit SpamAssassin settings stored in an SQL DB
|
||||
|
||||
RUN_DEPENDS= ${SQUIRRELDIR}/index.php:${PORTSDIR}/mail/squirrelmail \
|
||||
${SQUIRRELDIR}/plugins/compatibility:${PORTSDIR}/mail/squirrelmail-compatibility-plugin \
|
||||
${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB
|
||||
|
||||
SQUIRREL_PLUGIN_NAME= sasql
|
||||
|
||||
.ifdef SQUIRRELDIR
|
||||
PLIST_SUB+= SQUIRRELDIR=${SQUIRRELDIR}
|
||||
SUB_LIST+= "SQUIRRELDIR=${SQUIRRELDIR}"
|
||||
.else
|
||||
. ifndef WITHOUT_WWWDIR
|
||||
SQUIRRELDIR= ${PREFIX}/www/squirrelmail
|
||||
PLIST_SUB+= SQUIRRELDIR=www/squirrelmail
|
||||
SUB_LIST+= "SQUIRRELDIR=www/squirrelmail"
|
||||
. else
|
||||
SQUIRRELDIR= ${PREFIX}/squirrelmail
|
||||
PLIST_SUB+= SQUIRRELDIR=squirrelmail
|
||||
SUB_LIST+= "SQUIRRELDIR=squirrelmail"
|
||||
. endif
|
||||
.endif
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
NO_BUILD= yes
|
||||
NO_WRKSUBDIR= yes
|
||||
USE_PERL5_BUILD=yes
|
||||
USE_PHP= yes
|
||||
WANT_PHP_WEB= yes
|
||||
|
||||
pre-everything::
|
||||
@${ECHO} ""
|
||||
.ifndef WITHOUT_ACTIVATE
|
||||
@${ECHO} "Activating plug-in in SquirrelMail after installation."
|
||||
@${ECHO} "If you don't want to automatically activate the plug-in set"
|
||||
@${ECHO} "WITHOUT_ACTIVATE=yes"
|
||||
.else
|
||||
@${ECHO} "NOT Activating plug-in in SquirrelMail after installation."
|
||||
@${ECHO} "If you want to automatically activate the plug-in unset"
|
||||
@${ECHO} "WITHOUT_ACTIVATE"
|
||||
.endif
|
||||
@${ECHO} ""
|
||||
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/*.orig ${WRKSRC}/${SQUIRREL_PLUGIN_NAME}/.cvsignore
|
||||
|
||||
do-install:
|
||||
${CP} -rp ${WRKSRC}/${SQUIRREL_PLUGIN_NAME} ${SQUIRRELDIR}/plugins
|
||||
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${SQUIRRELDIR}/plugins/${SQUIRREL_PLUGIN_NAME}
|
||||
|
||||
post-install:
|
||||
.ifndef WITHOUT_ACTIVATE
|
||||
.if exists( ${SQUIRRELDIR}/config/config.php )
|
||||
@${ECHO} "Activating plug-in in SquirrelMail"
|
||||
${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}
|
||||
.endif
|
||||
.else
|
||||
@${ECHO} "To activate the plug-in in SquirrelMail use"
|
||||
@${ECHO} "${SQUIRRELDIR}/config/conf.pl --install-plugin ${SQUIRREL_PLUGIN_NAME}"
|
||||
.endif
|
||||
@${ECHO} ""
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
3
mail/squirrelmail-sasql-plugin/distinfo
Normal file
3
mail/squirrelmail-sasql-plugin/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (squirrelmail/sasql-3.2.0.tar.gz) = a492922e5b0d2245d4e9bc255a7c5755
|
||||
SHA256 (squirrelmail/sasql-3.2.0.tar.gz) = af4d0b37116a532b5a2398620ad7be4b914966e3957da1f2df51f968a1597a56
|
||||
SIZE (squirrelmail/sasql-3.2.0.tar.gz) = 41392
|
31
mail/squirrelmail-sasql-plugin/files/patch-sasql_hooks.php
Normal file
31
mail/squirrelmail-sasql-plugin/files/patch-sasql_hooks.php
Normal file
|
@ -0,0 +1,31 @@
|
|||
diff -Nur sasql.orig/sasql_hooks.php sasql/sasql_hooks.php
|
||||
--- sasql.orig/sasql_hooks.php 2006-11-09 21:29:21.000000000 +0100
|
||||
+++ sasql/sasql_hooks.php 2006-12-10 12:13:12.000000000 +0100
|
||||
@@ -74,23 +74,23 @@
|
||||
|
||||
if (!sqimap_mailbox_exists($imap_stream, $mailbox)) {
|
||||
sqimap_mailbox_create($imap_stream, $mailbox, '');
|
||||
- if ($imap_server_type == 'cyrus') {
|
||||
+ if ($imap_server_type == 'cyrus' || $imap_server_type == 'courier') {
|
||||
$boxes = sqimap_mailbox_list($imap_stream);
|
||||
} else {
|
||||
$boxes = sqimap_mailbox_list($imap_stream, true);
|
||||
}
|
||||
- session_register($boxes, 'boxesnew');
|
||||
+ sqsession_register($boxes, 'boxesnew');
|
||||
// echo "<foo sasql created: $box />";
|
||||
}
|
||||
|
||||
if (!sqimap_mailbox_is_subscribed($imap_stream, $mailbox)) {
|
||||
sqimap_subscribe($imap_stream, $mailbox);
|
||||
- if ($imap_server_type == 'cyrus') {
|
||||
+ if ($imap_server_type == 'cyrus' || $imap_server_type == 'courier') {
|
||||
$boxes = sqimap_mailbox_list($imap_stream);
|
||||
} else {
|
||||
$boxes = sqimap_mailbox_list($imap_stream, true);
|
||||
}
|
||||
- session_register($boxes, 'boxesnew');
|
||||
+ sqsession_register($boxes, 'boxesnew');
|
||||
// echo "<foo sasql subscried: $box />";
|
||||
}
|
||||
}
|
5
mail/squirrelmail-sasql-plugin/files/pkg-message.in
Normal file
5
mail/squirrelmail-sasql-plugin/files/pkg-message.in
Normal file
|
@ -0,0 +1,5 @@
|
|||
For the port to work properly you must copy the file
|
||||
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php.dist
|
||||
to
|
||||
%%PREFIX%%/%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php
|
||||
and edit the configuration to meet your needs.
|
6
mail/squirrelmail-sasql-plugin/pkg-descr
Normal file
6
mail/squirrelmail-sasql-plugin/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
The SASql SquirrelMail plugin lets users change a pre-defined set of
|
||||
SpamAssassin settings when those settings are stored in a SQL DB rather than
|
||||
a config file. This is very useful in a virtual user setting when the users
|
||||
don't have home directories or access to them.
|
||||
|
||||
WWW: http://www.squirrelmail.org
|
38
mail/squirrelmail-sasql-plugin/pkg-plist
Normal file
38
mail/squirrelmail-sasql-plugin/pkg-plist
Normal file
|
@ -0,0 +1,38 @@
|
|||
@unexec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --remove-plugin sasql; fi
|
||||
%%SQUIRRELDIR%%/plugins/sasql/contrib/README
|
||||
%%SQUIRRELDIR%%/plugins/sasql/contrib/adodb.patch
|
||||
%%SQUIRRELDIR%%/plugins/sasql/contrib/xgetpo
|
||||
%%SQUIRRELDIR%%/plugins/sasql/README
|
||||
%%SQUIRRELDIR%%/plugins/sasql/README.dspam
|
||||
%%SQUIRRELDIR%%/plugins/sasql/README.policyd
|
||||
%%SQUIRRELDIR%%/plugins/sasql/TODO
|
||||
%%SQUIRRELDIR%%/plugins/sasql/bayes_stats.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/divider.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/dspam.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/dspam_conf.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/dspam_primer.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/end_section.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/index.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/move_to.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/policyd.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/policyd_conf-dist.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/policyd_docs.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/process-spam.pl
|
||||
%%SQUIRRELDIR%%/plugins/sasql/purge.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sa_abooksync.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sa_opts-dist.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sa_settings.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sa_whitelist.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql.pot
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql_api.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql_conf.php.dist
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql_db.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql_hooks.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql_options.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/sasql_wblist.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/setup.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/start_section.inc.php
|
||||
%%SQUIRRELDIR%%/plugins/sasql/version
|
||||
@dirrm %%SQUIRRELDIR%%/plugins/sasql/contrib
|
||||
@dirrm %%SQUIRRELDIR%%/plugins/sasql/
|
||||
@exec if [ -f %D/%%SQUIRRELDIR%%/config/config.php ]; then %D/%%SQUIRRELDIR%%/config/conf.pl --install-plugin sasql; fi
|
Loading…
Reference in a new issue