Update to 3.5

Allow building with postgresql client only installation.

PR:             71212
Submitted by:   Palle Girgensohn <girgen@pingpong.net>
This commit is contained in:
Tilman Keskinoz 2004-09-02 15:58:33 +00:00
parent 51f2c79e0a
commit 2cdc9fb6dc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117948
4 changed files with 28 additions and 18 deletions

View file

@ -6,8 +6,7 @@
#
PORTNAME= PyGreSQL
PORTVERSION= 3.4
PORTREVISION= 1
PORTVERSION= 3.5
PORTEPOCH= 1
CATEGORIES= databases python
MASTER_SITES= ftp://ftp.pygresql.org/pub/distrib/
@ -15,7 +14,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
MAINTAINER= girgen@pingpong.net
COMMENT= A Python interface to PostgreSQL, both classic interface and DP-API 2.0
COMMENT= A Python interface to PostgreSQL, both classic and DP-API 2.0
BUILD_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base
RUN_DEPENDS= ${DATETIME_DEP}:${PORTSDIR}/lang/py-mx-base

View file

@ -1,2 +1,2 @@
MD5 (PyGreSQL-3.4.tgz) = 3cd6e4b689a339748261fa714a8fcd6c
SIZE (PyGreSQL-3.4.tgz) = 33266
MD5 (PyGreSQL-3.5.tgz) = aec4cc8600af25b1fe895f2ee6cd9801
SIZE (PyGreSQL-3.5.tgz) = 44884

View file

@ -0,0 +1,24 @@
--- pgmodule.c~ Tue Jan 13 13:29:57 2004
+++ pgmodule.c Sat Aug 28 16:41:56 2004
@@ -27,10 +27,19 @@
*/
#include <Python.h>
-#include "postgres.h"
+
+/* defines snatched from "catalog/pg_type.h" */
+#define INT2OID 21
+#define INT4OID 23
+#define INT8OID 20
+#define OIDOID 26
+#define FLOAT4OID 700
+#define FLOAT8OID 701
+#define NUMERICOID 1700
+#define CASHOID 790
+
#include "libpq-fe.h"
#include "libpq/libpq-fs.h"
-#include "catalog/pg_type.h"
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

View file

@ -1,13 +0,0 @@
--- setup.py~ Tue Jan 13 13:29:57 2004
+++ setup.py Tue Jan 13 16:14:50 2004
@@ -30,8 +30,8 @@
optional_libs=[ 'libpqdll', 'wsock32', 'advapi32' ]
data_files = [ 'libpq.dll' ]
else:
- include_dirs=['/usr/include/pgsql']
- library_dirs=['/usr/lib/pgsql']
+ include_dirs=['%%LOCALBASE%%/include', '%%LOCALBASE%%/include/postgresql', '%%LOCALBASE%%/include/postgresql/server']
+ library_dirs=['%%LOCALBASE%%/lib']
optional_libs=['pq']
data_files = []