Update to 3.0.8:
http://www.caucho.com/resin-3.0/features/resin-3.0.8.xtp PR: ports/68002 Submitted by: maintainer
This commit is contained in:
parent
8aa66b085b
commit
2ce2081d2f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=112104
9 changed files with 25 additions and 46 deletions
|
@ -8,7 +8,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= resin
|
||||
PORTVERSION= 3.0.7
|
||||
PORTVERSION= 3.0.8
|
||||
CATEGORIES= www java
|
||||
MASTER_SITES= http://www.caucho.com/download/
|
||||
|
||||
|
@ -57,6 +57,8 @@ REPLACE_FILES= ${FILESDIR}/pkg-install \
|
|||
${FILESDIR}/resin.sh.in
|
||||
COPYDIRS= doc lib libexec webapps
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Pass JAVA_HOME as determined by bsd.java.mk
|
||||
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
|
||||
|
||||
|
@ -88,6 +90,14 @@ PLIST_SUB+= APACHE="@comment "
|
|||
PLIST_SUB+= APP_NAME=${APP_NAME}
|
||||
PLIST_SUB+= APXS=${APXS}
|
||||
|
||||
.if ((defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES)) \
|
||||
|| (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES)))
|
||||
LIBEXECDIR!= ${APXS} -q LIBEXECDIR
|
||||
SYSCONFDIR!= ${APXS} -q SYSCONFDIR
|
||||
CONFIGURE_ARGS+= --with-apache-libexec=${LIBEXECDIR}
|
||||
CONFIGURE_ARGS+= --with-apache-conf=${SYSCONFDIR}
|
||||
.endif
|
||||
|
||||
SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
|
||||
-e "s|%%APP_NAME%%|${APP_NAME}|g" \
|
||||
-e "s|%%APXS%%|${APXS}|g" \
|
||||
|
@ -106,8 +116,6 @@ SUBSTITUTIONS= -e "s|%%APP_HOME%%|${APP_HOME}|g" \
|
|||
-e "s|%%WRKDIR%%|${WRKDIR}|g" \
|
||||
-e "s|%%WRKSRC%%|${WRKSRC}|g"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
post-patch:
|
||||
.for FILE in ${REINPLACE_FILES}
|
||||
@${REINPLACE_CMD} ${SUBSTITUTIONS} ${FILE}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (resin-3.0.7.tar.gz) = 337043c5e20341409628002afa263cdd
|
||||
SIZE (resin-3.0.7.tar.gz) = 5332182
|
||||
MD5 (resin-3.0.8.tar.gz) = 30498b230b287d45ce914befdeaa0fee
|
||||
SIZE (resin-3.0.8.tar.gz) = 5757738
|
||||
|
|
|
@ -18,15 +18,15 @@ if test -e %%PREFIX%%/etc/%%APP_NAME%%/resin.xml && \
|
|||
else
|
||||
test -d %%PREFIX%%/etc/%%APP_NAME%% || mkdir %%PREFIX%%/etc/%%APP_NAME%%
|
||||
echo Created configuration directory %%PREFIX%%/etc/%%APP_NAME%%
|
||||
install %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
cp %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
fi
|
||||
|
||||
# Install new config file with '-dist' appended
|
||||
install %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml-dist
|
||||
cp %%WRKDIR%%/resin.conf %%PREFIX%%/etc/%%APP_NAME%%/resin.xml-dist
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%/resin.xml-dist
|
||||
|
||||
install %%WRKSRC%%/conf/app-default.xml %%PREFIX%%/etc/%%APP_NAME%%
|
||||
cp %%WRKSRC%%/conf/app-default.xml %%PREFIX%%/etc/%%APP_NAME%%
|
||||
echo Installed %%PREFIX%%/etc/%%APP_NAME%%/app-default.xml
|
||||
|
||||
install %%WRKDIR%%/resin.sh.in %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
--- src/c/plugin/apache/Makefile.in.orig Sun Mar 28 12:45:11 2004
|
||||
+++ src/c/plugin/apache/Makefile.in Sun Mar 28 12:47:59 2004
|
||||
@@ -29,8 +29,7 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.la *.so
|
|
@ -1,12 +0,0 @@
|
|||
--- src/c/plugin/apache2/Makefile.in.orig Thu Mar 25 01:29:07 2004
|
||||
+++ src/c/plugin/apache2/Makefile.in Sun Mar 28 12:52:01 2004
|
||||
@@ -30,8 +30,7 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -apache_dir $(apache_dir) \
|
||||
- -libexec $(apache_libexec) -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.so
|
|
@ -1,15 +1,6 @@
|
|||
--- conf/resin.conf.orig Thu Mar 25 01:28:47 2004
|
||||
+++ conf/resin.conf Sun Mar 28 13:07:28 2004
|
||||
@@ -67,7 +67,7 @@
|
||||
<keepalive-timeout>120s</keepalive-timeout>
|
||||
|
||||
<!-- The http port -->
|
||||
- <http id="" host="*" port="8080"/>
|
||||
+ <http id="" host="*" port="%%PORT%%"/>
|
||||
|
||||
<!--
|
||||
- SSL port configuration:
|
||||
@@ -148,7 +148,7 @@
|
||||
--- conf/resin.conf.orig Tue Jun 15 10:50:09 2004
|
||||
+++ conf/resin.conf Tue Jun 15 10:50:47 2004
|
||||
@@ -158,7 +158,7 @@
|
||||
- With another web server, like Apache, this can be commented out
|
||||
- because the web server will log this information.
|
||||
-->
|
||||
|
@ -18,7 +9,7 @@
|
|||
format='%h %l %u %t "%r" %s %b "%{Referer}i" "%{User-Agent}i"'
|
||||
rollover-period='1W'/>
|
||||
|
||||
@@ -176,7 +176,7 @@
|
||||
@@ -186,7 +186,7 @@
|
||||
</host-default>
|
||||
|
||||
<!-- includes the web-app-default for default web-app behavior -->
|
||||
|
|
|
@ -3,4 +3,6 @@ Resin is now installed in %%APP_HOME%%
|
|||
You may want to start it using the
|
||||
startup script installed as %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh and then point
|
||||
your web browser to the default home page at http://localhost:%%PORT%%/ to read
|
||||
the doc. Resin configuration is located at %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
the documentation and test the samples.
|
||||
|
||||
Resin configuration is located at %%PREFIX%%/etc/%%APP_NAME%%/resin.xml
|
||||
|
|
|
@ -22,6 +22,7 @@ ARGS="-conf $PREFIX/etc/%%APP_NAME%%/resin.xml \
|
|||
-pid %%PID_FILE%%"
|
||||
PATH=/usr/sbin:/usr/bin:/bin
|
||||
|
||||
unset CLASSPATH
|
||||
export JAVA_HOME=%%JAVA_HOME%%
|
||||
export RESIN_HOME=$PREFIX/%%APP_NAME%%
|
||||
|
||||
|
|
|
@ -7,6 +7,7 @@
|
|||
%%APP_NAME%%/lib/jstl-11.jar
|
||||
%%APP_NAME%%/lib/jta-101.jar
|
||||
%%APP_NAME%%/lib/license.jar
|
||||
%%APP_NAME%%/lib/portlet-10.jar
|
||||
%%APP_NAME%%/lib/resin.jar
|
||||
%%APP_NAME%%/lib/webutil.jar
|
||||
%%APP_NAME%%/webapps/resin-doc.war
|
||||
|
|
Loading…
Reference in a new issue