Update to upstream release 0.17.1; fix build on pre-10
PR: 206009 Submitted by: tobias.rehbein@web.de (maintainer) MFH: 2016Q1
This commit is contained in:
parent
327625af94
commit
2cf869b1c2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=405731
6 changed files with 35 additions and 36 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= stonesoup
|
||||
PORTVERSION= 0.16.2
|
||||
PORTVERSION= 0.17.1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/crawl-ref/Stone%20Soup/${PORTVERSION}
|
||||
MASTER_SITES= http://crawl.develz.org/release/
|
||||
|
@ -27,12 +27,10 @@ WRKSRC= ${WRKDIR}/stone_soup-${PORTVERSION}/source/
|
|||
SUB_FILES= README.FreeBSD
|
||||
PLIST_SUB= SAVEDIR="${SAVEDIR}"
|
||||
|
||||
# WIZARD is currently broken upstream, remove until fixed
|
||||
##OPTIONS_DEFINE= SOUND WIZARD LUA_BINDINGS DOCS EXAMPLES
|
||||
OPTIONS_DEFINE= SOUND LUA_BINDINGS DOCS EXAMPLES
|
||||
OPTIONS_DEFINE= SOUND WIZARD LUA_BINDINGS DOCS EXAMPLES
|
||||
|
||||
SOUND_DESC= Sound support
|
||||
##WIZARD_DESC= Wizard mode
|
||||
WIZARD_DESC= Wizard mode
|
||||
LUA_BINDINGS_DESC= Bindings for LUA user scripts
|
||||
|
||||
MAKE_ARGS= prefix=${PREFIX} \
|
||||
|
@ -51,9 +49,9 @@ MAKE_ARGS= prefix=${PREFIX} \
|
|||
MAKE_ARGS+= V=yes
|
||||
.endif
|
||||
|
||||
##.if empty(PORT_OPTIONS:MWIZARD)
|
||||
##MAKE_ARGS+= NOWIZARD=y
|
||||
##.endif
|
||||
.if empty(PORT_OPTIONS:MWIZARD)
|
||||
MAKE_ARGS+= NOWIZARD=y
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MSDL}
|
||||
CONFLICTS+= ${PORTNAME}-[0-9]*
|
||||
|
@ -88,6 +86,10 @@ MAKE_ARGS+= NO_LUA_BINDINGS=yes
|
|||
CFLAGS+= -D_GLIBCXX_USE_C99
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
|
||||
CFLAGS+= -std=c++11
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
# @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
|
||||
.if ${PORT_OPTIONS:MSOUND}
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (stone_soup-0.16.2-nodeps.tar.xz) = 26b4d968f858916254f2e49866da33c8f86d5617e38abd9b51813882dadc0179
|
||||
SIZE (stone_soup-0.16.2-nodeps.tar.xz) = 9252540
|
||||
SHA256 (stone_soup-0.17.1-nodeps.tar.xz) = 6314ea8229ec5b27804ff1788988bd110a16aadeb6b2f26660645c43ecfc49dd
|
||||
SIZE (stone_soup-0.17.1-nodeps.tar.xz) = 9114224
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- AppHdr.h.orig 2015-03-23 01:49:21 UTC
|
||||
--- AppHdr.h.orig 2015-10-31 04:31:32 UTC
|
||||
+++ AppHdr.h
|
||||
@@ -147,7 +147,7 @@ static inline double pow(int x, double y
|
||||
@@ -152,7 +152,7 @@ static inline double pow(int x, double y
|
||||
//
|
||||
// WARNING: Filenames passed to this command *are not validated in any way*.
|
||||
//
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- Makefile.orig 2015-03-23 01:49:21 UTC
|
||||
--- Makefile.orig 2015-12-08 12:42:11 UTC
|
||||
+++ Makefile
|
||||
@@ -71,7 +71,7 @@
|
||||
# them; you can also ask for a package with convenience libraries instead --
|
||||
|
@ -9,16 +9,16 @@
|
|||
|
||||
# Disable GNU Make implicit rules and variables. Leaving them enabled will slow
|
||||
# down MinGW and Cygwin builds by a very VERY noticeable degree. Besides, we have
|
||||
@@ -103,7 +103,7 @@ include Makefile.obj
|
||||
#
|
||||
|
||||
@@ -105,7 +105,7 @@ include Makefile.obj
|
||||
# Which C++ standard to support
|
||||
STDFLAG = -std=c++11
|
||||
|
||||
-CFOTHERS := -pipe $(EXTERNAL_FLAGS)
|
||||
+CFOTHERS := $(CFLAGS)
|
||||
CFWARN :=
|
||||
CFWARN_L := -Wall -Wformat-security -Wundef
|
||||
|
||||
@@ -112,7 +112,7 @@ DEFINES := $(EXTERNAL_DEFINES)
|
||||
@@ -114,7 +114,7 @@ DEFINES := $(EXTERNAL_DEFINES)
|
||||
ifdef ANDROID
|
||||
LDFLAGS := $(EXTERNAL_LDFLAGS) $(LDFLAGS)
|
||||
else
|
||||
|
@ -27,7 +27,7 @@
|
|||
endif
|
||||
|
||||
#
|
||||
@@ -120,8 +120,6 @@ endif
|
||||
@@ -122,8 +122,6 @@ endif
|
||||
#
|
||||
AR = ar
|
||||
RANLIB = ranlib
|
||||
|
@ -36,7 +36,7 @@
|
|||
RM = rm -f
|
||||
COPY = cp
|
||||
COPY_R = cp -r
|
||||
@@ -495,16 +493,6 @@ ifneq ($(GCC_VER),)
|
||||
@@ -512,16 +510,6 @@ ifneq ($(GCC_VER),)
|
||||
GCC_VER_SUFFIX:=-$(GCC_VER)
|
||||
endif
|
||||
|
||||
|
@ -52,8 +52,8 @@
|
|||
-
|
||||
ifneq ($(FORCE_CC),)
|
||||
GCC := $(FORCE_CC)
|
||||
else
|
||||
@@ -554,15 +542,6 @@ ifdef USE_ICC
|
||||
HOSTCC := $(FORCE_CC)
|
||||
@@ -575,15 +563,6 @@ ifdef USE_ICC
|
||||
|
||||
# Some very good optimization flags.
|
||||
CFOPTIMIZE := -O2 -parallel
|
||||
|
@ -69,7 +69,7 @@
|
|||
endif
|
||||
|
||||
ifdef LTO
|
||||
@@ -636,13 +615,13 @@ ifndef BUILD_LUA
|
||||
@@ -655,13 +634,13 @@ ifndef BUILD_LUA
|
||||
LUA_PACKAGE = lua-5.1
|
||||
endif
|
||||
else
|
||||
|
@ -85,7 +85,7 @@
|
|||
endif
|
||||
INCLUDES_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-I | sed -e 's/-I/-isystem /')
|
||||
CFLAGS_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-other)
|
||||
@@ -655,7 +634,7 @@ endif
|
||||
@@ -674,7 +653,7 @@ endif
|
||||
|
||||
ifndef BUILD_SQLITE
|
||||
ifeq ($(shell grep -q sqlite3_prepare $(SQLITE_INCLUDE_DIR)/sqlite3.h 2>/dev/null && echo yes),yes)
|
||||
|
@ -94,7 +94,7 @@
|
|||
LIBS += $(SQLITE_LIB)
|
||||
ifneq ($(shell grep -q sqlite3_prepare_v2 $(SQLITE_INCLUDE_DIR)/sqlite3.h 2>/dev/null && echo yes),yes)
|
||||
DEFINES_L += -DANCIENT_SQLITE
|
||||
@@ -743,7 +722,7 @@ endif
|
||||
@@ -762,7 +741,7 @@ endif
|
||||
endif
|
||||
|
||||
DEFINES_L += $(PNG_CFLAGS) $(FREETYPE_CFLAGS) $(SDL2_CFLAGS)
|
||||
|
@ -103,7 +103,7 @@
|
|||
|
||||
endif # TILES
|
||||
|
||||
@@ -816,7 +795,7 @@ ifndef NOWIZARD
|
||||
@@ -831,7 +810,7 @@ ifndef NOWIZARD
|
||||
DEFINES += -DWIZARD
|
||||
endif
|
||||
ifdef NO_OPTIMIZE
|
||||
|
@ -112,7 +112,7 @@
|
|||
endif
|
||||
|
||||
ifdef PCH
|
||||
@@ -943,7 +922,7 @@ else
|
||||
@@ -958,7 +937,7 @@ else
|
||||
SYS_PROPORTIONAL_FONT = $(shell { name=$(OUR_PROPORTIONAL_FONT);\
|
||||
{\
|
||||
fc-list | sed 's/: .*//' | grep -Fi "/$$name";\
|
||||
|
@ -121,7 +121,7 @@
|
|||
do [ -d $$dir ] && echo $$dir; done;\
|
||||
} | xargs -I% find % -type f -iname $$name -print | head -n1; } 2>/dev/null)
|
||||
ifneq (,$(SYS_PROPORTIONAL_FONT))
|
||||
@@ -968,7 +947,7 @@ else
|
||||
@@ -983,7 +962,7 @@ else
|
||||
SYS_MONOSPACED_FONT = $(shell { name=$(OUR_MONOSPACED_FONT);\
|
||||
{\
|
||||
fc-list | sed 's/: .*//' | grep -Fi "/$$name";\
|
||||
|
@ -130,7 +130,7 @@
|
|||
do [ -d $$dir ] && echo $$dir; done;\
|
||||
} | xargs -I% find % -type f -iname $$name -print | head -n1; } 2>/dev/null)
|
||||
ifneq (,$(SYS_MONOSPACED_FONT))
|
||||
@@ -1035,10 +1014,6 @@ CFWARN := -wd383,810,869,981,1418 -we14,
|
||||
@@ -1050,10 +1029,6 @@ CFWARN := -wd383,810,869,981,1418 -we14,
|
||||
CFWARN_L :=
|
||||
endif
|
||||
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
--- rltiles/Makefile.orig 2015-03-04 04:53:28 UTC
|
||||
--- rltiles/Makefile.orig 2015-12-15 18:50:32 UTC
|
||||
+++ rltiles/Makefile
|
||||
@@ -10,8 +10,6 @@ endif
|
||||
# Also, cross-compilation with no system libraries for host rather than target
|
||||
# is not supported. If host=target, contribs are enough.
|
||||
|
||||
-CFLAGS := -O2 -g -Wall -Wextra -Wno-parentheses -Wno-unused-parameter
|
||||
-CFLAGS := -O2 $(STDFLAG) -g -Wall -Wextra -Wno-parentheses -Wno-unused-parameter
|
||||
-
|
||||
ifdef ANDROID
|
||||
CXXFLAGS :=
|
||||
|
|
|
@ -80,6 +80,7 @@ bin/stonesoup
|
|||
%%DATADIR%%/dat/des/branches/vaults_rooms_hard.des
|
||||
%%DATADIR%%/dat/des/branches/vaults_rooms_standard.des
|
||||
%%DATADIR%%/dat/des/branches/zot.des
|
||||
%%DATADIR%%/dat/des/builder/alphashops.des
|
||||
%%DATADIR%%/dat/des/builder/arena.des
|
||||
%%DATADIR%%/dat/des/builder/decor.des
|
||||
%%DATADIR%%/dat/des/builder/dummy.des
|
||||
|
@ -125,7 +126,6 @@ bin/stonesoup
|
|||
%%DATADIR%%/dat/des/serial/ice.des
|
||||
%%DATADIR%%/dat/des/serial/magic_research.des
|
||||
%%DATADIR%%/dat/des/serial/park.des
|
||||
%%DATADIR%%/dat/des/serial/ponds.des
|
||||
%%DATADIR%%/dat/des/serial/serial_guide.txt
|
||||
%%DATADIR%%/dat/des/serial/sigils.des
|
||||
%%DATADIR%%/dat/des/serial/undead.des
|
||||
|
@ -142,7 +142,6 @@ bin/stonesoup
|
|||
%%DATADIR%%/dat/des/test.des
|
||||
%%DATADIR%%/dat/des/test/suite-los.des
|
||||
%%DATADIR%%/dat/des/test/suite.des
|
||||
%%DATADIR%%/dat/des/traps/beogh_trap.des
|
||||
%%DATADIR%%/dat/des/traps/boulders.des
|
||||
%%DATADIR%%/dat/des/traps/grate.des
|
||||
%%DATADIR%%/dat/des/traps/rats_trap.des
|
||||
|
@ -153,7 +152,6 @@ bin/stonesoup
|
|||
%%DATADIR%%/dat/des/tutorial/lesson4.des
|
||||
%%DATADIR%%/dat/des/tutorial/lesson5.des
|
||||
%%DATADIR%%/dat/des/variable/ambush.des
|
||||
%%DATADIR%%/dat/des/variable/ancient_champions.des
|
||||
%%DATADIR%%/dat/des/variable/arcadia.des
|
||||
%%DATADIR%%/dat/des/variable/cathedral_bats.des
|
||||
%%DATADIR%%/dat/des/variable/compat.des
|
||||
|
@ -167,7 +165,6 @@ bin/stonesoup
|
|||
%%DATADIR%%/dat/des/variable/mini.des
|
||||
%%DATADIR%%/dat/des/variable/mini_features.des
|
||||
%%DATADIR%%/dat/des/variable/mini_monsters.des
|
||||
%%DATADIR%%/dat/des/zotdef/zotdef.des
|
||||
%%DATADIR%%/dat/descript/ability.txt
|
||||
%%DATADIR%%/dat/descript/backgrounds.txt
|
||||
%%DATADIR%%/dat/descript/branches.txt
|
||||
|
@ -358,7 +355,6 @@ bin/stonesoup
|
|||
%%DATADIR%%/dat/descript/pl/gods.txt
|
||||
%%DATADIR%%/dat/descript/pl/hints.txt
|
||||
%%DATADIR%%/dat/descript/pl/items.txt
|
||||
%%DATADIR%%/dat/descript/pl/monsters.txt
|
||||
%%DATADIR%%/dat/descript/pl/quotes.txt
|
||||
%%DATADIR%%/dat/descript/pl/skills.txt
|
||||
%%DATADIR%%/dat/descript/pl/species.txt
|
||||
|
@ -537,6 +533,7 @@ bin/stonesoup
|
|||
%%DATADIR%%/docs/develop/android.txt
|
||||
%%DATADIR%%/docs/develop/coding_conventions.txt
|
||||
%%DATADIR%%/docs/develop/ctags.txt
|
||||
%%DATADIR%%/docs/develop/editor_tips.txt
|
||||
%%DATADIR%%/docs/develop/gdb_tips.txt
|
||||
%%DATADIR%%/docs/develop/levels/advanced.txt
|
||||
%%DATADIR%%/docs/develop/levels/introduction.txt
|
||||
|
@ -546,7 +543,6 @@ bin/stonesoup
|
|||
%%DATADIR%%/docs/develop/new_dev_checklist.txt
|
||||
%%DATADIR%%/docs/develop/patch_guide.txt
|
||||
%%DATADIR%%/docs/develop/process.txt
|
||||
%%DATADIR%%/docs/develop/release.txt
|
||||
%%DATADIR%%/docs/develop/save_compatibility.txt
|
||||
%%DATADIR%%/docs/develop/spells.txt
|
||||
%%DATADIR%%/docs/develop/testing.txt
|
||||
|
@ -568,6 +564,7 @@ bin/stonesoup
|
|||
%%DATADIR%%/settings/0.12_monster_glyphs.txt
|
||||
%%DATADIR%%/settings/0.13_monster_glyphs.txt
|
||||
%%DATADIR%%/settings/0.14_monster_glyphs.txt
|
||||
%%DATADIR%%/settings/0.16_monster_glyphs.txt
|
||||
%%DATADIR%%/settings/0.9_monster_glyphs.txt
|
||||
%%DATADIR%%/settings/034_command_keys.txt
|
||||
%%DATADIR%%/settings/034_monster_glyphs.txt
|
||||
|
|
Loading…
Reference in a new issue