New sgrep port. From the man page:
sgrep (structured grep) is a tool for searching text files and filtering text streams using structural criteria. The data model of sgrep is based on regions, which are non- empty substrings of text. Regions are typically occur- rences of constant strings or meaningful text elements, which are recognizable through some delimiting strings. PR: 6449 Submitted by: A Joseph Koshy <koshy@india.hp.com>
This commit is contained in:
parent
36ca7be718
commit
2d15f8c368
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10759
14 changed files with 160 additions and 0 deletions
23
textproc/sgrep/Makefile
Normal file
23
textproc/sgrep/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# New ports collection makefile for: sgrep
|
||||
# Version required: 0.99
|
||||
# Date created: Apr 29 1998
|
||||
# Whom: <koshy@india.hp.com>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= sgrep-0.99
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/
|
||||
|
||||
MAINTAINER= koshy@india.hp.com
|
||||
|
||||
MAN1= sgrep.1
|
||||
|
||||
# Override the install target in the supplied makefile
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sgrep ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/sgrep.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/sample.sgreprc ${PREFIX}/share/sgreprc
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/sgrep/distinfo
Normal file
1
textproc/sgrep/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (sgrep-0.99.tar.gz) = af09a90c4f1929bfae4818c8962a8907
|
30
textproc/sgrep/files/patch-aa
Normal file
30
textproc/sgrep/files/patch-aa
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- Makefile-- Wed Apr 29 12:08:55 1998
|
||||
+++ Makefile Wed Apr 29 12:20:29 1998
|
||||
@@ -10,11 +10,11 @@
|
||||
#
|
||||
|
||||
# This is where the executable goes
|
||||
-BINDIR = /usr/local/bin/
|
||||
+BINDIR = ${PREFIX}/bin
|
||||
# Where sgrep library files are placed (sgreprc)
|
||||
-LIBDIR = /usr/local/lib
|
||||
+LIBDIR = ${PREFIX}/share
|
||||
# Where the manual page goes
|
||||
-MANFILE = /usr/local/man/man1/sgrep.1
|
||||
+MANFILE = ${PREFIX}/man/man1/sgrep.1
|
||||
# Where the sample rc file goes
|
||||
RCFILE = $(LIBDIR)/sgreprc
|
||||
# If you can't install as root you might wan't to use this as rc file
|
||||
@@ -45,11 +45,7 @@
|
||||
clean:
|
||||
-rm -f $(OBJECTS)
|
||||
|
||||
-install: sgrep
|
||||
- cp sgrep $(BINDIR)/sgrep
|
||||
- chmod 755 $(BINDIR)/sgrep
|
||||
- cp sgrep.1 $(MANFILE)
|
||||
- chmod 644 $(MANFILE)
|
||||
+install:
|
||||
|
||||
install.rc: sample.sgreprc
|
||||
cp sample.sgreprc $(RCFILE)
|
11
textproc/sgrep/files/patch-ab
Normal file
11
textproc/sgrep/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- sgrep.1-- Wed Apr 29 12:26:40 1998
|
||||
+++ sgrep.1 Wed Apr 29 12:26:49 1998
|
||||
@@ -91,7 +91,7 @@
|
||||
\fB$HOME/.sgreprc,\fP
|
||||
or if it doesn't exist,
|
||||
from file
|
||||
-\fB/usr/lib/sgreprc, \fP
|
||||
+\fB/usr/local/share/sgreprc, \fP
|
||||
and then from the command line. Different behavior
|
||||
can be specified through command line options.
|
||||
.Pp
|
1
textproc/sgrep/pkg-comment
Normal file
1
textproc/sgrep/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A `grep' for structured text like SGML and HTML.
|
11
textproc/sgrep/pkg-descr
Normal file
11
textproc/sgrep/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
`sgrep' (structured grep) is a tool for searching text files and
|
||||
filtering text streams using structural criteria. Complex criteria
|
||||
can be specified as macros using M4.
|
||||
|
||||
Sgrep was created by:
|
||||
|
||||
Jani Jaakkola, email:Jani.Jaakkola@helsinki.fi
|
||||
Pekka Kilpelainen, email: Pekka.Kilpelainen@helsinki.fi
|
||||
|
||||
- Koshy
|
||||
<jkoshy@acm.org>
|
3
textproc/sgrep/pkg-plist
Normal file
3
textproc/sgrep/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/sgrep
|
||||
share/sgreprc
|
||||
man/man1/sgrep.1.gz
|
23
textproc/sgrep2/Makefile
Normal file
23
textproc/sgrep2/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# New ports collection makefile for: sgrep
|
||||
# Version required: 0.99
|
||||
# Date created: Apr 29 1998
|
||||
# Whom: <koshy@india.hp.com>
|
||||
#
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= sgrep-0.99
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.cs.helsinki.fi/pub/Software/Local/Sgrep/
|
||||
|
||||
MAINTAINER= koshy@india.hp.com
|
||||
|
||||
MAN1= sgrep.1
|
||||
|
||||
# Override the install target in the supplied makefile
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sgrep ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/sgrep.1 ${MANPREFIX}/man/man1
|
||||
${INSTALL_DATA} ${WRKSRC}/sample.sgreprc ${PREFIX}/share/sgreprc
|
||||
|
||||
.include <bsd.port.mk>
|
1
textproc/sgrep2/distinfo
Normal file
1
textproc/sgrep2/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (sgrep-0.99.tar.gz) = af09a90c4f1929bfae4818c8962a8907
|
30
textproc/sgrep2/files/patch-aa
Normal file
30
textproc/sgrep2/files/patch-aa
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- Makefile-- Wed Apr 29 12:08:55 1998
|
||||
+++ Makefile Wed Apr 29 12:20:29 1998
|
||||
@@ -10,11 +10,11 @@
|
||||
#
|
||||
|
||||
# This is where the executable goes
|
||||
-BINDIR = /usr/local/bin/
|
||||
+BINDIR = ${PREFIX}/bin
|
||||
# Where sgrep library files are placed (sgreprc)
|
||||
-LIBDIR = /usr/local/lib
|
||||
+LIBDIR = ${PREFIX}/share
|
||||
# Where the manual page goes
|
||||
-MANFILE = /usr/local/man/man1/sgrep.1
|
||||
+MANFILE = ${PREFIX}/man/man1/sgrep.1
|
||||
# Where the sample rc file goes
|
||||
RCFILE = $(LIBDIR)/sgreprc
|
||||
# If you can't install as root you might wan't to use this as rc file
|
||||
@@ -45,11 +45,7 @@
|
||||
clean:
|
||||
-rm -f $(OBJECTS)
|
||||
|
||||
-install: sgrep
|
||||
- cp sgrep $(BINDIR)/sgrep
|
||||
- chmod 755 $(BINDIR)/sgrep
|
||||
- cp sgrep.1 $(MANFILE)
|
||||
- chmod 644 $(MANFILE)
|
||||
+install:
|
||||
|
||||
install.rc: sample.sgreprc
|
||||
cp sample.sgreprc $(RCFILE)
|
11
textproc/sgrep2/files/patch-ab
Normal file
11
textproc/sgrep2/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- sgrep.1-- Wed Apr 29 12:26:40 1998
|
||||
+++ sgrep.1 Wed Apr 29 12:26:49 1998
|
||||
@@ -91,7 +91,7 @@
|
||||
\fB$HOME/.sgreprc,\fP
|
||||
or if it doesn't exist,
|
||||
from file
|
||||
-\fB/usr/lib/sgreprc, \fP
|
||||
+\fB/usr/local/share/sgreprc, \fP
|
||||
and then from the command line. Different behavior
|
||||
can be specified through command line options.
|
||||
.Pp
|
1
textproc/sgrep2/pkg-comment
Normal file
1
textproc/sgrep2/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A `grep' for structured text like SGML and HTML.
|
11
textproc/sgrep2/pkg-descr
Normal file
11
textproc/sgrep2/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
`sgrep' (structured grep) is a tool for searching text files and
|
||||
filtering text streams using structural criteria. Complex criteria
|
||||
can be specified as macros using M4.
|
||||
|
||||
Sgrep was created by:
|
||||
|
||||
Jani Jaakkola, email:Jani.Jaakkola@helsinki.fi
|
||||
Pekka Kilpelainen, email: Pekka.Kilpelainen@helsinki.fi
|
||||
|
||||
- Koshy
|
||||
<jkoshy@acm.org>
|
3
textproc/sgrep2/pkg-plist
Normal file
3
textproc/sgrep2/pkg-plist
Normal file
|
@ -0,0 +1,3 @@
|
|||
bin/sgrep
|
||||
share/sgreprc
|
||||
man/man1/sgrep.1.gz
|
Loading…
Reference in a new issue