Add xorg-fonts-truetype, a port of the X.Org TrueType fonts (bitstream-vera

provided by the existing port).
This commit is contained in:
Eric Anholt 2004-05-31 03:06:13 +00:00
parent bc8d43e2fc
commit 2d288e9e2b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110454
7 changed files with 91 additions and 0 deletions

View file

@ -224,6 +224,7 @@
SUBDIR += xorg-fonts-cyrillic
SUBDIR += xorg-fonts-encodings
SUBDIR += xorg-fonts-miscbitmaps
SUBDIR += xorg-fonts-truetype
SUBDIR += xorg-libraries
SUBDIR += xorg-manpages
SUBDIR += xprompt

View file

@ -0,0 +1,31 @@
# New ports collection makefile for: xorg-fonts-truetype
# Date created: 30 May 2004
# Whom: anholt@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= xorg-fonts-truetype
PORTVERSION= 6.7.0
CATEGORIES= x11
MASTER_SITES= http://freedesktop.org/~xorg/X11R6.7.0/src/
DISTNAME= X11R6.7.0-src1
MAINTAINER= x11@FreeBSD.org
COMMENT= X.Org TrueType fonts
BUILD_DEPENDS= ucs2any:${PORTSDIR}/x11/xorg-clients \
fc-cache:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/encodings/encodings.dir:${PORTSDIR}/x11-fonts/xorg-fonts-encodings \
${X11BASE}/lib/X11/fonts/bitstream-vera/VeraIt.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
fc-cache:${PORTSDIR}/x11-fonts/fontconfig
CONFLICTS= XFree86-fontScalable-*
EXTRA_PATCHES= ${CF_PATCHES}
XBUILD_DIRS= fonts/encodings fonts/scaled/TTF
XINSTALL_DIRS= fonts/scaled/TTF
.include "${.CURDIR}/../../x11-servers/xorg-server/Makefile.inc"
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
MD5 (xorg/X11R6.7.0-src1.tar.gz) = 22465263bae7a2e9f5ad77e172cf1ab5
SIZE (xorg/X11R6.7.0-src1.tar.gz) = 30039655

View file

@ -0,0 +1,25 @@
--- fonts/scaled/TTF/Imakefile.orig Sun May 30 17:51:49 2004
+++ fonts/scaled/TTF/Imakefile Sun May 30 17:52:06 2004
@@ -8,7 +8,7 @@
VERAFONTS = Vera.ttf VeraBI.ttf VeraBd.ttf VeraMoBI.ttf VeraMoBd.ttf \
VeraMoIt.ttf VeraMono.ttf VeraSe.ttf VeraSeBd.ttf
-FONTS = $(LUXIFONTS) $(VERAFONTS)
+FONTS = $(LUXIFONTS)
OBJS = $(FONTS)
FONTINSTDIR = $(FONTDIR)/TTF
@@ -31,6 +31,7 @@
DependSubdirs($(SUBDIRS))
#endif
+.if 0
LinkSourceFile(Vera.ttf,$(VERASRCDIR))
LinkSourceFile(VeraBI.ttf,$(VERASRCDIR))
LinkSourceFile(VeraBd.ttf,$(VERASRCDIR))
@@ -41,4 +42,4 @@
LinkSourceFile(VeraMono.ttf,$(VERASRCDIR))
LinkSourceFile(VeraSe.ttf,$(VERASRCDIR))
LinkSourceFile(VeraSeBd.ttf,$(VERASRCDIR))
-
+.endif

View file

@ -0,0 +1,6 @@
This package contains X.Org TrueType fonts.
WWW: http://www.x.org/
- Eric Anholt
anholt@FreeBSD.org

View file

@ -0,0 +1,16 @@
lib/X11/fonts/TTF/encodings.dir
lib/X11/fonts/TTF/fonts.dir
lib/X11/fonts/TTF/fonts.scale
lib/X11/fonts/TTF/luximb.ttf
lib/X11/fonts/TTF/luximbi.ttf
lib/X11/fonts/TTF/luximr.ttf
lib/X11/fonts/TTF/luximri.ttf
lib/X11/fonts/TTF/luxirb.ttf
lib/X11/fonts/TTF/luxirbi.ttf
lib/X11/fonts/TTF/luxirr.ttf
lib/X11/fonts/TTF/luxirri.ttf
lib/X11/fonts/TTF/luxisb.ttf
lib/X11/fonts/TTF/luxisbi.ttf
lib/X11/fonts/TTF/luxisr.ttf
lib/X11/fonts/TTF/luxisri.ttf
@unexec %D/lib/X11/fonts/TTF/fonts.cache-1 2>/dev/null || /usr/bin/true

View file

@ -0,0 +1,10 @@
#!/bin/sh
LOCALDEF=$WRKDIR/.config
rm -f $LOCALDEF
echo "#define UseInstalledPrograms YES" >> $LOCALDEF
echo "#define UseInstalledClients YES" >> $LOCALDEF
echo "#define StandardIncludes -I${PREFIX}/include" >> $LOCALDEF
sh $PORTSDIR/x11-servers/xorg-server/scripts/configure.gen