- Update to 1.2.6
- Move to LOCALBASE We waited the maintainer's opinion about the issue he found for 14 days. The fix is submitted to upstream and will be in next release. PR: ports/105634 Submitted by: Henrik Brix Andersen <henrik at brixandersen.dk> Approved by: Tobias Roth <ports at fsck.ch> (maintainer)
This commit is contained in:
parent
e4314a9cdc
commit
2d5f929aad
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=179489
6 changed files with 78 additions and 34 deletions
|
@ -6,7 +6,7 @@
|
||||||
#
|
#
|
||||||
|
|
||||||
PORTNAME= slim
|
PORTNAME= slim
|
||||||
PORTVERSION= 1.2.4
|
PORTVERSION= 1.2.6
|
||||||
CATEGORIES= x11
|
CATEGORIES= x11
|
||||||
MASTER_SITES= http://download.berlios.de/slim/ \
|
MASTER_SITES= http://download.berlios.de/slim/ \
|
||||||
http://depot.fsck.ch/mirror/distfiles/
|
http://depot.fsck.ch/mirror/distfiles/
|
||||||
|
@ -20,7 +20,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||||
RUN_DEPENDS= ${X11BASE}/bin/X:${X_SERVER_PORT}
|
RUN_DEPENDS= ${X11BASE}/bin/X:${X_SERVER_PORT}
|
||||||
BUILD_DEPENDS= ${X11BASE}/include/X11/Xft/Xft.h:${PORTSDIR}/x11-fonts/libXft
|
BUILD_DEPENDS= ${X11BASE}/include/X11/Xft/Xft.h:${PORTSDIR}/x11-fonts/libXft
|
||||||
|
|
||||||
USE_X_PREFIX= yes
|
|
||||||
USE_XLIB= yes
|
USE_XLIB= yes
|
||||||
USE_RC_SUBR= slim.sh
|
USE_RC_SUBR= slim.sh
|
||||||
|
|
||||||
|
@ -29,22 +28,24 @@ MAN1= slim.1
|
||||||
MAKEFILE= Makefile.freebsd
|
MAKEFILE= Makefile.freebsd
|
||||||
|
|
||||||
pre-build:
|
pre-build:
|
||||||
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
|
@${REINPLACE_CMD} \
|
||||||
|
-e 's|%%X11BASE%%|${X11BASE}|g' \
|
||||||
|
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
|
||||||
${WRKSRC}/Makefile.freebsd \
|
${WRKSRC}/Makefile.freebsd \
|
||||||
${WRKSRC}/slim.conf
|
${WRKSRC}/slim.conf
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${X11BASE}/bin
|
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${LOCALBASE}/bin
|
||||||
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${X11BASE}/etc/${PORTNAME}.conf.sample
|
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${LOCALBASE}/etc/${PORTNAME}.conf.sample
|
||||||
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${X11BASE}/man/man1
|
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${LOCALBASE}/man/man1
|
||||||
@${MKDIR} ${DATADIR}/themes/default
|
@${MKDIR} ${DATADIR}/themes/default
|
||||||
@${INSTALL_DATA} ${WRKSRC}/themes/default/${PORTNAME}.theme ${DATADIR}/themes/default
|
@${INSTALL_DATA} ${WRKSRC}/themes/default/${PORTNAME}.theme ${DATADIR}/themes/default
|
||||||
@${INSTALL_DATA} ${WRKSRC}/themes/default/panel.png ${DATADIR}/themes/default
|
@${INSTALL_DATA} ${WRKSRC}/themes/default/panel.png ${DATADIR}/themes/default
|
||||||
@${INSTALL_DATA} ${WRKSRC}/themes/default/background.jpg ${DATADIR}/themes/default
|
@${INSTALL_DATA} ${WRKSRC}/themes/default/background.jpg ${DATADIR}/themes/default
|
||||||
|
|
||||||
post-install:
|
post-install:
|
||||||
@if [ ! -f ${X11BASE}/etc/slim.conf ]; then \
|
@if [ ! -f ${LOCALBASE}/etc/slim.conf ]; then \
|
||||||
${CP} -p ${X11BASE}/etc/slim.conf.sample ${X11BASE}/etc/slim.conf ; \
|
${CP} -p ${LOCALBASE}/etc/slim.conf.sample ${LOCALBASE}/etc/slim.conf ; \
|
||||||
fi
|
fi
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
MD5 (slim-1.2.4.tar.gz) = b4aec9724050cf0fd582f8a39bf30f1e
|
MD5 (slim-1.2.6.tar.gz) = 1bf891f046014a03236c21ce6cbe455b
|
||||||
SHA256 (slim-1.2.4.tar.gz) = 84d0fbbd39d012821de195ee3a14af421a40afc0fb68aaa06dc6c5996ace2a62
|
SHA256 (slim-1.2.6.tar.gz) = 4f0a51c88d0d4f942d3552efcfbfcb245bc558336a1ed3f531dbe65252ad8c5e
|
||||||
SIZE (slim-1.2.4.tar.gz) = 214449
|
SIZE (slim-1.2.6.tar.gz) = 219003
|
||||||
|
|
|
@ -1,26 +1,25 @@
|
||||||
--- Makefile.freebsd.orig Sun Sep 11 18:50:36 2005
|
--- Makefile.freebsd.orig Thu Nov 16 17:47:00 2006
|
||||||
+++ Makefile.freebsd Sun Jan 8 12:17:45 2006
|
+++ Makefile.freebsd Thu Nov 16 17:57:34 2006
|
||||||
@@ -3,15 +3,15 @@
|
@@ -3,14 +3,15 @@
|
||||||
# Edit the following section to adjust the options
|
# Edit the following section to adjust the options
|
||||||
# to fit into your operating system / distribution
|
# to fit into your operating system / distribution
|
||||||
#######################################################
|
#######################################################
|
||||||
-CXX=/usr/bin/g++
|
-CXX=/usr/bin/g++
|
||||||
-CC=/usr/bin/gcc
|
-CC=/usr/bin/gcc
|
||||||
-CFLAGS=-I. -I/usr/X11R6/include -I/usr/local/include/freetype2 -I/usr/local/include/freetype2/config -I/usr/local/include/libpng -I/usr/local/include -I/usr/include
|
-CFLAGS=-I. -I/usr/X11R6/include -I/usr/local/include/freetype2 -I/usr/local/include/freetype2/config -I/usr/local/include/libpng -I/usr/local/include -I/usr/include
|
||||||
-CXXLAGS=$(CFLAGS)
|
-LDFLAGS=-L/usr/X11R6/lib -L/usr/local/lib -lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng -lz -lm -lcrypt -lXmu -lpng -ljpeg
|
||||||
-LDFLAGS=-L/usr/X11R6/lib -L/usr/local/lib -lXft -lX11 -lfreetype -lXrender -lfontconfig -lpng -lz -lm -lcrypt -lXpm -lXmu -lpng -ljpeg
|
|
||||||
+CXX?=/usr/bin/g++
|
+CXX?=/usr/bin/g++
|
||||||
+CC?=/usr/bin/gcc
|
+CC?=/usr/bin/gcc
|
||||||
+CFLAGS+=-I%%X11BASE%%/include `freetype-config --cflags` `libpng-config --cflags`
|
+CFLAGS+=-I%%X11BASE%%/include `freetype-config --cflags` `libpng-config --cflags`
|
||||||
+CXXLAGS+=$(CFLAGS)
|
+CXXLAGS+=$(CFLAGS)
|
||||||
+LDFLAGS=-L%%X11BASE%%/lib `freetype-config --libs` `libpng-config --libs` -lXft -lX11 -lXrender -lfontconfig -lz -lm -lcrypt -lXpm -lXmu -ljpeg
|
+LDFLAGS=-L%%X11BASE%%/lib `freetype-config --libs` `libpng-config --libs` -lXft -lX11 -lXrender -lfontconfig -lz -lm -lcrypt -lXmu -ljpeg
|
||||||
CUSTOM=-DNEEDS_BASENAME
|
CUSTOM=-DNEEDS_BASENAME
|
||||||
-PREFIX=/usr
|
-PREFIX=/usr
|
||||||
-CFGDIR=/etc
|
-CFGDIR=/etc
|
||||||
-MANDIR=/usr/share/man
|
-MANDIR=/usr/share/man
|
||||||
+PREFIX=%%X11BASE%%
|
+PREFIX=%%LOCALBASE%%
|
||||||
+CFGDIR=%%X11BASE%%/etc
|
+CFGDIR=%%LOCALBASE%%/etc
|
||||||
+MANDIR=%%X11BASE%%/man
|
+MANDIR=%%LOCALBASE%%/man
|
||||||
DESTDIR=
|
DESTDIR=
|
||||||
#######################################################
|
#######################################################
|
||||||
|
|
||||||
|
|
37
x11/slim/files/patch-app.cpp
Normal file
37
x11/slim/files/patch-app.cpp
Normal file
|
@ -0,0 +1,37 @@
|
||||||
|
--- app.cpp.orig Fri Nov 24 16:36:58 2006
|
||||||
|
+++ app.cpp Sun Nov 26 23:14:35 2006
|
||||||
|
@@ -560,13 +560,6 @@ int App::StartServer() {
|
||||||
|
} else if (pos == 0) {
|
||||||
|
server[argc++] = args+pos;
|
||||||
|
}
|
||||||
|
- if (server[argc-1][0] == 'v' && server[argc-1][1] == 't') {
|
||||||
|
- bool ok = false;
|
||||||
|
- Cfg::string2int(server[argc-1]+2, &ok);
|
||||||
|
- if (ok) {
|
||||||
|
- hasVtSet = true;
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
++pos;
|
||||||
|
|
||||||
|
if (argc+1 >= MAX_XSERVER_ARGS) {
|
||||||
|
@@ -576,8 +569,19 @@ int App::StartServer() {
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ for (int i=0; i<argc; i++) {
|
||||||
|
+ if (server[i][0] == 'v' && server[i][1] == 't') {
|
||||||
|
+ bool ok = false;
|
||||||
|
+ Cfg::string2int(server[i]+2, &ok);
|
||||||
|
+ if (ok) {
|
||||||
|
+ hasVtSet = true;
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (!hasVtSet && daemonmode) {
|
||||||
|
- server[argc++] = "vt07";
|
||||||
|
+ server[argc++] = "vt09";
|
||||||
|
}
|
||||||
|
server[argc] = NULL;
|
||||||
|
|
|
@ -1,10 +1,13 @@
|
||||||
--- slim.conf.orig Sun Sep 11 18:50:36 2005
|
--- slim.conf.orig Thu Nov 16 17:59:38 2006
|
||||||
+++ slim.conf Sun Jan 8 14:32:02 2006
|
+++ slim.conf Thu Nov 16 18:14:31 2006
|
||||||
@@ -1,13 +1,15 @@
|
@@ -1,17 +1,19 @@
|
||||||
# Path, X server and arguments (if needed)
|
# Path, X server and arguments (if needed)
|
||||||
default_path ./:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
|
# Note: -xauth $authfile is automatically appended
|
||||||
default_xserver /usr/X11R6/bin/X
|
-default_path ./:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
|
||||||
|
-default_xserver /usr/X11R6/bin/X
|
||||||
-#xserver_arguments -dpi 75
|
-#xserver_arguments -dpi 75
|
||||||
|
+default_path ./:/bin:/usr/bin:%%LOCALBASE%%/bin:%%X11BASE%%/bin
|
||||||
|
+default_xserver %%X11BASE%%/bin/X
|
||||||
+# The X server needs to be started on an unused virtual terminal,
|
+# The X server needs to be started on an unused virtual terminal,
|
||||||
+# for FreeBSD in a default configuration, the first one of those is #09
|
+# for FreeBSD in a default configuration, the first one of those is #09
|
||||||
+xserver_arguments vt09
|
+xserver_arguments vt09
|
||||||
|
@ -15,12 +18,16 @@
|
||||||
reboot_cmd /sbin/shutdown -r now
|
reboot_cmd /sbin/shutdown -r now
|
||||||
-console_cmd /usr/X11R6/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
|
-console_cmd /usr/X11R6/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
|
||||||
-#suspend_cmd /usr/sbin/suspend
|
-#suspend_cmd /usr/sbin/suspend
|
||||||
+console_cmd /usr/X11R6/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/motd; exec /usr/bin/login"
|
+console_cmd %%X11BASE%%/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/motd; exec /usr/bin/login"
|
||||||
+suspend_cmd /usr/sbin/acpiconf -s 3
|
+suspend_cmd /usr/sbin/acpiconf -s 3
|
||||||
|
|
||||||
# This command is executed after a succesful login.
|
# Full path to the xauth binary
|
||||||
# you can place the %session and %theme variables
|
-xauth_path /usr/X11R6/bin/xauth
|
||||||
@@ -17,8 +19,8 @@
|
+xauth_path %%X11BASE%%/bin/xauth
|
||||||
|
|
||||||
|
# Xauth file for server
|
||||||
|
authfile /var/run/slim.auth
|
||||||
|
@@ -32,8 +34,8 @@
|
||||||
# NOTE: if your system does not have bash you need
|
# NOTE: if your system does not have bash you need
|
||||||
# to adjust the command according to your preferred shell,
|
# to adjust the command according to your preferred shell,
|
||||||
# i.e. for freebsd use:
|
# i.e. for freebsd use:
|
||||||
|
@ -29,9 +36,9 @@
|
||||||
+login_cmd exec /bin/sh - ~/.xinitrc %session
|
+login_cmd exec /bin/sh - ~/.xinitrc %session
|
||||||
+#login_cmd exec /bin/bash -login ~/.xinitrc %session
|
+#login_cmd exec /bin/bash -login ~/.xinitrc %session
|
||||||
|
|
||||||
# Available sessions (first one is the default).
|
# Commands executed when starting and exiting a session.
|
||||||
# The current chosen session name is replaced in the login_cmd
|
# They can be used for registering a X11 session with
|
||||||
@@ -33,7 +35,7 @@
|
@@ -60,7 +62,7 @@
|
||||||
welcome_msg Welcome to %host
|
welcome_msg Welcome to %host
|
||||||
|
|
||||||
# shutdown / reboot messages
|
# shutdown / reboot messages
|
||||||
|
@ -40,7 +47,7 @@
|
||||||
reboot_msg The system is rebooting...
|
reboot_msg The system is rebooting...
|
||||||
|
|
||||||
# default user, leave blank or remove this line
|
# default user, leave blank or remove this line
|
||||||
@@ -45,7 +47,7 @@
|
@@ -72,7 +74,7 @@
|
||||||
current_theme default
|
current_theme default
|
||||||
|
|
||||||
# Lock file
|
# Lock file
|
||||||
|
|
|
@ -18,7 +18,7 @@ load_rc_config $name
|
||||||
|
|
||||||
: ${slim_enable="NO"}
|
: ${slim_enable="NO"}
|
||||||
|
|
||||||
command=%%X11BASE%%/bin/slim
|
command=%%LOCALBASE%%/bin/slim
|
||||||
command_args="-d"
|
command_args="-d"
|
||||||
pidfile=/var/run/slim.pid
|
pidfile=/var/run/slim.pid
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue