- Update to 5e1

PR:		ports/82940
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Pav Lucistnik 2005-07-06 15:53:10 +00:00
parent f9f820f775
commit 2d8945f4b3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=138599
6 changed files with 94 additions and 45 deletions

View file

@ -6,13 +6,12 @@
#
PORTNAME= scm
PORTVERSION= 5d9
PORTREVISION= 1
PORTVERSION= 5e1
CATEGORIES= lang scheme
MASTER_SITES= http://swissnet.ai.mit.edu/ftpdir/scm/%SUBDIR%/
MASTER_SITE_SUBDIR= . OLD
DISTFILES= scm5d9.zip slib3a1.zip slib-psd1-3.tar.gz
EXTRACT_ONLY= scm5d9.zip slib3a1.zip
DISTFILES= scm5e1.zip slib3a2.zip slib-psd1-3.tar.gz
EXTRACT_ONLY= scm5e1.zip slib3a2.zip
MAINTAINER= ports@FreeBSD.org
COMMENT= A scheme interpreter
@ -32,7 +31,7 @@ PLIST_SUB= VERSION=${PORTVERSION}
SCM_DATA= COPYING Iedline.scm Init${PORTVERSION}.scm Link.scm \
Macexp.scm Macro.scm Transcen.scm Tscript.scm mkimpcat.scm \
r4rstest.scm
SCM_MODULES= crs.so edline.so gsubr.so ioext.so posix.so ramap.so \
SCM_MODULES= byte.so crs.so edline.so gsubr.so ioext.so posix.so ramap.so \
record.so rgx.so sc2.so socket.so unix.so
.include <bsd.port.pre.mk>
@ -54,7 +53,13 @@ post-patch:
post-build:
@cd ${WRKSRC} \
&& SCMLIT="./scmlit" ${SH} ./build \
-F "arrays bignums cautious inexact macro dynamic-linking" \
-F arrays \
-F bignums \
-F cautious \
-F engineering-notation \
-F inexact \
-F macro \
-F dynamic-linking \
-h system \
-o scm \
-s "${PREFIX}/lib/scm/" \
@ -67,8 +72,43 @@ post-build:
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c "sc2.c rgx.c record.c gsubr.c ioext.c posix.c unix.c \
socket.c ramap.c" \
-c sc2.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c rgx.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c record.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c gsubr.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c ioext.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c posix.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c unix.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c socket.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c ramap.c \
-h system \
-t dll \
&& SCMLIT="./scmlit" ${SH} ./build \
-c byte.c \
-h system \
-t dll
@ -86,7 +126,6 @@ do-install:
@${MKDIR} ${PREFIX}/lib/scm/slib/psd
${INSTALL_DATA} ${WRKDIR}/slib/psd/*.scm ${PREFIX}/lib/scm/slib/psd
${INSTALL_DATA} ${WRKDIR}/scm/scm.info ${PREFIX}/info
@install-info ${PREFIX}/info/scm.info ${PREFIX}/info/dir
cd ${PREFIX}/lib/scm && ${PREFIX}/bin/scm -lmkimpcat.scm
.include <bsd.port.post.mk>

View file

@ -1,6 +1,6 @@
MD5 (scm5d9.zip) = 27ca7806ca4fcb205b9f53a914853546
SIZE (scm5d9.zip) = 843122
MD5 (slib3a1.zip) = a8805700c4c49d48a14fc8a0c2b996f4
SIZE (slib3a1.zip) = 861953
MD5 (scm5e1.zip) = d16e3b63f958e13109efa57a72ab262c
SIZE (scm5e1.zip) = 868500
MD5 (slib3a2.zip) = 1e3a119031411105c47c02c9cc8450dc
SIZE (slib3a2.zip) = 961683
MD5 (slib-psd1-3.tar.gz) = 81f5d0b2cb4cc1bf51ad4ed3e40b6769
SIZE (slib-psd1-3.tar.gz) = 62397

View file

@ -1,9 +1,9 @@
--- build.orig Mon Dec 1 07:29:36 2003
+++ build Sun Dec 7 23:42:13 2003
--- build.orig Mon Sep 13 09:20:04 2004
+++ build Wed Jun 29 01:42:24 2005
@@ -1,5 +1,5 @@
#! /bin/sh
-:;exec ./scmlit -no-init-file -f $0 -e"(bi)" build $*
+:;exec $SCMLIT -no-init-file -f $0 -e"(bi)" build $*
-:;exec ./scmlit -no-init-file -f $0 -e"(bi)" build "$@"
+:;exec $SCMLIT -no-init-file -f $0 -e"(bi)" build "$@"
(require 'getopt)
(require 'getopt-parameters)

View file

@ -1,37 +1,41 @@
--- build.scm.orig Wed Nov 27 10:44:43 2002
+++ build.scm Sat Nov 30 13:16:28 2002
@@ -1438,7 +1438,7 @@
(lambda (files parms)
(and (batch:try-chopped-command
--- build.scm.orig Mon Jan 10 00:23:55 2005
+++ build.scm Wed Jun 29 02:32:25 2005
@@ -1576,7 +1576,7 @@
parms
;;; gcc 3.4.2 for FreeBSD does not allow options other than default i.e. -O0 if NO -DGCC_SPARC_BUG - dai 2004-10-30
;;"cc" "-O3 -pipe -DGCC_SPARC_BUG " "-c"
- "cc" "-O3 -pipe " "-c"
+ "%%CC%%" "%%CFLAGS%%" "-c"
(c-includes parms)
(c-flags parms)
files)
@@ -1459,7 +1459,7 @@
@@ -1586,7 +1586,7 @@
(batch:rename-file parms
oname (string-append oname "~"))
(and (batch:try-command parms
- "cc" "-o" oname
+ "%%CC%%" "-o" oname
(must-be-first
'("-nostartfiles"
"pre-crt0.o" "crt0.o"
@@ -1596,14 +1596,14 @@
(defcommand compile-dll-c-files freebsd
(lambda (files parms)
(and (batch:try-chopped-command
parms
- "cc" "-O3 -pipe "
+ "%%CC%%" "%%CFLAGS%%"
"-fPIC" "-c" (c-includes parms)
(c-flags parms)
files)
@@ -1468,10 +1468,10 @@
(lambda (fname)
(and (batch:try-command
parms
- "cc" "-shared"
+ "%%CC%%" "-shared"
(cond
((equal? fname "edline") "-lreadline")
- ((equal? fname "x") "-L/usr/X11R6/lib -lSM -lICE -lXext -lX11 -lxpg4")
+ ((equal? fname "x") "-L%%X11BASE%%/lib -lSM -lICE -lXext -lX11")
(else ""))
"-o"
(string-append fname ".so")
@@ -1485,7 +1485,7 @@
- parms "cc" "-O3 -pipe " "-fPIC" "-c"
+ parms "%%CC%%" "%%CFLAGS%%" "-fPIC" "-c"
(c-includes parms) (c-flags parms) files)
(let ((fnames (truncate-up-to (map c-> files) #\/)))
(and (batch:try-command
parms "cc" "-shared"
(cond
((equal? (car fnames) "edline") "-lreadline")
- ((equal? (car fnames) "x") "-L/usr/X11R6/lib -lSM -lICE -lXext -lX11 -lxpg4")
+ ((equal? (car fnames) "x") "-L%%X11BASE%%/lib -lSM -lICE -lXext -lX11 -lxpg4")
(else ""))
"-o" (string-append (car fnames) ".so")
(map (lambda (fname) (string-append fname ".o")) fnames))
@@ -1616,7 +1616,7 @@
(lambda (oname objects libs parms)
(and (batch:try-command
parms

View file

@ -10,10 +10,10 @@ SLIB is a portable Scheme library which SCM uses.
SLIB-PSD is a portable debugger for Scheme (requires emacs editor).
The init file is hard-coded as /usr/local/share/scm/Init.scm. Alternatively,
The init file is hard-coded as /usr/local/lib/scm/Init.scm. Alternatively,
one can set the environment variable SCM_INIT_PATH to the pathname of Init.scm.
The library files are in /usr/local/share/scm/slib. Alternatively, one can set
The library files are in /usr/local/lib/scm/slib. Alternatively, one can set
the environment variable SCHEME_LIBRARY_PATH to the slib directory. Remember to
use a trailing / on the pathname.

View file

@ -8,6 +8,7 @@ lib/scm/Macexp.scm
lib/scm/Macro.scm
lib/scm/Transcen.scm
lib/scm/Tscript.scm
lib/scm/byte.so
lib/scm/crs.so
lib/scm/edline.so
lib/scm/gsubr.so
@ -33,6 +34,7 @@ lib/scm/slib/byte.scm
lib/scm/slib/bytenumb.scm
lib/scm/slib/chap.scm
lib/scm/slib/charplot.scm
lib/scm/slib/clrnamdb.scm
lib/scm/slib/cltime.scm
lib/scm/slib/coerce.scm
lib/scm/slib/collect.scm
@ -64,6 +66,8 @@ lib/scm/slib/eval.scm
lib/scm/slib/factor.scm
lib/scm/slib/fft.scm
lib/scm/slib/fluidlet.scm
lib/scm/slib/format.scm
lib/scm/slib/formatst.scm
lib/scm/slib/genwrite.scm
lib/scm/slib/getopt.scm
lib/scm/slib/getparam.scm
@ -95,6 +99,7 @@ lib/scm/slib/null.scm
lib/scm/slib/obj2str.scm
lib/scm/slib/object.scm
lib/scm/slib/paramlst.scm
lib/scm/slib/peanosfc.scm
lib/scm/slib/phil-spc.scm
lib/scm/slib/plottest.scm
lib/scm/slib/pnm.scm
@ -156,6 +161,7 @@ lib/scm/slib/subarray.scm
lib/scm/slib/synchk.scm
lib/scm/slib/synclo.scm
lib/scm/slib/synrul.scm
lib/scm/slib/timecore.scm
lib/scm/slib/timezone.scm
lib/scm/slib/top-refs.scm
lib/scm/slib/trace.scm