Approved by:	portmgr@ (blanket approval)
This commit is contained in:
Vanilla I. Shu 2014-07-05 00:01:29 +00:00
parent bce680e297
commit 2e07114854
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=360700
3 changed files with 34 additions and 2 deletions

View file

@ -24,8 +24,7 @@ MAKE_ARGS+= WITHOUT_SSL=yes
LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.endif
NO_STAGE= yes
post-install:
@${STRIP_CMD} ${PREFIX}/bin/fusenshi
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/fusenshi
.include <bsd.port.mk>

View file

@ -0,0 +1,14 @@
--- po/Makefile.orig 2014-07-05 00:12:52.864252821 +0800
+++ po/Makefile 2014-07-05 00:13:07.164234705 +0800
@@ -51,9 +51,9 @@ update-po: build-po
msgmerge ${LANG}.po ${GETTEXT_PACKAGE}.pot -o ${LANG}.po
install:
- install -d -m 755 ${PACKAGE_LOCALE_DIR}/${LANG}/LC_MESSAGES
+ install -d -m 755 $(DESTDIR)${PACKAGE_LOCALE_DIR}/${LANG}/LC_MESSAGES
install -c -m 644 ${LANG}.gmo \
- ${PACKAGE_LOCALE_DIR}/${LANG}/LC_MESSAGES/${GETTEXT_PACKAGE}.mo
+ $(DESTDIR)${PACKAGE_LOCALE_DIR}/${LANG}/LC_MESSAGES/${GETTEXT_PACKAGE}.mo
clean:
rm -f ${LANG}.gmo

View file

@ -0,0 +1,19 @@
--- src/Makefile.orig 2014-07-05 00:11:32.020240534 +0800
+++ src/Makefile 2014-07-05 00:12:26.524236990 +0800
@@ -98,12 +98,12 @@ build: ${OBJ}
${CXX} ${CXXFLAGS} -o ${<:.cpp=.o} -c $<
install:
- install -c -m 755 ${TARGET} ${PREFIX}/bin/
- install -d -m 755 ${PACKAGE_DATA_DIR}/${TARGET}/pixmaps
+ install -c -m 755 ${TARGET} $(DESTDIR)${PREFIX}/bin/
+ install -d -m 755 $(DESTDIR)${PACKAGE_DATA_DIR}/${TARGET}/pixmaps
install -c -m 644 ../pixmaps/${TARGET}.xpm \
- ${PACKAGE_DATA_DIR}/${TARGET}/pixmaps/
+ $(DESTDIR)${PACKAGE_DATA_DIR}/${TARGET}/pixmaps/
install -c -m 644 ../pixmaps/${TARGET}_small.xpm \
- ${PACKAGE_DATA_DIR}/${TARGET}/pixmaps/
+ $(DESTDIR)${PACKAGE_DATA_DIR}/${TARGET}/pixmaps/
clean:
rm -f ${OBJ}