Split gimp in to master/slave port

You will need to upgrade via

portmaster -o graphics/gimp-app gimp
portmaster -u grapics/gimp

or

portupgrade -o graphics/gimp-app gimp
portmaster -u grapics/gimp

Repocopied by: marcus
This commit is contained in:
Michael Johnson 2007-04-04 15:18:50 +00:00
parent d5fa03286e
commit 2e0990971f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=189206
13 changed files with 34 additions and 2231 deletions

View file

@ -3,7 +3,7 @@
# Whom: erich@FreeBSD.org
#
# $FreeBSD$
# $MCom: ports/graphics/gimp/Makefile,v 1.2 2006/08/25 18:14:57 pav Exp $
# $MCom: ports/graphics/gimp-app/Makefile,v 1.12 2007/03/30 18:22:45 ahze Exp $
PORTNAME= gimp
PORTVERSION= 2.2.13
@ -30,7 +30,7 @@ LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
CONFLICTS= gimp-1.* gimpshop-[0-9]*
CONFLICTS= gimp-1.* gimpshop-[0-9]* gimp-app-devel-[0-9]*
SHLIBVER?= 200
@ -47,7 +47,8 @@ CONFIGURE_ARGS= --disable-perl \
--with-html-dir=${DOCSDIR} \
--disable-gtk-doc \
--enable-static \
--mandir=${PREFIX}/man
--mandir=${PREFIX}/man \
--disable-print
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
@ -59,7 +60,6 @@ MAN5= gimprc.5 gimprc-2.2.5
OPTIONS= DEBUG "debugging" off \
PYTHON "Python-Fu support" off \
RSVG "SVG format support" on \
PRINT "GIMP printing" on \
HTML_HELP_BROWSER "GIMP help browser" on \
MP "multiple processor support" off
@ -90,14 +90,6 @@ USE_GNOME+= librsvg2
PLIST_SUB+= SVG=""
.endif
.if defined(WITHOUT_PRINT)
CONFIGURE_ARGS+= --disable-print
PLIST_SUB+= PRINT="@comment "
.else
LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
PLIST_SUB+= PRINT=""
.endif
.if defined(WITH_MP)
CONFIGURE_ARGS+= --enable-mp
.endif

View file

@ -310,7 +310,6 @@ libexec/gimp/2.2/plug-ins/png
libexec/gimp/2.2/plug-ins/pnm
libexec/gimp/2.2/plug-ins/polar
libexec/gimp/2.2/plug-ins/postscript
%%PRINT%%libexec/gimp/2.2/plug-ins/print
libexec/gimp/2.2/plug-ins/procedure-browser
libexec/gimp/2.2/plug-ins/psd
libexec/gimp/2.2/plug-ins/psd_save

View file

@ -3,129 +3,48 @@
# Whom: erich@FreeBSD.org
#
# $FreeBSD$
# $MCom: ports/graphics/gimp/Makefile,v 1.2 2006/08/25 18:14:57 pav Exp $
# $MCom: ports/graphics/gimp/Makefile,v 1.9 2007/04/04 14:54:04 ahze Exp $
#
PORTNAME= gimp
PORTVERSION= 2.2.13
PORTREVISION= 2
PORTEPOCH= 1
PORTVERSION?= 2.2
PORTEPOCH?= 2
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
ftp://ftp.fh-heilbronn.de/mirrors/ftp.gimp.org/%SUBDIR%/ \
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/%SUBDIR%/ \
http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,}
MASTER_SITE_SUBDIR= gimp/v${PORTVERSION:R}
MASTER_SITES?= # empty
DISTFILES?= # empty
EXTRACT_ONLY?= # empty
MAINTAINER= gnome@FreeBSD.org
COMMENT= A GNU Image Manipulation Program
COMMENT= The "meta-port" for The Gimp
LIB_DEPENDS= wmf.2:${PORTSDIR}/graphics/libwmf \
aa.1:${PORTSDIR}/graphics/aalib \
exif.12:${PORTSDIR}/graphics/libexif \
mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
RUN_DEPENDS= gimp-2.2:${PORTSDIR}/graphics/gimp-app
CONFLICTS= gimp-1.* gimpshop-[0-9]*
OPTIONS= PRINT "Gutenprint (gimp-print) plugin" On \
HELP "Install Gimp-Help (50+MB distfile)" Off
SHLIBVER?= 200
USE_BZIP2= yes
USE_XPM= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2
WANT_GNOME= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
PLIST_SUB= SHLIBVER="${SHLIBVER}"
CONFIGURE_ARGS= --disable-perl \
--with-html-dir=${DOCSDIR} \
--disable-gtk-doc \
--enable-static \
--mandir=${PREFIX}/man
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
GIMP_DISTFILE= ${DISTDIR}/${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAN1= gimp.1 gimp-2.2.1 gimp-remote.1 gimp-remote-2.2.1 gimptool-2.0.1
MAN5= gimprc.5 gimprc-2.2.5
OPTIONS= DEBUG "debugging" off \
PYTHON "Python-Fu support" off \
RSVG "SVG format support" on \
PRINT "GIMP printing" on \
HTML_HELP_BROWSER "GIMP help browser" on \
MP "multiple processor support" off
NO_BUILD= yes
.include <bsd.port.pre.mk>
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
pre-everything::
@if [ -n "`${PKG_INFO} -xI '^gimp-[0-9].[0-9].[0-9]*' 2>/dev/null`" ]; then \
${ECHO_CMD} "${PKGNAME}: Old version of gimp detected! Please see ${PORTSDIR}/UPDATING for information on upgrading ${PKGNAME}" ; \
${FALSE}; \
fi
.if defined(WITH_HELP)
RUN_DEPENDS+= gimp-help>0:${PORTSDIR}/graphics/gimp-help
.endif
.if defined(WITH_PYTHON)
USE_PYTHON= yes
# we need to manually include this, because USE_PYTHON is defined
# after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.python.mk"
USE_GNOME+= pygtk2
CONFIGURE_ARGS+= --enable-python
PLIST_SUB+= PYTHON:=""
.else
CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON:="@comment "
#.if defined(WITH_PYTHON)
#RUN_DEPENDS+= ${LOCALBASE}/libexec/gimp/2.2/environ/pygimp.env:${PORTSDIR}/graphics/py-gimp
#.endif
.if !defined(WITHOUT_PRINT)
RUN_DEPENDS+= ${LOCALBASE}/libexec/gimp/2.2/plug-ins/print:${PORTSDIR}/print/gimp-gutenprint
.endif
.if defined(WITHOUT_RSVG)
CONFIGURE_ARGS+= --without-librsvg
PLIST_SUB+= SVG="@comment "
.else
USE_GNOME+= librsvg2
PLIST_SUB+= SVG=""
.endif
.if defined(WITHOUT_PRINT)
CONFIGURE_ARGS+= --disable-print
PLIST_SUB+= PRINT="@comment "
.else
LIB_DEPENDS+= gimpprint.2:${PORTSDIR}/print/gimp-print
PLIST_SUB+= PRINT=""
.endif
.if defined(WITH_MP)
CONFIGURE_ARGS+= --enable-mp
.endif
.if ${HAVE_GNOME:Mgnomepanel}!=""
USE_GNOME+= gnomepanel desktopfileutils
CONFIGURE_ARGS+= --with-desktop-dir=${LOCALBASE}/share/gnome
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
PKGNAMESUFFIX:= -gnome
PLIST_SUB+= GNOMEPANEL:=""
GNOME_ENABLED= yes
.else
PLIST_SUB+= GNOMEPANEL:="@comment "
CONFIGURE_ENV+= GIMP_THREAD_LIBS=${PTHREAD_LIBS}
.endif
.if defined(WITH_HTML_HELP_BROWSER)
USE_GNOME+= libgtkhtml
PLIST_SUB+= HELPBROWSER:=""
.else
PLIST_SUB+= HELPBROWSER:="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|\(have_gtkhtml2=\)yes|\1no|' ${WRKSRC}/configure
.endif
.if defined(GNOME_ENABLED)
post-install:
@-update-desktop-database
.endif
do-install: # empty
.include <bsd.port.post.mk>

View file

@ -1,3 +0,0 @@
MD5 (gimp-2.2.13.tar.bz2) = d84a4a476a0c4fae24602db67f6fe49a
SHA256 (gimp-2.2.13.tar.bz2) = d0273a3133461f5531bfa17ee24419abfe1f21121b03ef99195a2371a79b2ed7
SIZE (gimp-2.2.13.tar.bz2) = 12930670

View file

@ -1,20 +0,0 @@
--- app/main.c.orig Sun Oct 5 09:16:02 2003
+++ app/main.c Mon Oct 6 12:14:34 2003
@@ -23,6 +23,7 @@
#include <signal.h>
#include <string.h>
#include <sys/types.h>
+#include <floatingpoint.h>
#ifdef HAVE_SYS_WAIT_H
#include <sys/wait.h>
@@ -113,6 +114,9 @@
/* Initialize variables */
full_prog_name = argv[0];
+
+ /* Ignore floating point exceptions */
+ fpsetmask(0);
/* Initialize i18n support */

View file

@ -1,19 +0,0 @@
--- libgimp/gimp.c.orig Fri May 12 12:37:27 2000
+++ libgimp/gimp.c Thu May 18 16:42:21 2000
@@ -26,6 +26,7 @@
#include <stdlib.h>
#include <string.h>
#include <sys/types.h>
+#include <floatingpoint.h>
#ifdef HAVE_SYS_TIME_H
#include <sys/time.h>
@@ -211,6 +212,9 @@
}
progname = argv[0];
+
+ /* Ignore floating point exceptions */
+ fpsetmask(0);
g_set_prgname (g_basename (progname));

View file

@ -1,23 +0,0 @@
--- configure.orig Sun Mar 6 15:30:12 2005
+++ configure Sun Mar 6 15:33:57 2005
@@ -25925,6 +25925,7 @@
if test "x$enable_gtktest" = "xyes" ; then
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
+ GTK_LIBS="$GIMP_THREAD_LIBS $GTK_LIBS"
CFLAGS="$CFLAGS $GTK_CFLAGS"
LIBS="$GTK_LIBS $LIBS"
rm -f conf.gtktest
@@ -33865,9 +33866,9 @@
fi
fi;
-gimpdatadir="$datadir/$PACKAGE/2.0"
-gimpplugindir="$libdir/$PACKAGE/2.0"
-gimpsysconfdir="$sysconfdir/$PACKAGE/2.0"
+gimpdatadir="$datadir/$PACKAGE"
+gimpplugindir="$libexecdir/$PACKAGE/2.2"
+gimpsysconfdir="$sysconfdir/$PACKAGE/2.2"
localedir='${prefix}/${DATADIRNAME}/locale'

View file

@ -1,26 +0,0 @@
--- gimptool-2.0.in.orig Tue Jan 15 12:21:05 2002
+++ gimptool-2.0.in Fri May 17 20:46:18 2002
@@ -215,19 +215,19 @@
| --uninstall-script | --uninstall-admin-script )
case $1 in
--*install-bin)
- install_cmd="@INSTALL_PROGRAM@"
+ install_cmd="@INSTALL_SCRIPT@"
install_dir="$HOME/@gimpdir@/plug-ins"
;;
--install-bin-strip)
- install_cmd="@INSTALL_PROGRAM@ -s"
+ install_cmd="@INSTALL_SCRIPT@ -s"
install_dir="$HOME/@gimpdir@/plug-ins"
;;
--*install-admin-bin)
- install_cmd="@INSTALL_PROGRAM@"
+ install_cmd="@INSTALL_SCRIPT@"
install_dir="$gimpplugindir/plug-ins"
;;
--install-admin-bin-strip)
- install_cmd="@INSTALL_PROGRAM@ -s"
+ install_cmd="@INSTALL_SCRIPT@ -s"
install_dir="$gimpplugindir/plug-ins"
;;
--*install-script)

View file

@ -1,19 +0,0 @@
--- app/plug-in/plug-ins.c.orig Wed Nov 17 15:51:50 2004
+++ app/plug-in/plug-ins.c Sun Oct 22 18:58:36 2006
@@ -317,6 +317,8 @@
if (! gimp->no_interface)
{
+ gimp_menus_init (gimp, gimp->plug_in_defs, STD_PLUGINS_DOMAIN);
+
gimp->load_procs = g_slist_sort_with_data (gimp->load_procs,
plug_ins_file_proc_compare,
gimp);
@@ -324,7 +326,6 @@
plug_ins_file_proc_compare,
gimp);
- gimp_menus_init (gimp, gimp->plug_in_defs, STD_PLUGINS_DOMAIN);
}
/* build list of automatically started extensions */

View file

@ -1,17 +0,0 @@
--- plug-ins/common/url.c.orig Wed Dec 28 13:56:48 2005
+++ plug-ins/common/url.c Wed Dec 28 13:58:33 2005
@@ -186,10 +186,10 @@
putenv ("LANG=C");
#endif
- execlp ("wget",
- "wget", "-v", "-e", "server-response=off", "-T", TIMEOUT,
- filename, "-O", tmpname, NULL);
- g_message ("exec() failed: wget: %s", g_strerror (errno));
+ execlp ("fetch",
+ "fetch", "-T", TIMEOUT,
+ filename, "-p", "-o", tmpname, NULL);
+ g_message ("exec() failed: fetch: %s", g_strerror (errno));
g_free (tmpname);
_exit (127);
}

View file

@ -1,11 +0,0 @@
--- plug-ins/print/print.c.orig Tue Dec 26 07:43:54 2000
+++ plug-ins/print/print.c Tue Dec 26 07:44:07 2000
@@ -1417,7 +1417,7 @@
if (i < (sizeof(lpcs) / sizeof(lpcs[0])))
{
- strcat(command, " status < /dev/null");
+ strcat(command, " status all < /dev/null");
type = PRINTERS_LPC;
}
else

View file

@ -16,4 +16,6 @@ major features:
new effect filters.
* Multiple undo/redo.
This is "The Gimp" meta-port, see ports/graphics/gimp-app for more details
WWW: http://www.gimp.org/

File diff suppressed because it is too large Load diff