Add gxine, a GTK interface to xine. The interface is simple, but stable.

PR:		51156
Submitted by:	Grigori Goronzy <greg@chown.ath.cx>
This commit is contained in:
Adam Weinberger 2003-04-19 18:34:23 +00:00
parent 38f392c9a9
commit 2e2e978fae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79301
10 changed files with 104 additions and 0 deletions

View file

@ -23,6 +23,7 @@
SUBDIR += gsubedit
SUBDIR += gtksubtitler
SUBDIR += gxanim
SUBDIR += gxine
SUBDIR += kdemultimedia3
SUBDIR += kmplayer
SUBDIR += kplayer

32
multimedia/gxine/Makefile Normal file
View file

@ -0,0 +1,32 @@
# New ports collection makefile for: gxine
# Date created: Sa 19 Apr 2003 01:34:06 CEST
# Whom: Grigori Goronzy <greg@chown.ath.cx>
#
# $FreeBSD$
#
PORTNAME= gxine
PORTVERSION= 0.3.3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xine
MAINTAINER= greg@chown.ath.cx
COMMENT= An alternative GUI for the Xine media player
LIB_DEPENDS= xine.6:${PORTSDIR}/multimedia/libxine
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
USE_GNOME= gtk20
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -I${X11BASE}/lib"
MANLANG= "" de
MAN1= gxine.1
post-patch:
@${REINPLACE_CMD} -e 's/browser-plugin//' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>

View file

@ -0,0 +1 @@
MD5 (gxine-0.3.3.tar.gz) = d54af2f901065555348a77fa3b61581e

View file

@ -0,0 +1,10 @@
--- src/desktop_integration.c.orig Sat Apr 19 02:23:31 2003
+++ src/desktop_integration.c Sat Apr 19 02:23:39 2003
@@ -30,7 +30,6 @@
#include <stdlib.h>
#include <stdio.h>
#include <dlfcn.h>
-#include <alloca.h>
#include <string.h>
#include "globals.h"

View file

@ -0,0 +1,10 @@
--- src/globals.h.orig Sat Apr 19 02:18:27 2003
+++ src/globals.h Sat Apr 19 02:20:42 2003
@@ -28,6 +28,7 @@
#include <gtk/gtk.h>
#include <gdk/gdk.h>
#include <glib.h>
+#include <pthread.h>
#include "infobar.h"

View file

@ -0,0 +1,10 @@
--- src/gtkxine.h.orig Sat Apr 19 02:24:55 2003
+++ src/gtkxine.h Sat Apr 19 02:25:07 2003
@@ -27,6 +27,7 @@
#include <X11/Xlib.h>
#include <X11/extensions/XShm.h>
#include <xine.h>
+#include "globals.h"
#ifdef __cplusplus
extern "C" {

View file

@ -0,0 +1,12 @@
--- src/http.c.orig Sat Apr 19 02:22:23 2003
+++ src/http.c Sat Apr 19 02:22:34 2003
@@ -35,6 +35,9 @@
#include <unistd.h>
#include <ctype.h>
#include <errno.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+#define IPPROTO_TCP 6
#include "http.h"

View file

@ -0,0 +1,11 @@
--- src/spidermonkey/jsprf.c.orig Sat Apr 19 02:11:15 2003
+++ src/spidermonkey/jsprf.c Sat Apr 19 02:12:27 2003
@@ -57,7 +57,7 @@
#define VARARGS_ASSIGN(foo, bar) (foo) = (bar)
#endif
*/
-#define VARARGS_ASSIGN(foo, bar) __va_copy(foo, bar)
+#define VARARGS_ASSIGN(foo, bar) (foo) = (bar)
/*
** WARNING: This code may *NOT* call JS_LOG (because JS_LOG calls it)

View file

@ -0,0 +1,6 @@
gxine is a simple but effective GUI for the Xine media player.
It uses the GTK toolkit, so it nicely fits in into a GNOME desktop.
NOTE: gxine's browser plugin is currently disabled, because it doesn't build.
WWW: http://www.xinehq.de

View file

@ -0,0 +1,11 @@
bin/gxine
bin/gxine_client
share/gxine/logo.mpv
share/gxine/pixmaps/gxine-logo.png
share/gxine/pixmaps/gxine-icon.xpm
share/gxine/pixmaps/wizards.png
share/gxine/pixmaps/splash.png
share/gxine/mediamarks
share/gnome/apps/Multimedia/gxine.desktop
@dirrm share/gxine/pixmaps
@dirrm share/gxine