- Fix build failure in fetch
- New MASTER_SITES - Update LICENSE* PR: 193727 Submitted by: takefu@airport.fm (maintainer)
This commit is contained in:
parent
46cf4bcb84
commit
2e59289758
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=368447
2 changed files with 11 additions and 7 deletions
|
@ -3,13 +3,13 @@
|
|||
|
||||
PORTNAME= libaacplus
|
||||
PORTVERSION= 2.0.2
|
||||
PORTREVISION= 6
|
||||
PORTREVISION= 7
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://media.wnet.ua/~tipok/aacplus/:site1\
|
||||
MASTER_SITES= http://tipok.org.ua/downloads/media/aacplus/libaacplus/:site1\
|
||||
ftp://ftp.3gpp.org/Specs/archive/26_series/26.410/:site2\
|
||||
http://www.3gpp.org/ftp/Specs/archive/26_series/26.410/:site2
|
||||
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:site1\
|
||||
26410-800.zip:site2
|
||||
${SRC26410}:site2
|
||||
|
||||
MAINTAINER= takefu@airport.fm
|
||||
COMMENT= HE-AAC+ Codec as Shared Library
|
||||
|
@ -18,6 +18,8 @@ LICENSE= libaacplus
|
|||
LICENSE_NAME= 3GPP
|
||||
LICENSE_TEXT= ${RESTRICTED}
|
||||
LICENSE_PERMS= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-accept
|
||||
LICENSE_DISTFILES_LGPL= ${DISTNAME}${EXTRACT_SUFX}
|
||||
LICENSE_DISTFILES_3GPP= ${SRC26410}
|
||||
|
||||
RESTRICTED= unclear legal status, probably need licenses from 3GPP, Via Licensing and Coding Technologies
|
||||
|
||||
|
@ -37,6 +39,8 @@ AUTOMAKE_ARGS= --add-missing
|
|||
OPTIONS_DEFINE= FFTW3
|
||||
OPTIONS_DEFAULT=FFTW3
|
||||
|
||||
SRC26410= 26410-800.zip
|
||||
|
||||
FFTW3_DESC= Use FFTW3 library for performance
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
|
|
@ -1,11 +1,11 @@
|
|||
--- src/Makefile.am.orig 2012-02-05 17:48:09.719522837 +0000
|
||||
+++ src/Makefile.am 2012-02-05 17:49:47.572522148 +0000
|
||||
--- src/Makefile.am.orig 2010-11-11 06:27:41.000000000 +0900
|
||||
+++ src/Makefile.am 2014-05-22 07:32:03.000000000 +0900
|
||||
@@ -206,14 +206,14 @@
|
||||
$(MAKE) unpack_3gp_sources
|
||||
|
||||
$(srcdir)/FloatFR_aacPlusenc:
|
||||
- cd $(srcdir) && $(UNZIP) 26410-800-ANSI-C_source_code.zip
|
||||
+ cd $(srcdir) && /usr/bin/tar xf 26410-800-ANSI-C_source_code.zip
|
||||
+ cd $(srcdir) && /usr/bin/bsdtar xf 26410-800-ANSI-C_source_code.zip
|
||||
mv -f $(srcdir)/3GPP_enhanced_aacPlus_src_*/FloatFR_aacPlusenc $(srcdir)
|
||||
rm -rf $(srcdir)/3GPP_enhanced_aacPlus_src_*
|
||||
|
||||
|
@ -13,7 +13,7 @@
|
|||
$(srcdir)/26410-800-ANSI-C_source_code.zip: $(srcdir)/26410-800.zip
|
||||
rm -f $(srcdir)/26410-800-ANSI-C_source_code.zip $(srcdir)/26410-800.doc
|
||||
- cd $(srcdir) && $(UNZIP) 26410-800.zip
|
||||
+ cd $(srcdir) && /usr/bin/tar xf 26410-800.zip
|
||||
+ cd $(srcdir) && /usr/bin/bsdtar xf 26410-800.zip
|
||||
mv $(srcdir)/26410-800.doc $(top_srcdir)/26410-800.doc
|
||||
chmod og-w $(top_srcdir)/26410-800.doc
|
||||
|
||||
|
|
Loading…
Reference in a new issue