- Fix build on CURRENT after ino64 merge
This commit is contained in:
parent
3371a26c23
commit
2e69f4d0fd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=444645
2 changed files with 15 additions and 1 deletions
|
@ -39,6 +39,10 @@ DESKTOP_ENTRIES="kiki the nanobot" \
|
|||
CXXFLAGS+= -Werror=tautological-constant-out-of-range-compare
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} > 1200031
|
||||
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ino64
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e '/^CXXFLAGS/ s|.*|CXXFLAGS+=$$(KODI_INCLUDES) -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`|' ${WRKSRC}/kodilib/linux/Makefile
|
||||
@${REINPLACE_CMD} -e 's|getenv("KIKI_HOME")|"${DATADIR}"|' ${WRKSRC}/src/main/KikiController.cpp
|
||||
|
@ -50,7 +54,6 @@ do-build:
|
|||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/linux/kiki ${STAGEDIR}${PREFIX}/bin/
|
||||
${MKDIR} ${STAGEDIR}${DATADIR}
|
||||
cd ${WRKSRC} && ${COPYTREE_SHARE} "py sound" ${STAGEDIR}${DATADIR}/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
11
games/kiki/files/extra-patch-ino64
Normal file
11
games/kiki/files/extra-patch-ino64
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- kodilib/src/tools/KFileTools.cpp.orig 2004-06-30 20:03:38.000000000 +0400
|
||||
+++ kodilib/src/tools/KFileTools.cpp 2013-12-24 05:02:16.028538916 +0400
|
||||
@@ -299,7 +299,7 @@ bool kFileGetDirEntries ( const string &
|
||||
int fd = open (dirPath.c_str(), O_RDONLY | O_NONBLOCK);
|
||||
|
||||
struct stat sb;
|
||||
- long basep;
|
||||
+ off_t basep;
|
||||
char * entry;
|
||||
|
||||
if (fstat(fd, &sb) == -1)
|
Loading…
Reference in a new issue