- Fix build of wanderlust-xemacs21-mule with apel in xemacs-packages.

- Fix build of wanderlust-xemacs21-mule with WRKDIRPREFIX. [*]

Reported by:	kris [*]
This commit is contained in:
MANTANI Nobutaka 2005-11-27 16:02:43 +00:00
parent c49dbd943a
commit 2ec1b74e75
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=149677
3 changed files with 41 additions and 1 deletions

View file

@ -38,6 +38,10 @@ RUN_DEPENDS= ${LOCALBASE}/share/semi/${MIMEUI_COOKIE}:${PORTSDIR}/editors/${MIME
RUN_DEPENDS+= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/bitmap/bitmap.el:${PORTSDIR}/editors/${BITMAP_PORT_NAME}
.endif
.if (${EMACS_PORT_NAME} == "xemacs21-mule")
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-WL-MK ${PATCHDIR}/extra-patch-elmo:elmo-version.el
.endif
.include <bsd.port.pre.mk>
.if exists(${EMACS_W3M_LISP_FILE})
@ -74,9 +78,10 @@ PLIST_SUB+= EMACS_PACKAGESDIR=${EMACS_PACKAGESDIR} \
SHIMBUN=${SHIMBUN}
PLIST= ${PKGDIR}/pkg-plist.${EMACS_PORT_NAME}
WRK_STARTUP_FILE= ${WRKDIR}/wanderlust-startup.el
MAKE_ARGS+= EMACS=${EMACS_CMD} XEMACS=${EMACS_CMD} \
LISPDIR=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR} \
FLAGS="-batch -q -no-site-file -l ${WRKDIR}/wanderlust-startup.el"
FLAGS="-batch -q -no-site-file -l ${WRK_STARTUP_FILE:C/\/\/*/\//g}"
.if defined(EMACS_PACKAGESDIR)
MAKE_ARGS+= PACKAGEDIR=${PREFIX}/${EMACS_PACKAGESDIR}
.else

View file

@ -0,0 +1,13 @@
--- WL-MK.orig Sun Nov 27 22:32:36 2005
+++ WL-MK Sun Nov 27 22:33:20 2005
@@ -115,8 +115,8 @@
(load "./WL-ELS" nil nil t)
;; product.el version check
(require 'product)
- (if (not (fboundp 'product-version-as-string))
- (error "Please install new APEL. See INSTALL or INSTALL.ja"))
+; (if (not (fboundp 'product-version-as-string))
+; (error "Please install new APEL. See INSTALL or INSTALL.ja"))
;; smtp.el version check.
(require 'smtp)
(if (not (fboundp 'smtp-send-buffer))

View file

@ -0,0 +1,22 @@
--- elmo/elmo-version.el.orig Sun Nov 27 22:34:49 2005
+++ elmo/elmo-version.el Sun Nov 27 22:41:22 2005
@@ -42,6 +42,19 @@
;; Don't forget to check `wl-version.el' and Info.
(product-define "ELMO" nil '(2 14 0)))
+(defun product-version-as-string (product)
+ "Return version number of product as a string.
+PRODUCT is a product structure which returned by `product-define'.
+If optional argument UPDATE is non-nil, then regenerate
+`produce-version-string' from `product-version'."
+ (setq product (product-find product))
+ (or (product-version-string product)
+ (and (product-version product)
+ (product-set-version-string product
+ (mapconcat (function int-to-string)
+ (product-version product)
+ ".")))))
+
;; set version-string
(product-version-as-string 'elmo-version)