Fix build as a user.
While there, really don't generate backup copies in post-patch. Sponsored by: Absolight
This commit is contained in:
parent
f9b6310ef3
commit
2ec21e753c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=403731
2 changed files with 11 additions and 7 deletions
|
@ -44,10 +44,10 @@ SUB_LIST= OPENTSDB_USER="${OPENTSDB_USER}" \
|
|||
OPENTSDB_RUNDIR="${OPENTSDB_RUNDIR}"
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -i"" -e "s|python|${PYTHON_CMD}|" ${WRKSRC}/build-aux/gen_build_data.sh
|
||||
${REINPLACE_CMD} -i"" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/Makefile.in
|
||||
${REINPLACE_CMD} -i"" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/src/utils/Config.java
|
||||
${REINPLACE_CMD} -i"" -e "s|tsd.http.staticroot =|tsd.http.staticroot = ${DATADIR}/static|; s|tsd.http.cachedir =|tsd.http.cachedir = /tmp/opentsdb|; s|tsd.network.port =|tsd.network.port = 4242|;" ${WRKSRC}/src/opentsdb.conf
|
||||
${REINPLACE_CMD} -i "" -e "s|python|${PYTHON_CMD}|" ${WRKSRC}/build-aux/gen_build_data.sh
|
||||
${REINPLACE_CMD} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/Makefile.in
|
||||
${REINPLACE_CMD} -i "" -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/src/utils/Config.java
|
||||
${REINPLACE_CMD} -i "" -e "s|tsd.http.staticroot =|tsd.http.staticroot = ${DATADIR}/static|; s|tsd.http.cachedir =|tsd.http.cachedir = /tmp/opentsdb|; s|tsd.network.port =|tsd.network.port = 4242|;" ${WRKSRC}/src/opentsdb.conf
|
||||
|
||||
post-install:
|
||||
${MKDIR} ${STAGEDIR}${ETCDIR} ${STAGEDIR}${OPENTSDB_LOGDIR} ${STAGEDIR}${OPENTSDB_RUNDIR}
|
||||
|
|
|
@ -1,15 +1,19 @@
|
|||
--- Makefile.in.orig 2015-09-12 19:49:17 UTC
|
||||
+++ Makefile.in
|
||||
@@ -1415,7 +1415,7 @@ printdeps:
|
||||
@@ -1415,9 +1415,11 @@ printdeps:
|
||||
# This is kind of a hack, but I couldn't find a better way to adjust the paths
|
||||
# in the script before it gets installed...
|
||||
install-exec-hook:
|
||||
- script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(pkgdatadir)/etc/opentsdb'; \
|
||||
+ script=tsdb; pkgdatadir='$(pkgdatadir)'; configdir='$(sysconfdir)/etc/opentsdb'; \
|
||||
abs_srcdir=''; abs_builddir=''; $(edit_tsdb_script)
|
||||
+ chmod u+w "$(DESTDIR)$(bindir)/tsdb"
|
||||
cat tsdb.tmp >"$(DESTDIR)$(bindir)/tsdb"
|
||||
+ chmod u-w "$(DESTDIR)$(bindir)/tsdb"
|
||||
rm -f tsdb.tmp
|
||||
@@ -1442,7 +1442,7 @@ gwtc: .gwtc-stamp
|
||||
|
||||
$(builddata_SRC): .git/HEAD $(tsdb_SRC) $(top_srcdir)/build-aux/gen_build_data.sh
|
||||
@@ -1442,7 +1444,7 @@ gwtc: .gwtc-stamp
|
||||
@$(mkdir_p) gwt
|
||||
{ cd $(srcdir) && cat $(httpui_SRC); } | $(MD5) >"$@-t"
|
||||
cmp -s "$@" "$@-t" && exit 0; \
|
||||
|
@ -18,7 +22,7 @@
|
|||
$(GWTC_ARGS) -war gwt tsd.QueryUi
|
||||
@mv "$@-t" "$@"
|
||||
gwtdev: .gwtc-stamp
|
||||
@@ -1468,7 +1468,7 @@ gwttsd: staticroot
|
||||
@@ -1468,7 +1470,7 @@ gwttsd: staticroot
|
||||
# how to tell it to install a bunch of files recursively for which I don't
|
||||
# know ahead of time what the file names are.
|
||||
install-data-local: staticroot install-data-lib install-data-tools \
|
||||
|
|
Loading…
Reference in a new issue