add romeo
The Palm ROM Discombobulator
This commit is contained in:
parent
b852e5e08e
commit
2ed06f6cc8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40348
8 changed files with 55 additions and 0 deletions
|
@ -23,6 +23,7 @@
|
|||
SUBDIR += prc-tools
|
||||
SUBDIR += prc-tools-binutils
|
||||
SUBDIR += prc-tools-gcc
|
||||
SUBDIR += romeo
|
||||
SUBDIR += syncal
|
||||
SUBDIR += syncmal
|
||||
SUBDIR += txt2pdbdoc
|
||||
|
|
23
palm/romeo/Makefile
Normal file
23
palm/romeo/Makefile
Normal file
|
@ -0,0 +1,23 @@
|
|||
# ex:ts=8
|
||||
# New ports collection makefile for: romeo
|
||||
# Date created: Mar 25, 2001
|
||||
# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= romeo
|
||||
PORTVERSION= 0.5.0
|
||||
CATEGORIES= palm
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ijliao@FreeBSD.org
|
||||
|
||||
USE_GMAKE= yes
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/romeo ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
1
palm/romeo/distinfo
Normal file
1
palm/romeo/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (romeo-0.5.0.tgz) = 36a27d3c6a9be28b3676ec21ac87cc87
|
8
palm/romeo/files/patch-Makefile
Normal file
8
palm/romeo/files/patch-Makefile
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- Makefile.orig Sun Mar 25 21:30:01 2001
|
||||
+++ Makefile Sun Mar 25 21:30:12 2001
|
||||
@@ -1,5 +1,3 @@
|
||||
-CC = gcc
|
||||
-CFLAGS = -Wall -g
|
||||
LDFLAGS = -L. -lromeo
|
||||
AR = ar crv
|
||||
|
11
palm/romeo/files/patch-types.h
Normal file
11
palm/romeo/files/patch-types.h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- types.h.orig Sun Mar 25 21:29:19 2001
|
||||
+++ types.h Sun Mar 25 21:29:29 2001
|
||||
@@ -4,7 +4,7 @@
|
||||
/********************************************************************
|
||||
* Elementary data types
|
||||
********************************************************************/
|
||||
-#include <endian.h>
|
||||
+#include <machine/endian.h>
|
||||
|
||||
#define CPU_ENDIAN_LITTLE __LITTLE_ENDIAN
|
||||
#define CPU_ENDIAN_BIG __BIG_ENDIAN
|
1
palm/romeo/pkg-comment
Normal file
1
palm/romeo/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
The Palm ROM Discombobulator
|
9
palm/romeo/pkg-descr
Normal file
9
palm/romeo/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
With Romeo, you can construct custom PalmOS ROM images with extra
|
||||
applications of your choice and without any of the default applications
|
||||
that you never use. This can be extremely useful if your Palm doesn't
|
||||
have much RAM, or if you are deploying an application to, say, a sales
|
||||
team and want to make it as user-proof as possible. There's almost 600K
|
||||
of unused space on a typical Palm ROM, and you can be taking advantage
|
||||
of it.
|
||||
|
||||
WWW: http://romeo.sourceforge.net/
|
1
palm/romeo/pkg-plist
Normal file
1
palm/romeo/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
bin/romeo
|
Loading…
Reference in a new issue