After decades of war one company, who had gained powerful supplying both sides

with weaponary, steps forwards and crushes both warring factions in one swift
movement. Using far superior weaponary and AI craft, the company was completely
unstoppable and now no one can stand in their way. Thousands began to perish
under the iron fist of the company. The people cried out for a saviour, for
someone to light this dark hour... and someone did.

PR:		ports/83418
Submitted by:	Alejandro Pulver <alejandro@varnet.biz>
This commit is contained in:
Pav Lucistnik 2005-07-15 21:44:06 +00:00
parent c4ee4c94c7
commit 2f1065d8ee
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=139306
6 changed files with 107 additions and 0 deletions

View file

@ -469,6 +469,7 @@
SUBDIR += spider
SUBDIR += ssamtse
SUBDIR += ssc
SUBDIR += starfighter
SUBDIR += starlanes
SUBDIR += stratagus
SUBDIR += stvef-paks

View file

@ -0,0 +1,53 @@
# New ports collection makefile for: starfighter
# Date created: 13 Jul 2005
# Whom: Alejandro Pulver <alejandro@varnet.biz>
#
# $FreeBSD$
#
PORTNAME= starfighter
DISTVERSION= 1.1-1
CATEGORIES= games
MASTER_SITES= http://www.parallelrealities.co.uk/download.php?type=zip&file=
MAINTAINER= alejandro@varnet.biz
COMMENT= Chris Bainfield is fighting for the freedom of the galaxy
FETCH_BEFORE_ARGS+= -o ${DISTNAME}${EXTRACT_SUFX}
USE_GMAKE= yes
USE_SDL= image mixer sdl
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-1.1
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
MAKEFILE= makefile
MAKE_ENV= CXX="${CXX}"
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
${RM} ${DOCSDIR}/LICENSE
.endif
.include <bsd.port.pre.mk>
post-patch:
# Fix Makefile
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
s|\(-Wall\)|${CFLAGS} \1|' \
${WRKSRC}/${MAKEFILE}
# Fix SDL include statement
@${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
${WRKSRC}/code/*.cpp ${WRKSRC}/code/*.h
# Enable/disable compilation optimizations
.if !defined(WITH_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/${MAKEFILE}
.endif
.include <bsd.port.post.mk>

View file

@ -0,0 +1,2 @@
MD5 (starfighter-1.1-1.tar.gz) = 6a4b704dbc83c7403842b936f95ee958
SIZE (starfighter-1.1-1.tar.gz) = 2523399

View file

@ -0,0 +1,25 @@
--- makefile.orig Mon Aug 18 09:48:23 2003
+++ makefile Wed Jul 13 18:40:23 2005
@@ -7,9 +7,9 @@
PACK = starfighter.pak
DOCS = docs/*
-BINDIR = /usr/games/
-DATADIR = /usr/share/games/parallelrealities/
-DOCDIR = /usr/share/doc/starfighter/
+BINDIR = $(PREFIX)/bin/
+DATADIR = $(PREFIX)/share/$(PROG)/
+DOCDIR = $(PREFIX)/share/doc/$(PROG)/
# top-level rule to create the program.
all: $(PROG)
@@ -31,7 +31,5 @@
# install
install:
mkdir -p $(DATADIR)
- strip $(PROG)
- install -o root -g games -m 755 $(PROG) $(BINDIR)$(PROG)
- install -o root -g games -m 644 $(PACK) $(DATADIR)$(PACK)
- cp $(DOCS) $(DOCDIR)
+ $(BSD_INSTALL_PROGRAM) $(PROG) $(BINDIR)$(PROG)
+ $(BSD_INSTALL_DATA) $(PACK) $(DATADIR)$(PACK)

View file

@ -0,0 +1,11 @@
After decades of war one company, who had gained powerful supplying both sides
with weaponary, steps forwards and crushes both warring factions in one swift
movement. Using far superior weaponary and AI craft, the company was completely
unstoppable and now no one can stand in their way. Thousands began to perish
under the iron fist of the company. The people cried out for a saviour, for
someone to light this dark hour... and someone did.
WWW: http://www.parallelrealities.co.uk/starfighter.php
- Alejandro Pulver
alejandro@varnet.biz

View file

@ -0,0 +1,15 @@
bin/starfighter
%%PORTDOCS%%%%DOCSDIR%%/ammo.gif
%%PORTDOCS%%%%DOCSDIR%%/cash.gif
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/plasmaAmmo.png
%%PORTDOCS%%%%DOCSDIR%%/plasmaDamage.png
%%PORTDOCS%%%%DOCSDIR%%/plasmaRate.png
%%PORTDOCS%%%%DOCSDIR%%/rocketAmmo.png
%%PORTDOCS%%%%DOCSDIR%%/sflogo.gif
%%PORTDOCS%%%%DOCSDIR%%/shield.gif
%%PORTDOCS%%%%DOCSDIR%%/superCharge.png
%%PORTDOCS%%%%DOCSDIR%%/targetArrow.png
%%DATADIR%%/starfighter.pak
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%