RBL (Realtime Blackhole List) smtp daemon for blocking SPAM.

PR:		ports/8516 and ports/9080
Submitted by:	John Saunders <john@nlc.net.au>
Submitted by:	Neil Blakey-Milner <nbm@rucus.ru.ac.za>
This commit is contained in:
Jun Kuriyama 1999-02-11 07:23:16 +00:00
parent 22d5e4bb7f
commit 2f50aab331
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16603
7 changed files with 73 additions and 0 deletions

25
mail/rblsmtpd/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: rblsmtpd
# Version required: 0.70
# Date created: 30 October 1998
# Whom: John Saunders <john@nlc.net.au>
#
# $Id$
#
DISTNAME= rblsmtpd-0.70
CATEGORIES= mail
MASTER_SITES= ftp://koobera.math.uic.edu/pub/software/
MAINTAINER= john@nlc.net.au
NO_PACKAGE= Unsure of djb's license
ALL_TARGET= it
INSTALL_TARGET= setup check
SCRIPTS_ENV= BINOWN="${BINOWN}" BINGRP="${BINGRP}" BINMODE="${BINMODE}" \
MANMODE="${MANMODE}" CFLAGS="${CFLAGS}"
MAN8= rblsmtpd.8 antirbl.8
.include <bsd.port.mk>

1
mail/rblsmtpd/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (rblsmtpd-0.70.tar.gz) = 2b9440db40aad2429ecbe8c964f69aa9

View file

@ -0,0 +1,19 @@
--- hier.c.orig Fri Oct 30 14:09:44 1998
+++ hier.c Fri Oct 30 14:13:05 1998
@@ -7,12 +7,9 @@
d(auto_home,"bin",-1,-1,0755);
d(auto_home,"man",-1,-1,0755);
d(auto_home,"man/man8",-1,-1,0755);
- d(auto_home,"man/cat8",-1,-1,0755);
- c(auto_home,"bin","rblsmtpd",-1,-1,0755);
- c(auto_home,"bin","antirbl",-1,-1,0755);
- c(auto_home,"man/man8","rblsmtpd.8",-1,-1,0644);
- c(auto_home,"man/man8","antirbl.8",-1,-1,0644);
- c(auto_home,"man/cat8","rblsmtpd.0",-1,-1,0644);
- c(auto_home,"man/cat8","antirbl.0",-1,-1,0644);
+ c(auto_home,"bin","rblsmtpd",3,7,0555);
+ c(auto_home,"bin","antirbl",3,7,0555);
+ c(auto_home,"man/man8","rblsmtpd.8",3,7,0444);
+ c(auto_home,"man/man8","antirbl.8",3,7,0444);
}

View file

@ -0,0 +1 @@
RBL (Realtime Blackhole List) smtp daemon for blocking SPAM.

15
mail/rblsmtpd/pkg-descr Normal file
View file

@ -0,0 +1,15 @@
rblsmtpd is a generic tool to block mail from RBL-listed sites. It works
with any SMTP server that can run under tcpserver; in particular, any
version of qmail or sendmail. Turning it on is easy: simply insert
rblsmtpd in front of the real SMTP server in your inetd.conf (or
tcpserver) invocation.
rblsmtpd supports anti-RBL lists for sites that want to skip RBL lookups
for preauthorized hosts. It also optionally pays attention to temporary
RBL lookup errors.
See http://pobox.com/~djb/rblsmtpd.html for info and updates.
See http://maps.vix.com/rbl/ for more information about the RBL.
-John Saunders <john@nlc.net.au>

2
mail/rblsmtpd/pkg-plist Normal file
View file

@ -0,0 +1,2 @@
bin/rblsmtpd
bin/antirbl

10
mail/rblsmtpd/scripts/configure vendored Normal file
View file

@ -0,0 +1,10 @@
#!/bin/sh
#
# Set up daemontools for the *BSD environment...
#
# @(#) $Id: configure,v 1.1.1.1 1998/07/09 10:18:38 dburr Exp $
#
# Tune the options we're given.
echo ${PREFIX} > ${WRKSRC}/conf-home
echo cc ${CFLAGS} > ${WRKSRC}/conf-cc