LP64 fix, clean-up.
Approved by: maintainer
This commit is contained in:
parent
4c59237f06
commit
2fb291c94c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103566
2 changed files with 29 additions and 12 deletions
|
@ -10,33 +10,25 @@ PORTVERSION= 1.0.1a
|
|||
PORTREVISION= 1
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://www.logicalshift.demon.co.uk/unix/${PORTNAME}/
|
||||
DISTFILES= ${DISTFILE_SRC} ${DISTFILE_PATCH}
|
||||
EXTRACT_ONLY= ${DISTFILE_SRC}
|
||||
DISTFILES= ${PORTNAME}-1.0.1.tar.gz
|
||||
|
||||
PATCHFILES= zoom-1.0.1-1.0.1a.patch
|
||||
PATCH_DIST_STRIP=-p1
|
||||
|
||||
MAINTAINER= Jan.Stocker@t-online.de
|
||||
COMMENT= Z-Interpreter for X with full V6 support
|
||||
|
||||
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
|
||||
|
||||
NOT_FOR_ARCHS= sparc64
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_XLIB= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
DISTFILE_SRC= ${PORTNAME}-1.0.1.tar.gz
|
||||
DISTFILE_PATCH= zoom-1.0.1-1.0.1a.patch
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
|
||||
|
||||
MAKE_ENV= ${CONFIGURE_ENV}
|
||||
|
||||
post-extract:
|
||||
${MV} ${WRKDIR}/${PORTNAME}-1.0.1 ${WRKSRC}
|
||||
@cd ${WRKDIR} && \
|
||||
${PATCH} < ${DISTDIR}/${DISTFILE_PATCH}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
25
games/zoom/files/patch-src_hash.c
Normal file
25
games/zoom/files/patch-src_hash.c
Normal file
|
@ -0,0 +1,25 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/hash.c.orig Thu Jul 25 20:10:02 2002
|
||||
+++ src/hash.c Wed Mar 10 16:00:01 2004
|
||||
@@ -81,7 +81,7 @@
|
||||
for (i = 0; i < 256; ++i) {
|
||||
for (c = i << 24, j = 8; j > 0; --j)
|
||||
c = c & 0x80000000 ? (c << 1) ^ CRC32_POLY : (c << 1);
|
||||
- crc32_table[i] = c;
|
||||
+ crc32_table[i] = c & 0xffffffff;
|
||||
}
|
||||
}
|
||||
|
||||
@@ -95,8 +95,8 @@
|
||||
init_crc32(); /* build table */
|
||||
crc = 0xffffffff; /* preload shift register, per CRC-32 spec */
|
||||
for (p = buf; len > 0; ++p, --len)
|
||||
- crc = (crc << 8) ^ crc32_table[(crc >> 24) ^ *p];
|
||||
- return ~crc; /* transmit complement, per CRC-32 spec */
|
||||
+ crc = ((crc << 8) ^ crc32_table[(crc >> 24) ^ *p]) & 0xffffffff;
|
||||
+ return ~crc & 0xffffffff; /* transmit complement, per CRC-32 spec */
|
||||
}
|
||||
|
||||
static struct bucket *hash_lookup(hash hash,
|
Loading…
Reference in a new issue