Initial import of gkrellmvolume.
A plugin for GKrellM, that let's you control your mixer..
This commit is contained in:
parent
3af15641a0
commit
2fb59f6467
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29786
12 changed files with 168 additions and 0 deletions
26
audio/gkrellmvolume/Makefile
Normal file
26
audio/gkrellmvolume/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: gkrellmvolume
|
||||
# Date Created: Jun 22 2000
|
||||
# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gkrellmvolume
|
||||
PORTVERSION= 0.6
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://gkrellm.luon.net/files/
|
||||
DISTNAME= volume-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ume@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
|
||||
gdk_imlib.5:${PORTSDIR}/graphics/imlib
|
||||
BUILD_DEPENDS= ${PREFIX}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
|
||||
RUN_DEPENDS= ${PREFIX}/bin/gkrellm:${PORTSDIR}/sysutils/gkrellm
|
||||
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/gkrellmvolume/distinfo
Normal file
1
audio/gkrellmvolume/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (volume-0.6.tar.gz) = 68de87480dfdd8c84c11e148640421d7
|
47
audio/gkrellmvolume/files/patch-aa
Normal file
47
audio/gkrellmvolume/files/patch-aa
Normal file
|
@ -0,0 +1,47 @@
|
|||
Index: Makefile
|
||||
diff -u Makefile.orig Makefile
|
||||
--- Makefile.orig Thu Jun 15 21:02:13 2000
|
||||
+++ Makefile Thu Jun 22 22:16:36 2000
|
||||
@@ -1,15 +1,15 @@
|
||||
# Makefile for GKrellM volume plugin
|
||||
|
||||
# Linux
|
||||
-GTK_CONFIG = gtk-config
|
||||
-SYSLIB = -lpthread
|
||||
+#GTK_CONFIG = gtk-config
|
||||
+#SYSLIB = -lpthread
|
||||
|
||||
# FreeBSD
|
||||
#GTK_CONFIG = gtk12-config
|
||||
#SYSLIB =
|
||||
|
||||
-PLUGIN_DIR = /usr/share/gkrellm/plugins
|
||||
-GKRELLM_INCLUDE = -I/usr/local/include
|
||||
+PLUGIN_DIR = $(PREFIX)/libexec/gkrellm/plugins
|
||||
+GKRELLM_INCLUDE = -I$(PREFIX)/include
|
||||
|
||||
GTK_INCLUDE = `$(GTK_CONFIG) --cflags`
|
||||
GTK_LIB = `$(GTK_CONFIG) --libs`
|
||||
@@ -17,12 +17,10 @@
|
||||
IMLIB_INCLUDE = `imlib-config --cflags-gdk`
|
||||
IMLIB_LIB = `imlib-config --libs-gdk`
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
|
||||
LIBS = $(GTK_LIB) $(IMLIB_LIB) $(SYSLIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
-
|
||||
INSTALL = install -c
|
||||
INSTALL_PROGRAM = $(INSTALL) -s
|
||||
|
||||
@@ -34,7 +32,7 @@
|
||||
make GTK_CONFIG=gtk12-config SYSLIB= all
|
||||
|
||||
volume.so: $(OBJS)
|
||||
- $(CC) $(OBJS) -o volume.so $(LIBS) $(LFLAGS)
|
||||
+ $(CC) $(CFLAGS) $(OBJS) -o volume.so $(LFLAGS) $(LIBS)
|
||||
|
||||
clean:
|
||||
rm -f *.o core *.so* *.bak *~
|
1
audio/gkrellmvolume/pkg-comment
Normal file
1
audio/gkrellmvolume/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GKrellM volume plugin
|
8
audio/gkrellmvolume/pkg-descr
Normal file
8
audio/gkrellmvolume/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
GKrellM volume plugin
|
||||
Author: Sjoerd Simons <Sjoerd@donald-duck.ele.tue.nl>
|
||||
WWW: http://gkrellm.luon.net/volume.phtml
|
||||
|
||||
A plugin for GKrellM, that let's you control your mixer..
|
||||
|
||||
|
||||
- Hajimu UMEMOTO <ume@FreeBSD.org>
|
1
audio/gkrellmvolume/pkg-plist
Normal file
1
audio/gkrellmvolume/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
libexec/gkrellm/plugins/volume.so
|
26
audio/gkrellmvolume2/Makefile
Normal file
26
audio/gkrellmvolume2/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# New ports collection makefile for: gkrellmvolume
|
||||
# Date Created: Jun 22 2000
|
||||
# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gkrellmvolume
|
||||
PORTVERSION= 0.6
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://gkrellm.luon.net/files/
|
||||
DISTNAME= volume-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ume@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
|
||||
gdk_imlib.5:${PORTSDIR}/graphics/imlib
|
||||
BUILD_DEPENDS= ${PREFIX}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
|
||||
RUN_DEPENDS= ${PREFIX}/bin/gkrellm:${PORTSDIR}/sysutils/gkrellm
|
||||
|
||||
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/gkrellmvolume2/distinfo
Normal file
1
audio/gkrellmvolume2/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (volume-0.6.tar.gz) = 68de87480dfdd8c84c11e148640421d7
|
47
audio/gkrellmvolume2/files/patch-aa
Normal file
47
audio/gkrellmvolume2/files/patch-aa
Normal file
|
@ -0,0 +1,47 @@
|
|||
Index: Makefile
|
||||
diff -u Makefile.orig Makefile
|
||||
--- Makefile.orig Thu Jun 15 21:02:13 2000
|
||||
+++ Makefile Thu Jun 22 22:16:36 2000
|
||||
@@ -1,15 +1,15 @@
|
||||
# Makefile for GKrellM volume plugin
|
||||
|
||||
# Linux
|
||||
-GTK_CONFIG = gtk-config
|
||||
-SYSLIB = -lpthread
|
||||
+#GTK_CONFIG = gtk-config
|
||||
+#SYSLIB = -lpthread
|
||||
|
||||
# FreeBSD
|
||||
#GTK_CONFIG = gtk12-config
|
||||
#SYSLIB =
|
||||
|
||||
-PLUGIN_DIR = /usr/share/gkrellm/plugins
|
||||
-GKRELLM_INCLUDE = -I/usr/local/include
|
||||
+PLUGIN_DIR = $(PREFIX)/libexec/gkrellm/plugins
|
||||
+GKRELLM_INCLUDE = -I$(PREFIX)/include
|
||||
|
||||
GTK_INCLUDE = `$(GTK_CONFIG) --cflags`
|
||||
GTK_LIB = `$(GTK_CONFIG) --libs`
|
||||
@@ -17,12 +17,10 @@
|
||||
IMLIB_INCLUDE = `imlib-config --cflags-gdk`
|
||||
IMLIB_LIB = `imlib-config --libs-gdk`
|
||||
|
||||
-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
|
||||
+CFLAGS += -fPIC $(GTK_INCLUDE) $(IMLIB_INCLUDE) $(GKRELLM_INCLUDE)
|
||||
LIBS = $(GTK_LIB) $(IMLIB_LIB) $(SYSLIB)
|
||||
LFLAGS = -shared
|
||||
|
||||
-CC = gcc $(CFLAGS) $(FLAGS)
|
||||
-
|
||||
INSTALL = install -c
|
||||
INSTALL_PROGRAM = $(INSTALL) -s
|
||||
|
||||
@@ -34,7 +32,7 @@
|
||||
make GTK_CONFIG=gtk12-config SYSLIB= all
|
||||
|
||||
volume.so: $(OBJS)
|
||||
- $(CC) $(OBJS) -o volume.so $(LIBS) $(LFLAGS)
|
||||
+ $(CC) $(CFLAGS) $(OBJS) -o volume.so $(LFLAGS) $(LIBS)
|
||||
|
||||
clean:
|
||||
rm -f *.o core *.so* *.bak *~
|
1
audio/gkrellmvolume2/pkg-comment
Normal file
1
audio/gkrellmvolume2/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
GKrellM volume plugin
|
8
audio/gkrellmvolume2/pkg-descr
Normal file
8
audio/gkrellmvolume2/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
GKrellM volume plugin
|
||||
Author: Sjoerd Simons <Sjoerd@donald-duck.ele.tue.nl>
|
||||
WWW: http://gkrellm.luon.net/volume.phtml
|
||||
|
||||
A plugin for GKrellM, that let's you control your mixer..
|
||||
|
||||
|
||||
- Hajimu UMEMOTO <ume@FreeBSD.org>
|
1
audio/gkrellmvolume2/pkg-plist
Normal file
1
audio/gkrellmvolume2/pkg-plist
Normal file
|
@ -0,0 +1 @@
|
|||
libexec/gkrellm/plugins/volume.so
|
Loading…
Reference in a new issue