net/intel-ix-kmod: Remove unused DRIVER_MODULE devclass on recent main.

Reviewed by:	imp
Differential Revision:	https://reviews.freebsd.org/D35201
This commit is contained in:
John Baldwin 2022-06-23 14:31:37 -07:00
parent 2b2c9a4d2f
commit 2fd9ef9ddd
2 changed files with 16 additions and 0 deletions

View file

@ -21,6 +21,7 @@ MANPAGELINKS= ix if_ix if_ixgbe
MAX_NETMAP_OSVERSION= 9999999
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PATCHDIR= ${.CURDIR}/files
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo

View file

@ -0,0 +1,15 @@
--- if_ix.c.orig 2022-05-13 22:10:39 UTC
+++ if_ix.c
@@ -241,8 +241,12 @@ static driver_t ix_driver = {
"ix", ix_methods, sizeof(struct adapter),
};
+#if __FreeBSD_version >= 1400058
+DRIVER_MODULE(ix, pci, ix_driver, 0, 0);
+#else
devclass_t ix_devclass;
DRIVER_MODULE(ix, pci, ix_driver, ix_devclass, 0, 0);
+#endif
MODULE_DEPEND(ix, pci, 1, 1, 1);
MODULE_DEPEND(ix, ether, 1, 1, 1);