cleanup: Remove expired ports:
2021-10-30 databases/mysqlsniffer: Development discontinued upstream, doesn't build on recent FreeBSD
This commit is contained in:
parent
e9eb4687c7
commit
3060456b81
8 changed files with 1 additions and 71 deletions
1
MOVED
1
MOVED
|
@ -16586,3 +16586,4 @@ net/irrd-legacy|net/irrd|2021-10-27|Has expired: Use net/irrd
|
|||
mail/postfix-ldap-sasl|mail/postfix@ldap|2021-10-28|Converted to flavor
|
||||
mail/postfix-sasl|mail/postfix@sasl|2021-10-28|Converted to flavor
|
||||
mail/postfix-current-sasl|mail/postfix-current@sasl|2021-10-28|Converted to flavor
|
||||
databases/mysqlsniffer||2021-10-30|Has expired: Development discontinued upstream, doesn't build on recent FreeBSD
|
||||
|
|
|
@ -228,7 +228,6 @@
|
|||
SUBDIR += mysqldump-secure
|
||||
SUBDIR += mysqlreport
|
||||
SUBDIR += mysqlsla
|
||||
SUBDIR += mysqlsniffer
|
||||
SUBDIR += mysqltcl
|
||||
SUBDIR += mysqltuner
|
||||
SUBDIR += mysqlwsrep56-server
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
# Created by: Frederic Hardy <frederic.hardy@mageekbox.net>
|
||||
|
||||
PORTNAME= mysqlsniffer
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= databases
|
||||
|
||||
MAINTAINER= frederic.hardy@mageekbox.net
|
||||
COMMENT= Tcpdump clone specifically for MySQL
|
||||
|
||||
DEPRECATED= Development discontinued upstream, doesn't build on recent FreeBSD
|
||||
EXPIRATION_DATE=2021-10-30
|
||||
BROKEN_FreeBSD_13= ld: error: duplicate symbol: decoded_len
|
||||
BROKEN_FreeBSD_14= ld: error: duplicate symbol: decoded_len
|
||||
|
||||
WRKSRC_SUBDIR= ${PORTNAME}
|
||||
|
||||
PLIST_FILES= bin/mysqlsniffer
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= daniel-nichter
|
||||
GH_PROJECT= hackmysql.com
|
||||
GH_TAGNAME= ddb6f92
|
||||
|
||||
do-build:
|
||||
${CC} ${CFLAGS} -lpcap -o ${WRKSRC}/${PORTNAME} \
|
||||
${WRKSRC}/mysqlsniffer.c ${WRKSRC}/packet_handlers.c \
|
||||
${WRKSRC}/misc.c
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (daniel-nichter-hackmysql.com-1.2-ddb6f92_GH0.tar.gz) = ef8ce294e52a795388d96fb7fc8a3b1f7b90ac480b6c14683bcb8d3ce67571fb
|
||||
SIZE (daniel-nichter-hackmysql.com-1.2-ddb6f92_GH0.tar.gz) = 1954606
|
|
@ -1,10 +0,0 @@
|
|||
--- misc.c.orig 2006-08-18 14:37:02 UTC
|
||||
+++ misc.c
|
||||
@@ -4,6 +4,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <ctype.h>
|
||||
+#include <sys/types.h>
|
||||
#include "user_defines.h"
|
||||
#include "mysql_defines.h"
|
||||
#include "misc.h"
|
|
@ -1,10 +0,0 @@
|
|||
--- mysqlsniffer.c.orig 2006-08-18 14:52:52 UTC
|
||||
+++ mysqlsniffer.c
|
||||
@@ -31,6 +31,7 @@
|
||||
#include <getopt.h>
|
||||
#include <signal.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <sys/types.h>
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include "user_defines.h"
|
|
@ -1,10 +0,0 @@
|
|||
--- packet_handlers.c.orig 2006-08-18 14:37:02 UTC
|
||||
+++ packet_handlers.c
|
||||
@@ -3,6 +3,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
+#include <sys/types.h>
|
||||
#include "mysql_defines.h"
|
||||
#include "user_defines.h"
|
||||
#include "state_map.h"
|
|
@ -1,6 +0,0 @@
|
|||
mysqlsniffer is a tcpdump clone specifically for dumping/sniffing/watching MySQL
|
||||
network protocol traffic over TCP/IP networks.
|
||||
mysqlsniffer is coded in C using the pcap library and works with MySQL version
|
||||
4.0 and newer. mysqlsniffer is the only MySQL-specific network sniffer.
|
||||
|
||||
WWW: http://hackmysql.com/mysqlsniffer
|
Loading…
Reference in a new issue