Maintainer's update to 0.2.1
Also save 8 bytes in pkg-plist (use %%DOCSDIR%%) (by osa) PR: 55520
This commit is contained in:
parent
5f34cb31ac
commit
30ddd14a02
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86892
6 changed files with 16 additions and 72 deletions
|
@ -6,27 +6,25 @@
|
|||
#
|
||||
|
||||
PORTNAME= s10sh
|
||||
PORTVERSION= 0.2.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 0.2.1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.reynoldsnet.org/s10sh/ \
|
||||
http://www.edwinh.org/s10sh/ \
|
||||
http://www.kyuzz.org/antirez/s10sh-src/
|
||||
http://www.edwinh.org/s10sh/
|
||||
|
||||
MAINTAINER= johnjen@reynoldsnet.org
|
||||
COMMENT= USB/serial userspace driver for the Canon PowerShot digital cameras
|
||||
|
||||
# Don't extract the libusb bundled with s10sh:
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libusb*'
|
||||
|
||||
MAKEFILE= ${FILESDIR}/Makefile.bsd
|
||||
|
||||
.if defined(NOUSB) || defined(WITHOUT_USB)
|
||||
MAKE_ENV+= WITHOUT_USB=YES
|
||||
.else
|
||||
LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
|
||||
.endif
|
||||
|
||||
# Don't extract the libusb bundled with s10sh:
|
||||
EXTRACT_AFTER_ARGS= | ${TAR} -xf - --exclude '*/libusb*'
|
||||
|
||||
MAKEFILE= ${FILESDIR}/Makefile.bsd
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
post-install:
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (s10sh-0.2.0.tar.gz) = 7792756ccb941baa87b3624d1a4bbe92
|
||||
MD5 (s10sh-0.2.1.tar.gz) = d16ae61c435890f64224745e5d023d32
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
--- usb.c.orig Tue Mar 13 06:46:18 2001
|
||||
+++ usb.c Sat Dec 7 06:16:19 2002
|
||||
@@ -84,6 +84,12 @@
|
||||
printf("Canon S20 found\n");
|
||||
return USB_INIT_S20;
|
||||
break;
|
||||
+ case PRODUCT_ID_A20:
|
||||
+ *camera_dev = dev;
|
||||
+ if (opt_debug)
|
||||
+ printf("Canon A20 found\n");
|
||||
+ return USB_INIT_A20;
|
||||
+ break;
|
||||
case PRODUCT_ID_S100_EU:
|
||||
case PRODUCT_ID_S100_US:
|
||||
*camera_dev = dev;
|
||||
@@ -97,6 +103,12 @@
|
||||
printf("Canon G1 found\n");
|
||||
return USB_INIT_G1;
|
||||
break;
|
||||
+ case PRODUCT_ID_G3:
|
||||
+ *camera_dev = dev;
|
||||
+ if (opt_debug)
|
||||
+ printf("Canon G3 found\n");
|
||||
+ return USB_INIT_G3;
|
||||
+ break;
|
||||
case PRODUCT_ID_NEXTDIGICAM1:
|
||||
case PRODUCT_ID_NEXTDIGICAM2:
|
||||
case PRODUCT_ID_NEXTDIGICAM3:
|
||||
@@ -118,6 +130,7 @@
|
||||
dev->descriptor.idProduct);
|
||||
break;
|
||||
}
|
||||
+ break;
|
||||
default:
|
||||
if (opt_debug)
|
||||
printf("Unknown vendor ID: %04X\n",
|
|
@ -1,23 +0,0 @@
|
|||
--- usb.h.orig Tue Mar 13 06:46:18 2001
|
||||
+++ usb.h Sat Dec 7 06:16:19 2002
|
||||
@@ -19,15 +19,20 @@
|
||||
#define USB_INIT_S20 2 /* S20 found */
|
||||
#define USB_INIT_S100 3 /* S100 (Digital Ixus) found */
|
||||
#define USB_INIT_G1 4 /* G1 found */
|
||||
+#define USB_INIT_A20 5 /* A20 found */
|
||||
+#define USB_INIT_G2 6 /* G2 found */
|
||||
+#define USB_INIT_G3 7 /* G3 found */
|
||||
#define USB_INIT_NEW 100 /* Unsupported PowerShot found! */
|
||||
#define USB_INIT_FAILED -1 /* Unable to initialize USB */
|
||||
|
||||
#define VENDOR_ID_CANON 0x04A9
|
||||
#define PRODUCT_ID_S10 0x3041 /* PowerShot S10 */
|
||||
#define PRODUCT_ID_S20 0x3043 /* PowerShot S20 */
|
||||
+#define PRODUCT_ID_A20 0x304E /* PowerShot A20 */
|
||||
#define PRODUCT_ID_S100_US 0x3045 /* S100, aka. Digital Ixus, Elph */
|
||||
#define PRODUCT_ID_S100_EU 0x3047 /* S100, aka. Digital Ixus, Elph */
|
||||
#define PRODUCT_ID_G1 0x3048 /* PowerShot G1 */
|
||||
+#define PRODUCT_ID_G3 0x306E
|
||||
|
||||
/* The Canon USB protocol of the S10, S20, S100, G1 is the same.
|
||||
* We can hope that the next cameras will adopt a compatible protocol
|
|
@ -13,7 +13,12 @@ S10sh supports the following PowerShot models:
|
|||
A50 (serial only, supported with problems)
|
||||
Pro70 (serial only, supported with problems)
|
||||
|
||||
Other models are reported to work as well: Elph S400, Digital Ixus V3, S30,
|
||||
A60, EOS-10D.
|
||||
|
||||
With the release of libusb 0.1.3b (http://sourceforge.net/projects/libusb/),
|
||||
S10sh gained USB support under FreeBSD.
|
||||
|
||||
WWW: http://www.kyuzz.org/antirez/s10sh.html
|
||||
The original author's web page is http://www.kyuzz.org/antirez/s10sh.html
|
||||
|
||||
WWW: http://www.reynoldsnet.org/s10sh/
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
bin/s10sh
|
||||
%%PORTDOCS%%share/doc/s10sh/README
|
||||
%%PORTDOCS%%@dirrm share/doc/s10sh
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
|
|
Loading…
Reference in a new issue