Add fusefs-httpfs 2.06.07.10, fuse-based http filesystem.
PR: ports/100389 Submitted by: Gea-Suan Lin <gslin at gslin.org>
This commit is contained in:
parent
9867470978
commit
30ec470b97
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=168189
5 changed files with 66 additions and 0 deletions
|
@ -187,6 +187,7 @@
|
|||
SUBDIR += ftrace
|
||||
SUBDIR += fusefs-curlftpfs
|
||||
SUBDIR += fusefs-funionfs
|
||||
SUBDIR += fusefs-httpfs
|
||||
SUBDIR += fusefs-kmod
|
||||
SUBDIR += fusefs-libs
|
||||
SUBDIR += fusefs-sshfs
|
||||
|
|
42
sysutils/fusefs-httpfs/Makefile
Normal file
42
sysutils/fusefs-httpfs/Makefile
Normal file
|
@ -0,0 +1,42 @@
|
|||
# New ports collection makefile for: fusefs-httpfs
|
||||
# Date created: 2006-07-16
|
||||
# Whom: Gea-Suan Lin <gslin@gslin.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= httpfs
|
||||
PORTVERSION= 2.06.07.10
|
||||
CATEGORIES= sysutils www
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMEPREFIX= fusefs-
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}
|
||||
|
||||
MAINTAINER= gslin@gslin.org
|
||||
COMMENT= Fuse-based http filesystem
|
||||
|
||||
RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
|
||||
BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
|
||||
|
||||
PLIST_FILES= bin/httpfs
|
||||
USE_BZIP2= yes
|
||||
WRKSRC= ${WRKDIR}
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include/fuse \
|
||||
-DUSE_AUTH -D_FILE_OFFSET_BITS=64 -D_REENTRANT \
|
||||
-DFUSE_USE_VERSION=25 -D_POSIX_C_SOURCE=200112L -D_POSIX_SOURCE \
|
||||
-D_SVID_SOURCE -D_BSD_SOURCE -D_XOPEN_SOURCE=500 \
|
||||
-o httpfs httpfs.c -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lfuse)
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/httpfs ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 600000 # Inherited from sysutils/fusefs-kmod
|
||||
IGNORE= depends on kernel module that requires FreeBSD 6 or later
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
3
sysutils/fusefs-httpfs/distinfo
Normal file
3
sysutils/fusefs-httpfs/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (httpfs_2.06.07.10.tar.bz2) = f62e2f333651a7c21b610d0ec4f52f03
|
||||
SHA256 (httpfs_2.06.07.10.tar.bz2) = b6291852ae2810528585447b835aa9d507c6ee7d1a4e7889e183e0305f753223
|
||||
SIZE (httpfs_2.06.07.10.tar.bz2) = 13990
|
14
sysutils/fusefs-httpfs/files/patch-httpfs.c
Normal file
14
sysutils/fusefs-httpfs/files/patch-httpfs.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- httpfs.c.orig Sun Jul 16 22:48:19 2006
|
||||
+++ httpfs.c Sun Jul 16 22:48:39 2006
|
||||
@@ -32,9 +32,10 @@
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
#include <sys/stat.h>
|
||||
-#include <sys/dir.h>
|
||||
+#include <dirent.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <sys/select.h>
|
||||
#include <netinet/in.h>
|
||||
#include <netdb.h>
|
||||
#include <time.h>
|
6
sysutils/fusefs-httpfs/pkg-descr
Normal file
6
sysutils/fusefs-httpfs/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
httpfs depends on FUSE. It uses HTTP/1.1 extensions to read arbitrary
|
||||
bytes from a file on a web-server. This is particular interesting for
|
||||
an iso, since it can be investigated (loop device) without actually
|
||||
downloading the whole iso.
|
||||
|
||||
WWW: http://httpfs.sourceforge.net/
|
Loading…
Reference in a new issue