Add devel/grpc.

This commit is contained in:
Vanilla I. Shu 2017-04-26 03:31:33 +00:00
parent 1d3574577b
commit 3122b1a1b6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=439428
7 changed files with 358 additions and 0 deletions

View file

@ -817,6 +817,7 @@
SUBDIR += gradle
SUBDIR += grantlee
SUBDIR += grantlee5
SUBDIR += grpc
SUBDIR += grumpy
SUBDIR += gsettings-desktop-schemas
SUBDIR += gsoap

32
devel/grpc/Makefile Normal file
View file

@ -0,0 +1,32 @@
# Created by: vanilla@
# $FreeBSD$
PORTNAME= grpc
PORTVERSION= 1.2.5
DISTVERSIONPREFIX= v
CATEGORIES= devel
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Super fast C++ logging library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgflags.so:devel/gflags \
libprotobuf.so:devel/protobuf
USE_GITHUB= yes
GH_ACCOUNT= grpc
USES= cmake ssl
USE_LDCONFIG= yes
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm
CMAKE_ARGS= -DgRPC_ZLIB_PROVIDER:STRING="package" \
-DgRPC_PROTOBUF_PROVIDER:STRING="package" \
-DgRPC_GFLAGS_PROVIDER:STRING="package" \
-DgRPC_SSL_PROVIDER:STRING="package" \
-DBUILD_SHARED_LIBS=ON \
-DBUILD_STATIC_LIBS=ON
.include <bsd.port.mk>

3
devel/grpc/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1493132054
SHA256 (grpc-grpc-v1.2.5_GH0.tar.gz) = 44b60a7d2d6108ee569f970373401b57486146bc980bf4dd8187ed052e95cb83
SIZE (grpc-grpc-v1.2.5_GH0.tar.gz) = 4450406

View file

@ -0,0 +1,129 @@
--- CMakeLists.txt.orig 2017-03-20 21:16:13 UTC
+++ CMakeLists.txt
@@ -145,24 +145,14 @@ if("${gRPC_PROTOBUF_PROVIDER}" STREQUAL
if(TARGET libprotoc)
set(_gRPC_PROTOBUF_PROTOC_LIBRARIES libprotoc)
endif()
- if(TARGET protoc)
- set(_gRPC_PROTOBUF_PROTOC protoc)
- endif()
else()
message(WARNING "gRPC_PROTOBUF_PROVIDER is \"module\" but PROTOBUF_ROOT_DIR is wrong")
endif()
elseif("${gRPC_PROTOBUF_PROVIDER}" STREQUAL "package")
- find_package(protobuf CONFIG)
- if(protobuf_FOUND)
- if(TARGET protobuf::${_gRPC_PROTOBUF_LIBRARY_NAME})
- set(_gRPC_PROTOBUF_LIBRARIES protobuf::${_gRPC_PROTOBUF_LIBRARY_NAME})
- endif()
- if(TARGET protobuf::libprotoc)
- set(_gRPC_PROTOBUF_PROTOC_LIBRARIES protobuf::libprotoc)
- endif()
- if(TARGET protobuf::protoc)
- set(_gRPC_PROTOBUF_PROTOC protobuf::protoc)
- endif()
+ find_library(LIBPROTOBUF protobuf)
+ if(LIBPROTOBUF)
+ set(_gRPC_PROTOBUF_LIBRARIES protobuf)
+ set(_gRPC_PROTOBUF_PROTOC_LIBRARIES protoc)
set(_gRPC_FIND_PROTOBUF "if(NOT protobuf_FOUND)\n find_package(protobuf CONFIG)\nendif()")
else()
find_package(Protobuf MODULE)
@@ -237,7 +227,7 @@ if(NOT MSVC)
endif()
if(UNIX)
- set(_gRPC_ALLTARGETS_LIBRARIES dl rt m pthread)
+ set(_gRPC_ALLTARGETS_LIBRARIES rt m pthread)
endif()
if(WIN32 AND MSVC)
@@ -283,7 +273,7 @@ function(protobuf_generate_grpc_cpp)
"${_gRPC_PROTO_GENS_DIR}/${RELFIL_WE}.grpc.pb.h"
"${_gRPC_PROTO_GENS_DIR}/${RELFIL_WE}.pb.cc"
"${_gRPC_PROTO_GENS_DIR}/${RELFIL_WE}.pb.h"
- COMMAND ${_gRPC_PROTOBUF_PROTOC}
+ COMMAND "protoc"
ARGS --grpc_out=${_gRPC_PROTO_GENS_DIR}
--cpp_out=${_gRPC_PROTO_GENS_DIR}
--plugin=protoc-gen-grpc=$<TARGET_FILE:grpc_cpp_plugin>
@@ -730,6 +720,7 @@ add_library(gpr
src/core/lib/support/tmpfile_windows.c
src/core/lib/support/wrap_memcpy.c
)
+set_target_properties(gpr PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(gpr PROPERTIES COMPILE_PDB_NAME "gpr"
@@ -1078,6 +1069,7 @@ add_library(grpc
src/core/ext/census/tracing.c
src/core/plugin_registry/grpc_plugin_registry.c
)
+set_target_properties(grpc PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc PROPERTIES COMPILE_PDB_NAME "grpc"
@@ -1359,6 +1351,7 @@ add_library(grpc_cronet
src/core/ext/load_reporting/load_reporting_filter.c
src/core/plugin_registry/grpc_cronet_plugin_registry.c
)
+set_target_properties(grpc_cronet PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc_cronet PROPERTIES COMPILE_PDB_NAME "grpc_cronet"
@@ -1903,6 +1896,7 @@ add_library(grpc_unsecure
src/core/ext/census/tracing.c
src/core/plugin_registry/grpc_unsecure_plugin_registry.c
)
+set_target_properties(grpc_unsecure PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc_unsecure PROPERTIES COMPILE_PDB_NAME "grpc_unsecure"
@@ -2104,6 +2098,7 @@ add_library(grpc++
src/cpp/util/time_cc.cc
src/cpp/codegen/codegen_init.cc
)
+set_target_properties(grpc++ PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc++ PROPERTIES COMPILE_PDB_NAME "grpc++"
@@ -2473,6 +2468,7 @@ add_library(grpc++_cronet
third_party/nanopb/pb_decode.c
third_party/nanopb/pb_encode.c
)
+set_target_properties(grpc++_cronet PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc++_cronet PROPERTIES COMPILE_PDB_NAME "grpc++_cronet"
@@ -2694,6 +2690,7 @@ add_library(grpc++_reflection
${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/reflection/v1alpha/reflection.pb.h
${_gRPC_PROTO_GENS_DIR}/src/proto/grpc/reflection/v1alpha/reflection.grpc.pb.h
)
+set_target_properties(grpc++_reflection PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc++_reflection PROPERTIES COMPILE_PDB_NAME "grpc++_reflection"
@@ -2961,6 +2958,7 @@ add_library(grpc++_unsecure
src/cpp/util/time_cc.cc
src/cpp/codegen/codegen_init.cc
)
+set_target_properties(grpc++_unsecure PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc++_unsecure PROPERTIES COMPILE_PDB_NAME "grpc++_unsecure"
@@ -3220,6 +3218,7 @@ add_library(grpc_plugin_support
src/compiler/python_generator.cc
src/compiler/ruby_generator.cc
)
+set_target_properties(grpc_plugin_support PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc_plugin_support PROPERTIES COMPILE_PDB_NAME "grpc_plugin_support"
@@ -3697,6 +3696,7 @@ endif (gRPC_BUILD_TESTS)
add_library(grpc_csharp_ext SHARED
src/csharp/ext/grpc_csharp_ext.c
)
+set_target_properties(grpc_csharp_ext PROPERTIES VERSION ${PACKAGE_VERSION} SOVERSION 1)
if(WIN32 AND MSVC)
set_target_properties(grpc_csharp_ext PROPERTIES COMPILE_PDB_NAME "grpc_csharp_ext"

View file

@ -0,0 +1,10 @@
--- src/core/lib/tsi/ssl_transport_security.c.orig 2017-03-20 21:16:13 UTC
+++ src/core/lib/tsi/ssl_transport_security.c
@@ -35,6 +35,7 @@
#include <grpc/support/port_platform.h>
+#include <sys/socket.h>
#include <limits.h>
#include <string.h>

3
devel/grpc/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
Super fast C++ logging library.
WWW: https://github.com/gabime/spdlog

180
devel/grpc/pkg-plist Normal file
View file

@ -0,0 +1,180 @@
bin/gen_hpack_tables
bin/gen_legal_metadata_characters
bin/gen_percent_encoding_tables
bin/grpc_cpp_plugin
bin/grpc_create_jwt
bin/grpc_csharp_plugin
bin/grpc_node_plugin
bin/grpc_objective_c_plugin
bin/grpc_php_plugin
bin/grpc_print_google_default_creds_token
bin/grpc_python_plugin
bin/grpc_ruby_plugin
bin/grpc_verify_jwt
include/grpc++/alarm.h
include/grpc++/channel.h
include/grpc++/client_context.h
include/grpc++/completion_queue.h
include/grpc++/create_channel.h
include/grpc++/create_channel_posix.h
include/grpc++/ext/health_check_service_server_builder_option.h
include/grpc++/ext/proto_server_reflection_plugin.h
include/grpc++/generic/async_generic_service.h
include/grpc++/generic/generic_stub.h
include/grpc++/grpc++.h
include/grpc++/health_check_service_interface.h
include/grpc++/impl/call.h
include/grpc++/impl/client_unary_call.h
include/grpc++/impl/codegen/async_stream.h
include/grpc++/impl/codegen/async_unary_call.h
include/grpc++/impl/codegen/call.h
include/grpc++/impl/codegen/call_hook.h
include/grpc++/impl/codegen/channel_interface.h
include/grpc++/impl/codegen/client_context.h
include/grpc++/impl/codegen/client_unary_call.h
include/grpc++/impl/codegen/completion_queue.h
include/grpc++/impl/codegen/completion_queue_tag.h
include/grpc++/impl/codegen/config.h
include/grpc++/impl/codegen/config_protobuf.h
include/grpc++/impl/codegen/core_codegen.h
include/grpc++/impl/codegen/core_codegen_interface.h
include/grpc++/impl/codegen/create_auth_context.h
include/grpc++/impl/codegen/grpc_library.h
include/grpc++/impl/codegen/metadata_map.h
include/grpc++/impl/codegen/method_handler_impl.h
include/grpc++/impl/codegen/proto_utils.h
include/grpc++/impl/codegen/rpc_method.h
include/grpc++/impl/codegen/rpc_service_method.h
include/grpc++/impl/codegen/security/auth_context.h
include/grpc++/impl/codegen/serialization_traits.h
include/grpc++/impl/codegen/server_context.h
include/grpc++/impl/codegen/server_interface.h
include/grpc++/impl/codegen/service_type.h
include/grpc++/impl/codegen/slice.h
include/grpc++/impl/codegen/status.h
include/grpc++/impl/codegen/status_code_enum.h
include/grpc++/impl/codegen/status_helper.h
include/grpc++/impl/codegen/string_ref.h
include/grpc++/impl/codegen/stub_options.h
include/grpc++/impl/codegen/sync_stream.h
include/grpc++/impl/codegen/time.h
include/grpc++/impl/grpc_library.h
include/grpc++/impl/method_handler_impl.h
include/grpc++/impl/rpc_method.h
include/grpc++/impl/rpc_service_method.h
include/grpc++/impl/serialization_traits.h
include/grpc++/impl/server_builder_option.h
include/grpc++/impl/server_builder_plugin.h
include/grpc++/impl/server_initializer.h
include/grpc++/impl/service_type.h
include/grpc++/resource_quota.h
include/grpc++/security/auth_context.h
include/grpc++/security/auth_metadata_processor.h
include/grpc++/security/credentials.h
include/grpc++/security/server_credentials.h
include/grpc++/server.h
include/grpc++/server_builder.h
include/grpc++/server_context.h
include/grpc++/server_posix.h
include/grpc++/support/async_stream.h
include/grpc++/support/async_unary_call.h
include/grpc++/support/byte_buffer.h
include/grpc++/support/channel_arguments.h
include/grpc++/support/config.h
include/grpc++/support/slice.h
include/grpc++/support/status.h
include/grpc++/support/status_code_enum.h
include/grpc++/support/string_ref.h
include/grpc++/support/stub_options.h
include/grpc++/support/sync_stream.h
include/grpc++/support/time.h
include/grpc/byte_buffer.h
include/grpc/byte_buffer_reader.h
include/grpc/census.h
include/grpc/compression.h
include/grpc/grpc.h
include/grpc/grpc_cronet.h
include/grpc/grpc_posix.h
include/grpc/grpc_security.h
include/grpc/grpc_security_constants.h
include/grpc/impl/codegen/atm.h
include/grpc/impl/codegen/atm_gcc_atomic.h
include/grpc/impl/codegen/atm_gcc_sync.h
include/grpc/impl/codegen/atm_windows.h
include/grpc/impl/codegen/byte_buffer_reader.h
include/grpc/impl/codegen/compression_types.h
include/grpc/impl/codegen/connectivity_state.h
include/grpc/impl/codegen/exec_ctx_fwd.h
include/grpc/impl/codegen/gpr_slice.h
include/grpc/impl/codegen/gpr_types.h
include/grpc/impl/codegen/grpc_types.h
include/grpc/impl/codegen/port_platform.h
include/grpc/impl/codegen/propagation_bits.h
include/grpc/impl/codegen/slice.h
include/grpc/impl/codegen/status.h
include/grpc/impl/codegen/sync.h
include/grpc/impl/codegen/sync_generic.h
include/grpc/impl/codegen/sync_posix.h
include/grpc/impl/codegen/sync_windows.h
include/grpc/load_reporting.h
include/grpc/slice.h
include/grpc/slice_buffer.h
include/grpc/status.h
include/grpc/support/alloc.h
include/grpc/support/atm.h
include/grpc/support/atm_gcc_atomic.h
include/grpc/support/atm_gcc_sync.h
include/grpc/support/atm_windows.h
include/grpc/support/avl.h
include/grpc/support/cmdline.h
include/grpc/support/cpu.h
include/grpc/support/histogram.h
include/grpc/support/host_port.h
include/grpc/support/log.h
include/grpc/support/log_windows.h
include/grpc/support/port_platform.h
include/grpc/support/string_util.h
include/grpc/support/subprocess.h
include/grpc/support/sync.h
include/grpc/support/sync_generic.h
include/grpc/support/sync_posix.h
include/grpc/support/sync_windows.h
include/grpc/support/thd.h
include/grpc/support/time.h
include/grpc/support/tls.h
include/grpc/support/tls_gcc.h
include/grpc/support/tls_msvc.h
include/grpc/support/tls_pthread.h
include/grpc/support/useful.h
lib/cmake/gRPC/gRPCConfig.cmake
lib/cmake/gRPC/gRPCConfigVersion.cmake
lib/libgpr.so
lib/libgpr.so.1
lib/libgpr.so.1.2.5
lib/libgrpc++.so
lib/libgrpc++.so.1
lib/libgrpc++.so.1.2.5
lib/libgrpc++_cronet.so
lib/libgrpc++_cronet.so.1
lib/libgrpc++_cronet.so.1.2.5
lib/libgrpc++_reflection.so
lib/libgrpc++_reflection.so.1
lib/libgrpc++_reflection.so.1.2.5
lib/libgrpc++_unsecure.so
lib/libgrpc++_unsecure.so.1
lib/libgrpc++_unsecure.so.1.2.5
lib/libgrpc.so
lib/libgrpc.so.1
lib/libgrpc.so.1.2.5
lib/libgrpc_cronet.so
lib/libgrpc_cronet.so.1
lib/libgrpc_cronet.so.1.2.5
lib/libgrpc_csharp_ext.so
lib/libgrpc_csharp_ext.so.1
lib/libgrpc_csharp_ext.so.1.2.5
lib/libgrpc_plugin_support.so
lib/libgrpc_plugin_support.so.1
lib/libgrpc_plugin_support.so.1.2.5
lib/libgrpc_unsecure.so
lib/libgrpc_unsecure.so.1
lib/libgrpc_unsecure.so.1.2.5