devel/cpp2py: Update 1.5.20200812 -> 2.0.0
This commit is contained in:
parent
4f871c3925
commit
3137c94f5c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=549454
4 changed files with 26 additions and 11 deletions
|
@ -1,9 +1,12 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= cpp2py
|
||||
DISTVERSION= 1.5.20200812
|
||||
DISTVERSION= 2.0.0
|
||||
CATEGORIES= devel
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES= 44d5238ab4f05ed4064736ffd2f2b63438d3f64c.patch:-p1 # fix build on i386
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= Reflection tools based on clang
|
||||
|
||||
|
@ -19,19 +22,22 @@ BUILD_DEPENDS= ${PY_DEPENDS} \
|
|||
RUN_DEPENDS= ${PY_DEPENDS} \
|
||||
llvm${LLVM_VER}>0:devel/llvm${LLVM_VER}
|
||||
|
||||
USES= cmake compiler:c++14-lang python shebangfix
|
||||
USES= cmake compiler:c++14-lang gettext-runtime python shebangfix
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= TRIQS
|
||||
GH_TAGNAME= 10ab97d2e5e56656227a74118943de02e2265292
|
||||
|
||||
SHEBANG_FILES= bin/c*
|
||||
|
||||
CMAKE_ARGS= -DPYTHON_INTERPRETER:STRING=${PYTHON_CMD} \
|
||||
-DFREEBSD_LLVM_VER:STRING=${LLVM_VER}
|
||||
|
||||
LLVM_VER= 60
|
||||
LLVM_VER= 10
|
||||
|
||||
PORTSCOUT= limit:^[0-9\.]*$$
|
||||
|
||||
post-install: # remove unnecessary files
|
||||
@cd ${STAGEDIR}${PREFIX} && ${RM} share/cpp2py.modulefile share/cpp2pyvars.sh
|
||||
post-install: # remove the unnecessary file: https://github.com/TRIQS/cpp2py/issues/41
|
||||
@${RM} ${STAGEDIR}${PREFIX}/share/cpp2pyvars.sh
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,5 @@
|
|||
TIMESTAMP = 1597389977
|
||||
SHA256 (TRIQS-cpp2py-1.5.20200812-10ab97d2e5e56656227a74118943de02e2265292_GH0.tar.gz) = 009d0114688a763c98cf4a63eee3396426cde170306cb117fa61613b604d5223
|
||||
SIZE (TRIQS-cpp2py-1.5.20200812-10ab97d2e5e56656227a74118943de02e2265292_GH0.tar.gz) = 87916
|
||||
TIMESTAMP = 1600704743
|
||||
SHA256 (TRIQS-cpp2py-2.0.0_GH0.tar.gz) = df67dc69ef3a57c615f39ea14b63bb00309adfaf6130e64cf84b2df1553696f6
|
||||
SIZE (TRIQS-cpp2py-2.0.0_GH0.tar.gz) = 87867
|
||||
SHA256 (44d5238ab4f05ed4064736ffd2f2b63438d3f64c.patch) = a48322e9173c978e622ec363316275e66838fca9bc35de7ffec968fd7bb6c8d0
|
||||
SIZE (44d5238ab4f05ed4064736ffd2f2b63438d3f64c.patch) = 1684
|
||||
|
|
8
devel/cpp2py/files/patch-c++_cpp2py_CMakeLists.txt
Normal file
8
devel/cpp2py/files/patch-c++_cpp2py_CMakeLists.txt
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- c++/cpp2py/CMakeLists.txt.orig 2020-08-17 21:09:23 UTC
|
||||
+++ c++/cpp2py/CMakeLists.txt
|
||||
@@ -1,4 +1,4 @@
|
||||
-add_library(cpp2py signal_handler.cpp exceptions.cpp numpy_proxy.cpp)
|
||||
+add_library(cpp2py SHARED signal_handler.cpp exceptions.cpp numpy_proxy.cpp)
|
||||
add_library(cpp2py::cpp2py ALIAS cpp2py)
|
||||
|
||||
target_compile_options(cpp2py PRIVATE -std=c++17 -fPIC)
|
|
@ -1,7 +1,6 @@
|
|||
bin/c++2cxx
|
||||
bin/c++2py
|
||||
bin/c++2rst
|
||||
bin/cp_rs
|
||||
include/cpp2py/converters/basic_types.hpp
|
||||
include/cpp2py/converters/complex.hpp
|
||||
include/cpp2py/converters/function.hpp
|
||||
|
@ -29,7 +28,7 @@ lib/cmake/Cpp2Py/Cpp2PyConfig.cmake
|
|||
lib/cmake/Cpp2Py/Cpp2PyConfigVersion.cmake
|
||||
lib/cmake/Cpp2Py/Cpp2PyTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
||||
lib/cmake/Cpp2Py/Cpp2PyTargets.cmake
|
||||
lib/libcpp2py.a
|
||||
lib/libcpp2py.so
|
||||
%%PYTHON_SITELIBDIR%%/cpp2cxx/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/cpp2cxx/cpp2cxx.py
|
||||
%%PYTHON_SITELIBDIR%%/cpp2py/__init__.py
|
||||
|
|
Loading…
Reference in a new issue