Add upstream commit to make the port build with the upcoming CMake 3.4.0.

This commit is contained in:
Raphael Kubo da Costa 2015-11-26 14:38:07 +00:00
parent 0f93502c68
commit 3160bb01ac
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=402449

View file

@ -0,0 +1,19 @@
commit 4a1a90ee1b2b4d13302046f043adf1c2a1de758d
Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
Date: Thu Nov 26 15:36:26 2015 +0100
Explicitly include CheckIncludeFiles.
This fixes the build with CMake 3.4.0. We were calling check_include_files()
and implicitly relying on CheckIncludeFiles being included.
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -21,6 +21,7 @@ if(STRICT_BUILD)
-DQT_NO_URL_CAST_FROM_STRING -DQT_STRICT_ITERATORS)
endif(STRICT_BUILD)
+include(CheckIncludeFiles)
check_include_files(${CMAKE_CURRENT_SOURCE_DIR}/include/frontend.h HAVE_DVB)
if(NOT HAVE_DVB)