Update to 1.2.1.

This commit is contained in:
Anders Nordby 2002-11-23 23:20:38 +00:00
parent 672b7b1d92
commit 317df2f3b5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70915
7 changed files with 66 additions and 61 deletions

View file

@ -6,35 +6,36 @@
#
PORTNAME= gringotts
PORTVERSION= 0.7.0
PORTVERSION= 1.2.1
CATEGORIES= security
MASTER_SITES= http://devel.pluto.linux.it/projects/Gringotts/current/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
MAINTAINER= anders@FreeBSD.org
LIB_DEPENDS= mcrypt.7:${PORTSDIR}/security/libmcrypt \
mhash.2:${PORTSDIR}/security/mhash \
LIB_DEPENDS= gringotts.2:${PORTSDIR}/security/libgringotts \
gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
popt.0:${PORTSDIR}/devel/popt
USE_BZIP2= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
USE_GNOMENG= yes
USE_REINPLACE= yes
WANT_GNOME= yes
CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS+= --disable-env-check
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mgnomehier}!=""
USE_GNOME+= gnomehier
.else
.endif
post-patch:
@${PATCH} < ${FILESDIR}/gnomeless-Makefile.in \
${WRKSRC}/Makefile.in >/dev/null 2>&1
${REINPLACE_CMD} -e "s|md5sum|md5|g" ${WRKSRC}/Makefile.in
.if ${HAVE_GNOME:Mgnomehier}==""
${REINPLACE_CMD} -E "s|(MAKE.*AM_MAKEFLAGS.*install-exec-am).*|\1|" \
${WRKSRC}/Makefile.in
.endif
.include <bsd.port.post.mk>

View file

@ -1 +1 @@
MD5 (gringotts-0.7.0.tar.bz2) = 2659807b62ca18ebe192b782d6903ad3
MD5 (gringotts-1.2.1.tar.bz2) = 1460fc3e52b1bca9c472212a78b5197f

View file

@ -1,11 +0,0 @@
--- Makefile.in.orig Sat Oct 26 14:18:54 2002
+++ Makefile.in Sat Oct 26 14:19:08 2002
@@ -367,7 +367,7 @@
install-data: install-data-recursive
install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am
install: install-recursive
uninstall-am: uninstall-DsktpDATA uninstall-local
uninstall: uninstall-recursive

View file

@ -1,16 +0,0 @@
--- Makefile.in.orig Sat Oct 26 14:05:36 2002
+++ Makefile.in Sat Oct 26 14:06:01 2002
@@ -441,10 +441,10 @@
@echo
@echo
@echo ----------------------------------------------------------------------
- @echo md5sum of relevant files:
+ @echo md5 checksum of relevant files:
@echo
- @md5sum $(DESTDIR)$(bindir)/gringotts|(read A B; echo $$B ": " $$A)
- @md5sum $(DESTDIR)$(libdir)/libgringotts.so|(read A B; echo $$B ": " $$A)
+ @md5 $(DESTDIR)$(bindir)/gringotts|(read A B; echo $$B ": " $$A)
+ @md5 $(DESTDIR)$(libdir)/libgringotts.so|(read A B; echo $$B ": " $$A)
@echo
@echo use these values to check program integrity at any time
@echo ----------------------------------------------------------------------

View file

@ -0,0 +1,37 @@
--- src/grg_pwd.c.orig Sat Nov 23 20:32:53 2002
+++ src/grg_pwd.c Sat Nov 23 20:34:32 2002
@@ -23,7 +23,6 @@
#include <fcntl.h>
#include <sys/stat.h>
#include <sys/mman.h>
-#include <linux/fd.h>
#include <sys/ioctl.h>
#include <signal.h>
@@ -129,7 +128,6 @@
gint fd, len;
gchar *file;
GRG_KEY key = NULL;
- struct floppy_drive_struct fstruct;
fd = open ("/dev/fd0", O_RDONLY);
@@ -138,18 +136,6 @@
{
grg_msg (_("Please insert a disk in the first floppy drive"),
GTK_MESSAGE_ERROR, dlg);
- return NULL;
- }
-
- //check for write protection
- ioctl (fd, FDGETDRVSTAT, &fstruct);
-
- if ((fstruct.flags >> FD_DISK_WRITABLE_BIT) & 1)
- {
- grg_msg (_
- ("The disk is not write protected. For security reasons, I'll not use it."),
- GTK_MESSAGE_ERROR, dlg);
- close (fd);
return NULL;
}

View file

@ -1,6 +1,6 @@
--- src/grg_safe.c.orig Sat Oct 26 14:09:40 2002
+++ src/grg_safe.c Sat Oct 26 14:15:28 2002
@@ -34,6 +34,7 @@
--- src/grg_safe.c.orig Sat Nov 23 18:42:36 2002
+++ src/grg_safe.c Sat Nov 23 18:43:22 2002
@@ -33,6 +33,7 @@
#include <stdlib.h>
#include <string.h>
@ -8,7 +8,7 @@
#include <regex.h>
#include <unistd.h>
#include <fcntl.h>
@@ -43,7 +44,6 @@
@@ -42,7 +43,6 @@
#include <sys/fsuid.h>
#endif
#include <sys/time.h>
@ -16,21 +16,21 @@
#include <sys/resource.h>
#define GRG_SAFE 0
@@ -64,8 +64,6 @@
@@ -56,8 +56,6 @@
grg_mlockall_and_drop_root_privileges (void)
{
//drop eventual group root privileges
- setgid (getgid ());
- setgid (getgid ()); //twice for counter "saved IDs", cfr. Secure Programming HowTo
#ifdef HAVE_SYS_FSUID_H
setfsgid (getgid ());
setfsgid (getgid ());
@@ -81,8 +79,6 @@
#endif
//drop eventual group root privileges
- setgid(getgid ());
- setgid(getgid ()); //twice for counter "saved IDs", cfr. Secure Programming HowTo
//drop root privileges
- setuid (getuid ());
- setuid (getuid ());
#ifdef HAVE_SYS_FSUID_H
setfsgid(getgid ());
setfsgid(getgid ());
@@ -84,8 +82,6 @@
#endif
//drop root privileges
- setuid(getuid());
- setuid(getuid());
#ifdef HAVE_SYS_FSUID_H
setfsuid(getuid());
setfsuid(getuid());
setfsuid (getuid ());
setfsuid (getuid ());

View file

@ -1,10 +1,4 @@
bin/gringotts
include/libgringotts.h
lib/libgringotts.so.2
lib/libgringotts.so
lib/libgringotts.la
lib/libgringotts.a
libdata/pkgconfig/libgringotts.pc
share/pixmaps/gringotts.xpm
share/locale/de/LC_MESSAGES/gringotts.mo
share/locale/fr/LC_MESSAGES/gringotts.mo