Change the default remote protocol from RSH to SSH.
Submitted by: knu
This commit is contained in:
parent
e65592ef9d
commit
31bb97e684
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=39247
6 changed files with 58 additions and 0 deletions
|
@ -8,6 +8,7 @@
|
|||
|
||||
PORTNAME= rsync
|
||||
PORTVERSION= 2.4.6
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= net ipv6
|
||||
MASTER_SITES= ftp://samba.anu.edu.au/pub/rsync/ \
|
||||
ftp://sunsite.auc.dk/pub/unix/rsync/ \
|
||||
|
@ -25,6 +26,16 @@ GNU_CONFIGURE= yes
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 400016
|
||||
USE_SSH?= yes
|
||||
.else
|
||||
USE_SSH?= no
|
||||
.endif
|
||||
|
||||
.if ${USE_SSH:U} == YES
|
||||
EXTRA_PATCHES= ${FILESDIR}/ssh-patch-*
|
||||
.endif
|
||||
|
||||
.if ${OSVERSION} >= 400014
|
||||
CONFIGURE_ARGS= --enable-ipv6
|
||||
.else
|
||||
|
@ -48,5 +59,6 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/doc/rsync
|
||||
${INSTALL_DATA} ${WRKSRC}/tech_report.tex ${PREFIX}/share/doc/rsync
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
8
net/rsync/files/ssh-patch-README
Normal file
8
net/rsync/files/ssh-patch-README
Normal file
|
@ -0,0 +1,8 @@
|
|||
--- README.orig Tue Sep 5 19:46:43 2000
|
||||
+++ README Thu Mar 8 03:31:32 2001
|
||||
@@ -60 +60 @@
|
||||
- -e, --rsh=COMMAND specify rsh replacement
|
||||
+ -e, --rsh=COMMAND specify rsh replacement (default ssh)
|
||||
@@ -96 +96 @@
|
||||
-rsh or ssh system. Using ssh is recommended for its security
|
||||
+rsh or ssh system. Using rsh is discouraged for lack of security
|
5
net/rsync/files/ssh-patch-options.c
Normal file
5
net/rsync/files/ssh-patch-options.c
Normal file
|
@ -0,0 +1,5 @@
|
|||
--- options.c.orig Thu Mar 8 03:31:32 2001
|
||||
+++ options.c Thu Mar 8 03:31:32 2001
|
||||
@@ -141 +141 @@
|
||||
- rprintf(F," -e, --rsh=COMMAND specify rsh replacement\n");
|
||||
+ rprintf(F," -e, --rsh=COMMAND specify rsh replacement (default %s)\n", RSYNC_RSH);
|
21
net/rsync/files/ssh-patch-rsync.1
Normal file
21
net/rsync/files/ssh-patch-rsync.1
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- rsync.1.orig Tue Sep 5 19:46:43 2000
|
||||
+++ rsync.1 Thu Mar 8 03:34:47 2001
|
||||
@@ -89,2 +89,2 @@
|
||||
-Once installed you can use rsync to any machine that you can use rsh
|
||||
-to\&. rsync uses rsh for its communications, unless both the source and
|
||||
+Once installed you can use rsync to any machine that you can use ssh
|
||||
+to\&. rsync uses ssh for its communications, unless both the source and
|
||||
@@ -93 +93 @@
|
||||
-You can also specify an alternative to rsh, by either using the -e
|
||||
+You can also specify an alternative to ssh, by either using the -e
|
||||
@@ -273 +273 @@
|
||||
- -e, --rsh=COMMAND specify rsh replacement
|
||||
+ -e, --rsh=COMMAND specify rsh replacement (default ssh)
|
||||
@@ -566,2 +566,2 @@
|
||||
-remote copies of rsync\&. By default, rsync will use rsh, but you may
|
||||
-like to instead use ssh because of its high security\&.
|
||||
+remote copies of rsync\&. By default, rsync will use ssh, but you may
|
||||
+need to use the much less secure rsh for compatibility reasons\&.
|
||||
@@ -890 +890 @@
|
||||
- rsh remotehost /bin/true > out\&.dat
|
||||
+ ssh remotehost /bin/true > out\&.dat
|
5
net/rsync/files/ssh-patch-rsync.h
Normal file
5
net/rsync/files/ssh-patch-rsync.h
Normal file
|
@ -0,0 +1,5 @@
|
|||
--- rsync.h.orig Sat Aug 19 06:10:39 2000
|
||||
+++ rsync.h Thu Mar 8 03:31:33 2001
|
||||
@@ -75 +75 @@
|
||||
-#define RSYNC_RSH "rsh"
|
||||
+#define RSYNC_RSH "ssh"
|
7
net/rsync/pkg-message
Normal file
7
net/rsync/pkg-message
Normal file
|
@ -0,0 +1,7 @@
|
|||
************************************************************
|
||||
Note that rsync now uses SSH as the transport by default.
|
||||
|
||||
If you still need to use RSH instead, please specify
|
||||
"-e rsh" in the rsync command line or set the environment
|
||||
variable RSYNC_RSH to "rsh".
|
||||
************************************************************
|
Loading…
Reference in a new issue