Add php5-phar extension.
PR: ports/162807 Submitted by: Oleg Pudeyev <oleg@bsdpower.com> Feature safe: yes
This commit is contained in:
parent
9e6092dc00
commit
31f3c6a656
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286403
4 changed files with 67 additions and 0 deletions
|
@ -132,6 +132,7 @@
|
|||
SUBDIR += php4-bz2
|
||||
SUBDIR += php4-zlib
|
||||
SUBDIR += php5-bz2
|
||||
SUBDIR += php5-phar
|
||||
SUBDIR += php5-zip
|
||||
SUBDIR += php5-zlib
|
||||
SUBDIR += php52-bz2
|
||||
|
|
14
archivers/php5-phar/Makefile
Normal file
14
archivers/php5-phar/Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
# New ports collection makefile for: php5-phar
|
||||
# Date created: 25 Nov 2011
|
||||
# Whom: Alex Dupre <ale@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
CATEGORIES= archivers
|
||||
|
||||
MASTERDIR= ${.CURDIR}/../../lang/php5
|
||||
|
||||
PKGNAMESUFFIX= -phar
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
41
archivers/php5-phar/files/patch-config.m4
Normal file
41
archivers/php5-phar/files/patch-config.m4
Normal file
|
@ -0,0 +1,41 @@
|
|||
--- config.m4.orig 2011-11-25 15:31:20.000000000 +0100
|
||||
+++ config.m4 2011-11-25 15:47:45.000000000 +0100
|
||||
@@ -4,8 +4,38 @@
|
||||
PHP_ARG_ENABLE(phar, for phar archive support,
|
||||
[ --disable-phar Disable phar support], yes)
|
||||
|
||||
+PHP_ARG_WITH(pcre-dir, pcre install prefix,
|
||||
+[ --with-pcre-dir PHAR: pcre install prefix], no, no)
|
||||
+
|
||||
+
|
||||
if test "$PHP_PHAR" != "no"; then
|
||||
+
|
||||
+ dnl This is PECL build, check if bundled PCRE library is used
|
||||
+ old_CPPFLAGS=$CPPFLAGS
|
||||
+ CPPFLAGS=$INCLUDES
|
||||
+ AC_EGREP_CPP(yes,[
|
||||
+#include <main/php_config.h>
|
||||
+#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
|
||||
+yes
|
||||
+#endif
|
||||
+ ],[
|
||||
+ PHP_PCRE_REGEX=yes
|
||||
+ ],[
|
||||
+ AC_EGREP_CPP(yes,[
|
||||
+#include <main/php_config.h>
|
||||
+#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
|
||||
+yes
|
||||
+#endif
|
||||
+ ],[
|
||||
+ PHP_PCRE_REGEX=pecl
|
||||
+ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
|
||||
+ ],[
|
||||
+ PHP_PCRE_REGEX=no
|
||||
+ ])
|
||||
+ ])
|
||||
+
|
||||
PHP_NEW_EXTENSION(phar, util.c tar.c zip.c stream.c func_interceptors.c dirstream.c phar.c phar_object.c phar_path_check.c, $ext_shared)
|
||||
+ PHP_HASH=yes
|
||||
AC_MSG_CHECKING([for phar openssl support])
|
||||
if test "$PHP_HASH_SHARED" != "yes"; then
|
||||
if test "$PHP_HASH" != "no"; then
|
11
archivers/php5-phar/files/patch-phar.c
Normal file
11
archivers/php5-phar/files/patch-phar.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- phar.c.orig 2011-11-25 15:38:44.000000000 +0100
|
||||
+++ phar.c 2011-11-25 15:39:01.000000000 +0100
|
||||
@@ -3716,7 +3716,7 @@
|
||||
ZEND_MOD_OPTIONAL("openssl")
|
||||
ZEND_MOD_OPTIONAL("zlib")
|
||||
ZEND_MOD_OPTIONAL("standard")
|
||||
-#if defined(HAVE_HASH) && !defined(COMPILE_DL_HASH)
|
||||
+#if defined(HAVE_HASH)
|
||||
ZEND_MOD_REQUIRED("hash")
|
||||
#endif
|
||||
#if HAVE_SPL
|
Loading…
Reference in a new issue