PyBlosxom, a light wight weblog system like blosxom with focus on simplicity,
extensibility, and community. PR: ports/79855 Submitted by: Dryice Liu <dryice@liu.com.cn>
This commit is contained in:
parent
e39458901a
commit
322bff4f9d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133416
7 changed files with 129 additions and 0 deletions
|
@ -644,6 +644,7 @@
|
||||||
SUBDIR += py-websvcs
|
SUBDIR += py-websvcs
|
||||||
SUBDIR += py-webware
|
SUBDIR += py-webware
|
||||||
SUBDIR += py-webware-component
|
SUBDIR += py-webware-component
|
||||||
|
SUBDIR += pyblosxom
|
||||||
SUBDIR += pyphany
|
SUBDIR += pyphany
|
||||||
SUBDIR += pyweblib
|
SUBDIR += pyweblib
|
||||||
SUBDIR += qdecoder
|
SUBDIR += qdecoder
|
||||||
|
|
31
www/pyblosxom/Makefile
Normal file
31
www/pyblosxom/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
||||||
|
# New ports collection makefile for: pyblosxom
|
||||||
|
# Date created: 13 April 2005
|
||||||
|
# Whom: Dryice Liu <dryice@liu.com.cn>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= pyblosxom
|
||||||
|
PORTVERSION= 1.2
|
||||||
|
CATEGORIES= www python
|
||||||
|
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||||
|
http://bsdchat.com/dist/dryice/
|
||||||
|
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||||
|
|
||||||
|
MAINTAINER= dryice@liu.com.cn
|
||||||
|
COMMENT= A lightweight weblog system
|
||||||
|
|
||||||
|
USE_PYTHON= 2.2+
|
||||||
|
USE_PYDISTUTILS= yes
|
||||||
|
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${PORTVERSION}
|
||||||
|
|
||||||
|
post-install:
|
||||||
|
.if !defined(NOPORTDOCS)
|
||||||
|
${MKDIR} ${DOCSDIR}
|
||||||
|
.for docfile in ChangeLog INSTALL LICENSE README
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
|
||||||
|
.endfor
|
||||||
|
.endif
|
||||||
|
@${CAT} ${PKGMESSAGE}
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
2
www/pyblosxom/distinfo
Normal file
2
www/pyblosxom/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
MD5 (pyblosxom-1.2.tar.gz) = de3cb536c0c86c1ce0450b2e425ff194
|
||||||
|
SIZE (pyblosxom-1.2.tar.gz) = 95469
|
11
www/pyblosxom/files/patch-setup.py
Normal file
11
www/pyblosxom/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- setup.py.orig Sun Mar 27 00:05:18 2005
|
||||||
|
+++ setup.py Wed Apr 13 17:17:06 2005
|
||||||
|
@@ -64,7 +64,7 @@
|
||||||
|
|
||||||
|
# we want to move the web script files as well, so we sneak them
|
||||||
|
# in here.
|
||||||
|
- pydf.append( [os.path.join('share', PVER, 'web'),
|
||||||
|
+ pydf.append( [os.path.join('share/examples', PVER),
|
||||||
|
[os.path.normpath("web/pyblosxom.cgi"),
|
||||||
|
os.path.normpath("web/pyblosxom.tac"),
|
||||||
|
os.path.normpath("web/pyblosxom_wsgi.cgi"),
|
20
www/pyblosxom/pkg-descr
Normal file
20
www/pyblosxom/pkg-descr
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
PyBlosxom is a lightweight weblog system. It originally started out as
|
||||||
|
a Python clone of Blosxom but has since evolved into a beast of its
|
||||||
|
own. PyBlosxom focuses on three things: simplicity, extensibility, and
|
||||||
|
community.
|
||||||
|
|
||||||
|
simplicity - PyBlosxom uses the file system for all its data
|
||||||
|
storage. Because of this you can use whatever editor you want to use
|
||||||
|
to create, update, and manipulate entries.
|
||||||
|
|
||||||
|
extensibility - PyBlosxom has plugin framework allowing you to build
|
||||||
|
plugins in Python to augment and change PyBlosxom's default behavior.
|
||||||
|
|
||||||
|
community - There are hundreds of PyBlosxom users out there all of
|
||||||
|
whom have different needs. PyBlosxom is used on a variety of operating
|
||||||
|
systems in a variety of environments.
|
||||||
|
|
||||||
|
PyBlosxom is a pretty straight-forward system that allows you to do
|
||||||
|
the things you need to do without building everything from scratch.
|
||||||
|
|
||||||
|
WWW: http://pyblosxom.sf.net
|
4
www/pyblosxom/pkg-message
Normal file
4
www/pyblosxom/pkg-message
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
*******************************************************************
|
||||||
|
* To get started, copy config.py and one of the running script in *
|
||||||
|
* the example dir and modify config.py. *
|
||||||
|
*******************************************************************
|
60
www/pyblosxom/pkg-plist
Normal file
60
www/pyblosxom/pkg-plist
Normal file
|
@ -0,0 +1,60 @@
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/__init__.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/__init__.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/__init__.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/__init__.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/__init__.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/__init__.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/base.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/base.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/base.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/entrypickle.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/entrypickle.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/entrypickle.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/entryshelve.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/entryshelve.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/cache/entryshelve.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/__init__.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/__init__.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/__init__.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/base.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/base.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/base.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/fileentry.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/fileentry.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/entries/fileentry.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/plugin_utils.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/plugin_utils.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/plugin_utils.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/pyblosxom.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/pyblosxom.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/pyblosxom.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/__init__.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/__init__.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/__init__.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/base.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/base.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/base.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/blosxom.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/blosxom.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/blosxom.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/debug.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/debug.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/renderers/debug.pyo
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/tools.py
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/tools.pyc
|
||||||
|
%%PYTHON_SITELIBDIR%%/Pyblosxom/tools.pyo
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||||
|
%%EXAMPLESDIR%%/config.py
|
||||||
|
%%EXAMPLESDIR%%/pyblosxom.cgi
|
||||||
|
%%EXAMPLESDIR%%/pyblosxom.tac
|
||||||
|
%%EXAMPLESDIR%%/pyblosxom_wsgi.cgi
|
||||||
|
%%EXAMPLESDIR%%/wsgi_app.py
|
||||||
|
@dirrm %%EXAMPLESDIR%%
|
||||||
|
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||||
|
@dirrm %%PYTHON_SITELIBDIR%%/Pyblosxom/renderers
|
||||||
|
@dirrm %%PYTHON_SITELIBDIR%%/Pyblosxom/entries
|
||||||
|
@dirrm %%PYTHON_SITELIBDIR%%/Pyblosxom/cache
|
||||||
|
@dirrm %%PYTHON_SITELIBDIR%%/Pyblosxom
|
Loading…
Reference in a new issue