- Update to 0.6.1

- Add patches: THRIFT-1102, THRIFT-705

Changes:	http://svn.apache.org/viewvc/thrift/tags/thrift-0.6.1/CHANGES?revision=1096491&view=co
PR:		ports/159380
Submitted by:	Gasol Wu <gasol.wu@gmail.com>
This commit is contained in:
Sergey Skvortsov 2011-08-11 22:37:13 +00:00
parent d2da483e52
commit 3304a6db7c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=279511
9 changed files with 45 additions and 17 deletions

View file

@ -6,7 +6,7 @@
#
PORTNAME= Thrift
PORTVERSION= 0.3.0
PORTVERSION= 0.6.1
PORTEPOCH= 1
CATEGORIES= devel perl5
PKGNAMEPREFIX= p5-

View file

@ -6,7 +6,7 @@
#
PORTNAME= thrift
PORTVERSION= 0.3.0
PORTVERSION= 0.5.0
PORTEPOCH= 1
CATEGORIES= devel python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -6,7 +6,7 @@
#
PORTNAME= thrift
PORTVERSION= 0.3.0
PORTVERSION= 0.6.1
PORTEPOCH= 1
CATEGORIES= devel
PKGNAMEPREFIX= ruby-

View file

@ -6,7 +6,7 @@
#
PORTNAME= thrift
PORTVERSION= 0.3.0
PORTVERSION= 0.6.1
PORTEPOCH= 1
CATEGORIES= devel
PKGNAMEPREFIX= ruby-

View file

@ -6,23 +6,26 @@
#
PORTNAME= thrift
PORTVERSION= 0.4.0
PORTVERSION= 0.6.1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= APACHE
MASTER_SITE_SUBDIR= incubator/thrift/${PORTVERSION}-incubating
MASTER_SITE_SUBDIR= /thrift/${PORTVERSION}
DISTNAME= thrift-${PORTVERSION}
MAINTAINER= skv@FreeBSD.org
COMMENT= Framework for scalable cross-language services development
LICENSE= ASL
LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
event-1.4:${PORTSDIR}/devel/libevent
USE_AUTOTOOLS= autoconf:env autoheader:env aclocal:env \
automake:env libtool:env
USE_AUTOTOOLS= autoconf autoheader:env aclocal automake libtool
ACLOCAL_ARGS= -I${WRKSRC}/aclocal
AUTOMAKE_ARGS= --foreign --add-missing --copy
USE_GNOME= pkgconfig
USE_GCC= 4.2+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
@ -40,12 +43,16 @@ CONFIGURE_ENV+= ${MAKE_ENV}
# Other languages are not yet supported, please feel free to contribute
# using one of the leaf ports as an example.
CONFIGURE_ARGS+= \
--with-cpp \
--without-c_glib \
--without-csharp \
--without-erlang \
--without-haskell \
--without-java \
--without-perl \
--without-php \
--without-py \
--without-php_extension \
--without-python \
--without-ruby
.include <bsd.port.pre.mk>
@ -58,7 +65,7 @@ post-patch:
@${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' ${WRKSRC}/lib/cpp/Makefile.am
pre-configure:
@(cd ${WRKSRC} && ./bootstrap.sh)
@${REINPLACE_CMD} '/config.h/d' ${WRKSRC}/lib/cpp/Makefile.am
post-install:
@${LN} -sf ${PREFIX}/lib/libthrift.so.0 ${PREFIX}/lib/libthrift.so
@ -69,7 +76,7 @@ post-install:
@${ECHO_MSG} "to compile and link your generated IDL bindings."
@${ECHO_MSG}
@${ECHO_MSG} "Note: The Thrift white paper may be downloaded from:"
@${ECHO_MSG} "http://incubator.apache.org/thrift/static/thrift-20070401.pdf"
@${ECHO_MSG} "http://thrift.apache.org/static/thrift-20070401.pdf"
@${ECHO_MSG}
.include <bsd.port.post.mk>

View file

@ -1,2 +1,2 @@
SHA256 (thrift-0.4.0.tar.gz) = 7cb8825a8888686ed6a9e229c9e9fcd9878a4af623785e1b22cdcc01a578d248
SIZE (thrift-0.4.0.tar.gz) = 1206710
SHA256 (thrift-0.6.1.tar.gz) = 1bed1ea17bf31c861fa8dd6e0182360eb8234383f32d0e4a36b70047b2e6b313
SIZE (thrift-0.6.1.tar.gz) = 2034583

View file

@ -0,0 +1,11 @@
--- configure.ac.orig 2011-03-20 21:26:41.000000000 +0000
+++ configure.ac 2011-03-20 21:26:57.000000000 +0000
@@ -85,7 +85,7 @@
have_cpp=no
if test "$with_cpp" = "yes"; then
AX_BOOST_BASE([1.33.1])
- if test "x$succeeded" == "xyes" ; then
+ if test "x$succeeded" = "xyes" ; then
have_cpp="yes"
fi

View file

@ -9,4 +9,4 @@ servers.
Thrift is specifically designed to support non-atomic version changes
across client and server code.
WWW: http://incubator.apache.org/thrift/
WWW: http://thrift.apache.org/

View file

@ -5,6 +5,13 @@ include/thrift/TLogging.h
include/thrift/TProcessor.h
include/thrift/TReflectionLocal.h
include/thrift/Thrift.h
include/thrift/async/SimpleCallback.h
include/thrift/async/TAsyncBufferProcessor.h
include/thrift/async/TAsyncChannel.h
include/thrift/async/TAsyncProcessor.h
include/thrift/async/TAsyncProtocolProcessor.h
include/thrift/async/TEvhttpClientChannel.h
include/thrift/async/TEvhttpServer.h
include/thrift/concurrency/Exception.h
include/thrift/concurrency/FunctionRunner.h
include/thrift/concurrency/Monitor.h
@ -14,19 +21,20 @@ include/thrift/concurrency/Thread.h
include/thrift/concurrency/ThreadManager.h
include/thrift/concurrency/TimerManager.h
include/thrift/concurrency/Util.h
include/thrift/config.h
include/thrift/processor/PeekProcessor.h
include/thrift/processor/StatsProcessor.h
include/thrift/protocol/TBase64Utils.h
include/thrift/protocol/TBinaryProtocol.h
include/thrift/protocol/TBinaryProtocol.tcc
include/thrift/protocol/TCompactProtocol.h
include/thrift/protocol/TCompactProtocol.tcc
include/thrift/protocol/TDebugProtocol.h
include/thrift/protocol/TDenseProtocol.h
include/thrift/protocol/TJSONProtocol.h
include/thrift/protocol/TOneWayProtocol.h
include/thrift/protocol/TProtocol.h
include/thrift/protocol/TProtocolException.h
include/thrift/protocol/TProtocolTap.h
include/thrift/protocol/TVirtualProtocol.h
include/thrift/server/TNonblockingServer.h
include/thrift/server/TServer.h
include/thrift/server/TSimpleServer.h
@ -47,6 +55,7 @@ include/thrift/transport/TSocketPool.h
include/thrift/transport/TTransport.h
include/thrift/transport/TTransportException.h
include/thrift/transport/TTransportUtils.h
include/thrift/transport/TVirtualTransport.h
include/thrift/transport/TZlibTransport.h
lib/libthrift.a
lib/libthrift.la
@ -68,4 +77,5 @@ libdata/pkgconfig/thrift.pc
@dirrm include/thrift/protocol
@dirrm include/thrift/processor
@dirrm include/thrift/concurrency
@dirrm include/thrift/async
@dirrm include/thrift