Equake is a panel plugin which monitors and displays earthquakes each time
a new one occurs. WWW: http://freecode.com/projects/equake-xfce
This commit is contained in:
parent
9c5ac763df
commit
3331c8a771
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323488
6 changed files with 57 additions and 0 deletions
|
@ -187,6 +187,7 @@
|
|||
SUBDIR += vmd
|
||||
SUBDIR += voro++
|
||||
SUBDIR += x11iraf
|
||||
SUBDIR += xfce4-equake-plugin
|
||||
SUBDIR += xmakemol
|
||||
SUBDIR += xmds
|
||||
|
||||
|
|
21
science/xfce4-equake-plugin/Makefile
Normal file
21
science/xfce4-equake-plugin/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# Created by: Olivier Duchateau
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= xfce4-equake-plugin
|
||||
PORTVERSION= 1.3.1
|
||||
CATEGORIES= science xfce
|
||||
MASTER_SITES= http://www.e-quake.org/wp-uploads/2013/07/
|
||||
DIST_SUBDIR= xfce4
|
||||
|
||||
MAINTAINER= xfce@FreeBSD.org
|
||||
COMMENT= Earthquake monitor plugin for the Xfce desktop
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USES= gettext pkgconfig gmake
|
||||
USE_GNOME= glib20 gtk20 intltool intlhack
|
||||
USE_XFCE= configenv libmenu libutil panel
|
||||
USE_XORG= x11
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
science/xfce4-equake-plugin/distinfo
Normal file
2
science/xfce4-equake-plugin/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (xfce4/xfce4-equake-plugin-1.3.1.tar.gz) = ca85a7c7af9337bb17d52f5a687209e310c4586d695dee6fc6aeed0a84a858ac
|
||||
SIZE (xfce4/xfce4-equake-plugin-1.3.1.tar.gz) = 478802
|
|
@ -0,0 +1,22 @@
|
|||
Avoid warning during compilation stage.
|
||||
|
||||
--- ./panel-plugin/equake_applet.c.orig 2013-07-20 00:56:31.000000000 +0000
|
||||
+++ ./panel-plugin/equake_applet.c 2013-07-20 15:58:24.000000000 +0000
|
||||
@@ -907,7 +907,7 @@
|
||||
static void display_about_dialog(XfcePanelPlugin *applet, struct Equake_Data *equakedata)
|
||||
{
|
||||
GtkWidget *about;
|
||||
- gchar *auth[]={AUTHOR, NULL};
|
||||
+ const gchar *auth[]={AUTHOR, NULL};
|
||||
|
||||
about=gtk_about_dialog_new();
|
||||
if(about!=NULL)
|
||||
@@ -919,7 +919,7 @@
|
||||
gtk_about_dialog_set_license((GtkAboutDialog*)about,LICENSE);
|
||||
gtk_about_dialog_set_website((GtkAboutDialog*)about,WEBSITE);
|
||||
gtk_about_dialog_set_website_label((GtkAboutDialog*)about,WEBSITELABEL);
|
||||
- gtk_about_dialog_set_authors((GtkAboutDialog*)about, (gchar*)auth);
|
||||
+ gtk_about_dialog_set_authors((GtkAboutDialog*)about, (const gchar**)auth);
|
||||
|
||||
g_signal_connect_swapped(about, "response", G_CALLBACK (gtk_widget_destroy), about);
|
||||
gtk_widget_show_all((GtkWidget*)about);
|
4
science/xfce4-equake-plugin/pkg-descr
Normal file
4
science/xfce4-equake-plugin/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
Equake is a panel plugin which monitors and displays earthquakes each time
|
||||
a new one occurs.
|
||||
|
||||
WWW: http://freecode.com/projects/equake-xfce
|
7
science/xfce4-equake-plugin/pkg-plist
Normal file
7
science/xfce4-equake-plugin/pkg-plist
Normal file
|
@ -0,0 +1,7 @@
|
|||
lib/xfce4/panel-plugins/xfce4-equake-plugin
|
||||
share/icons/hicolor/48x48/apps/xfce4-equake-plugin-icon.png
|
||||
share/xfce4/panel-plugins/xfce4-equake-plugin.desktop
|
||||
@dirrmtry share/xfce4/panel-plugins
|
||||
@dirrmtry share/xfce4
|
||||
@dirrmtry lib/xfce4/panel-plugins
|
||||
@dirrmtry lib/xfce4
|
Loading…
Reference in a new issue