- Update to 1.02
PR: ports/67380 Submitted by: Florent Thoumie <flz@xbsd.org> (maintainer)
This commit is contained in:
parent
3df0a18951
commit
336a2222ef
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110410
8 changed files with 42 additions and 26 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libbt
|
||||
PORTVERSION= 1.01
|
||||
PORTVERSION= 1.02
|
||||
CATEGORIES= net devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -23,15 +23,11 @@ USE_REINPLACE= yes
|
|||
USE_GCC= 3.3
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "alpha"
|
||||
BROKEN= "Does not compile on alpha"
|
||||
.endif
|
||||
PORTDOCS= protocol-ext.txt protocol.txt
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ |' ${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ \@CPPFLAGS\@ |' ${WRKSRC}/src/Makefile.in
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/src/libbt.a ${PREFIX}/lib
|
||||
|
@ -46,7 +42,9 @@ do-install:
|
|||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/protocol.txt ${DOCSDIR}
|
||||
.for i in ${PORTDOCS}
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (libbt-1.01.tar.gz) = 6a22db0d4db9036afbb5af94b8fdd526
|
||||
SIZE (libbt-1.01.tar.gz) = 307537
|
||||
MD5 (libbt-1.02.tar.gz) = 1db9d77dd51014d672e1c3e2fd60eb31
|
||||
SIZE (libbt-1.02.tar.gz) = 307050
|
||||
|
|
12
net-p2p/libbt/files/patch-include::util.h
Normal file
12
net-p2p/libbt/files/patch-include::util.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- include/util.h Fri Apr 16 08:41:48 2004
|
||||
+++ include/util.h.new Sun May 30 14:17:54 2004
|
||||
@@ -28,9 +28,4 @@
|
||||
typedef void (*exitfn_ptr) (int,void*);
|
||||
int on_exit( exitfn_ptr exitfn, void* data) ;
|
||||
#endif
|
||||
-#define malloc(s) use_btmalloc_instead
|
||||
-#define calloc(n,s) use_btcalloc_instead
|
||||
-#define realloc(p,s) use_btrealloc_instead
|
||||
-#define free(p) use_btfree_instead
|
||||
-
|
||||
#endif
|
|
@ -15,6 +15,4 @@ include/libbt/stream.h
|
|||
include/libbt/types.h
|
||||
include/libbt/util.h
|
||||
lib/libbt.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm include/libbt
|
||||
|
|
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= libbt
|
||||
PORTVERSION= 1.01
|
||||
PORTVERSION= 1.02
|
||||
CATEGORIES= net devel
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -23,15 +23,11 @@ USE_REINPLACE= yes
|
|||
USE_GCC= 3.3
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${ARCH} == "alpha"
|
||||
BROKEN= "Does not compile on alpha"
|
||||
.endif
|
||||
PORTDOCS= protocol-ext.txt protocol.txt
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|depend||' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ |' ${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e 's|\(CFLAGS:=\)|\1\@CFLAGS\@ \@CPPFLAGS\@ |' ${WRKSRC}/src/Makefile.in
|
||||
|
||||
do-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/src/libbt.a ${PREFIX}/lib
|
||||
|
@ -46,7 +42,9 @@ do-install:
|
|||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/protocol.txt ${DOCSDIR}
|
||||
.for i in ${PORTDOCS}
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/${i} ${DOCSDIR}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
MD5 (libbt-1.01.tar.gz) = 6a22db0d4db9036afbb5af94b8fdd526
|
||||
SIZE (libbt-1.01.tar.gz) = 307537
|
||||
MD5 (libbt-1.02.tar.gz) = 1db9d77dd51014d672e1c3e2fd60eb31
|
||||
SIZE (libbt-1.02.tar.gz) = 307050
|
||||
|
|
12
net/libbt/files/patch-include::util.h
Normal file
12
net/libbt/files/patch-include::util.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- include/util.h Fri Apr 16 08:41:48 2004
|
||||
+++ include/util.h.new Sun May 30 14:17:54 2004
|
||||
@@ -28,9 +28,4 @@
|
||||
typedef void (*exitfn_ptr) (int,void*);
|
||||
int on_exit( exitfn_ptr exitfn, void* data) ;
|
||||
#endif
|
||||
-#define malloc(s) use_btmalloc_instead
|
||||
-#define calloc(n,s) use_btcalloc_instead
|
||||
-#define realloc(p,s) use_btrealloc_instead
|
||||
-#define free(p) use_btfree_instead
|
||||
-
|
||||
#endif
|
|
@ -15,6 +15,4 @@ include/libbt/stream.h
|
|||
include/libbt/types.h
|
||||
include/libbt/util.h
|
||||
lib/libbt.a
|
||||
%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
@dirrm include/libbt
|
||||
|
|
Loading…
Reference in a new issue