Update to 5.12
This commit is contained in:
parent
87cbbcfa72
commit
33794f1686
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=372665
4 changed files with 7 additions and 57 deletions
|
@ -2,8 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xist
|
||||
PORTVERSION= 3.25
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 5.12
|
||||
CATEGORIES= www python
|
||||
MASTER_SITES= CHEESESHOP \
|
||||
http://ftp.livinglogic.de/xist/
|
||||
|
@ -15,18 +14,11 @@ COMMENT= XML-based extensible HTML generator
|
|||
|
||||
LICENSE= MIT
|
||||
|
||||
RUN_DEPENDS= ${PYXML} \
|
||||
${PYTHON_PKGNAMEPREFIX}ll-core>=1.11.1:${PORTSDIR}/devel/py-ll-core \
|
||||
${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
|
||||
${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.7:${PORTSDIR}/www/py-cssutils
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=3.4:${PORTSDIR}/devel/py-lxml \
|
||||
${PYTHON_PKGNAMEPREFIX}pillow>2.6:${PORTSDIR}/graphics/py-pillow \
|
||||
${PYTHON_PKGNAMEPREFIX}cssutils>=1.0:${PORTSDIR}/www/py-cssutils
|
||||
|
||||
USES= python:2 tar:bzip2
|
||||
USES= python:3 tar:bzip2
|
||||
USE_PYTHON= autoplist distutils
|
||||
|
||||
post-patch:
|
||||
.for conflictswithllcore in __init__ scripts/__init__ ansistyle astyle color \
|
||||
daemon make misc scripts/ucp sisyphus url xml_codec
|
||||
${RM} ${WRKSRC}/src/ll/${conflictswithllcore}.py
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (ll-xist-3.25.tar.bz2) = 8eed92b69f5852bbe406c3800c18ddfeab8835029b9d606891a57897eb8b74b2
|
||||
SIZE (ll-xist-3.25.tar.bz2) = 388303
|
||||
SHA256 (ll-xist-5.12.tar.bz2) = a38e53eb5502e61b532fe69cadb3f22233b81d1e9318e553ac2972d00d7d2d1a
|
||||
SIZE (ll-xist-5.12.tar.bz2) = 516348
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
$FreeBSD$
|
||||
|
||||
Stop the port conflicting with devel/py-ll-core
|
||||
|
||||
--- setup.py.orig 2011-08-11 11:51:22.000000000 +0100
|
||||
+++ setup.py 2014-02-19 21:45:27.310309976 +0000
|
||||
@@ -241,16 +241,11 @@
|
||||
packages=["ll", "ll.scripts", "ll.xist", "ll.xist.ns", "ll.xist.scripts", "ll.orasql", "ll.orasql.scripts"],
|
||||
package_data={"ll.xist": ["data/js/*.js", "data/px/*.gif"]},
|
||||
ext_modules=[
|
||||
- tools.Extension("ll._url", ["src/ll/_url.c"]),
|
||||
- tools.Extension("ll._ansistyle", ["src/ll/_ansistyle.c"]),
|
||||
- tools.Extension("ll._misc", ["src/ll/_misc.c", "src/ll/_misc_include.c"]),
|
||||
- tools.Extension("ll._xml_codec", ["src/ll/_xml_codec.c", "src/ll/_xml_codec_include.c"]),
|
||||
tools.Extension("ll.xist.sgmlop", ["src/ll/xist/sgmlop.c"], define_macros=[("SGMLOP_UNICODE_SUPPORT", None)]),
|
||||
],
|
||||
entry_points=dict(
|
||||
console_scripts=[
|
||||
"uls = ll.scripts.uls:main",
|
||||
- "ucp = ll.scripts.ucp:main",
|
||||
"ucat = ll.scripts.ucat:main",
|
||||
"uhpp = ll.xist.scripts.uhpp:main",
|
||||
"db2ul4 = ll.scripts.db2ul4:main",
|
||||
@@ -269,7 +264,6 @@
|
||||
),
|
||||
scripts=[
|
||||
"scripts/uls.py",
|
||||
- "scripts/ucp.py",
|
||||
"scripts/ucat.py",
|
||||
"scripts/uhpp.py",
|
||||
"scripts/db2ul4.py",
|
|
@ -1,11 +0,0 @@
|
|||
--- src/ll/url.py.orig 2014-10-07 12:02:25 UTC
|
||||
+++ src/ll/url.py
|
||||
@@ -57,7 +57,7 @@
|
||||
execnet = None
|
||||
|
||||
try:
|
||||
- import Image
|
||||
+ from PIL import Image
|
||||
except ImportError:
|
||||
pass
|
||||
|
Loading…
Reference in a new issue