The concordance software suite allows you to program your Logitech Harmony
remote using a configuration object retreived from the harmony website. The Logitech Harmony is a highly configuration universal remote than can control most multimedia devices. This port contains the C Libraries for the concordance framework. PR: ports/190545 Submitted by: Stephen Hurd <shurd@sasktel.net>
This commit is contained in:
parent
e35cf64a81
commit
33970b6429
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=356303
6 changed files with 57 additions and 0 deletions
|
@ -74,6 +74,7 @@
|
|||
SUBDIR += kb
|
||||
SUBDIR += kermit
|
||||
SUBDIR += kremotecontrol
|
||||
SUBDIR += libconcord
|
||||
SUBDIR += libfec
|
||||
SUBDIR += libimobiledevice
|
||||
SUBDIR += libirman
|
||||
|
|
26
comms/libconcord/Makefile
Normal file
26
comms/libconcord/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# Created by: Stephen Hurd <shurd@sasktel.net>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libconcord
|
||||
PORTVERSION= 1.1
|
||||
CATEGORIES= comms
|
||||
MASTER_SITES= SF/concordance/concordance/${PORTVERSION}
|
||||
DISTNAME= concordance-${PORTVERSION}
|
||||
|
||||
MAINTAINER= shurd@sasktel.net
|
||||
COMMENT= Logitech Harmony configuration library
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconf
|
||||
LIB_DEPENDS= libhidapi.so:${PORTSDIR}/comms/hidapi \
|
||||
libzip.so:${PORTSDIR}/archivers/libzip
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
USES= tar:bzip2 libtool shared-mime-info
|
||||
WRKSRC_SUBDIR= libconcord
|
||||
GNU_CONFIGURE= yes
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
2
comms/libconcord/distinfo
Normal file
2
comms/libconcord/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (concordance-1.1.tar.bz2) = ca5ffbd8c0fd06d41192c1d5e3c8b964c2393ea6d3d9c5e495c1da4b2c778a05
|
||||
SIZE (concordance-1.1.tar.bz2) = 1142393
|
16
comms/libconcord/files/patch-configure
Normal file
16
comms/libconcord/files/patch-configure
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- configure.orig 2014-03-28 20:27:39.000000000 -0700
|
||||
+++ configure 2014-05-31 01:13:47.000000000 -0700
|
||||
@@ -15457,6 +15457,13 @@
|
||||
fi
|
||||
LIBCONCORD_LDFLAGS="-l$USBLIB"
|
||||
;;
|
||||
+ freebsd*)
|
||||
+ USBLIB="hidapi"
|
||||
+
|
||||
+$as_echo "#define WANT_HIDAPI 1" >>confdefs.h
|
||||
+
|
||||
+ LIBCONCORD_LDFLAGS="-l$USBLIB"
|
||||
+ ;;
|
||||
darwin*)
|
||||
USBLIB="hidapi"
|
||||
|
6
comms/libconcord/pkg-descr
Normal file
6
comms/libconcord/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
|||
The concordance software suite allows you to program your Logitech Harmony
|
||||
remote using a configuration object retreived from the harmony website. The
|
||||
Logitech Harmony is a highly configuration universal remote than can control
|
||||
most multimedia devices.
|
||||
|
||||
This port contains the C Libraries for the concordance framework.
|
6
comms/libconcord/pkg-plist
Normal file
6
comms/libconcord/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
|||
include/libconcord.h
|
||||
lib/libconcord.a
|
||||
lib/libconcord.so
|
||||
lib/libconcord.so.3
|
||||
lib/libconcord.so.3.0.0
|
||||
share/mime/packages/libconcord.xml
|
Loading…
Reference in a new issue