Initial import of kplaylist 1.8.505
kPlaylist is a free PHP system that makes your music collection available via the Internet. kPlaylist is a music database that you manage via the web. With kPlaylist you can stream your music (ogg, mp3, wav, wma, etc.), you can upload, make playlists, share, search, download and a lot more.
This commit is contained in:
parent
580c23c54d
commit
33a9c7db21
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=263677
5 changed files with 66 additions and 0 deletions
|
@ -355,6 +355,7 @@
|
|||
SUBDIR += khtml2png
|
||||
SUBDIR += knowledgekit
|
||||
SUBDIR += kompozer
|
||||
SUBDIR += kplaylist
|
||||
SUBDIR += kwebkitpart
|
||||
SUBDIR += larbin
|
||||
SUBDIR += libapreq2
|
||||
|
|
35
www/kplaylist/Makefile
Normal file
35
www/kplaylist/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: kplaylist
|
||||
# Date created: 28 October 2010
|
||||
# Whom: Kevin Lo <kevlo@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= kplaylist
|
||||
PORTVERSION= 1.8.505
|
||||
CATEGORIES= www multimedia
|
||||
MASTER_SITES= http://www.kplaylist.net/archive.php?file=1.8.505&tar=true/
|
||||
DISTNAME= ${PORTNAME}.${PORTVERSION}
|
||||
|
||||
MAINTAINER= kevlo@FreeBSD.org
|
||||
COMMENT= A PHP based music database
|
||||
|
||||
RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
|
||||
oggenc:${PORTSDIR}/audio/vorbis-tools \
|
||||
zip:${PORTSDIR}/archivers/zip
|
||||
|
||||
USE_PHP= curl mysql session iconv
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
WWWDIR?= ${PREFIX}/www/${PORTNAME}
|
||||
NO_BUILD= yes
|
||||
|
||||
PLIST_FILES= %%WWWDIR%%/index.php
|
||||
PLIST_DIRS= %%WWWDIR%%
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${WWWDIR}
|
||||
@cd ${WRKSRC} && ${CP} kplaylist.1.8.505.php ${WWWDIR}/index.php
|
||||
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
www/kplaylist/distinfo
Normal file
3
www/kplaylist/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (kplaylist.1.8.505.tar.gz) = c5dded81bd14bf9b094c5700d4fc8a28
|
||||
SHA256 (kplaylist.1.8.505.tar.gz) = cdc4fa12d881732f535f93be5213ba4278c2650e956692df2dc375f8a906bb48
|
||||
SIZE (kplaylist.1.8.505.tar.gz) = 237854
|
20
www/kplaylist/files/patch-kplaylist.1.8.505.php
Normal file
20
www/kplaylist/files/patch-kplaylist.1.8.505.php
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- kplaylist.1.8.505.php.orig 2010-10-28 16:21:51.000000000 +0800
|
||||
+++ kplaylist.1.8.505.php 2010-10-28 16:27:03.000000000 +0800
|
||||
@@ -155,7 +155,7 @@
|
||||
$cfg['lamecmd'] = '/usr/local/bin/lame --silent --nores --nohist --mp3input -h -m s -b %bitrate% "%file%" -';
|
||||
|
||||
// ogg command (transcode)
|
||||
-$cfg['oggcmd'] = '/usr/bin/oggdec -Q "%file%" -o - | /usr/bin/oggenc - --quiet --managed -b %bitrate% -o -';
|
||||
+$cfg['oggcmd'] = '/usr/local/bin/oggdec -Q "%file%" -o - | /usr/local/bin/oggenc - --quiet --managed -b %bitrate% -o -';
|
||||
|
||||
// enable ogg transcoding, look the line above for the command, check this before enabling
|
||||
$cfg['oggtranscode'] = false;
|
||||
@@ -166,7 +166,7 @@
|
||||
// YOU MUST SUIT THESE ARCHIVERS TO YOUR OWN NEED. DO NOT USE THE DEFAULT BLINDLY.
|
||||
$archivers = array();
|
||||
|
||||
-$archivers[] = array(1, 'zip', '/usr/bin/zip -j -0 %D "%F"', 'application/zip', 'zip');
|
||||
+$archivers[] = array(1, 'zip', '/usr/local/bin/zip -j -0 %D "%F"', 'application/zip', 'zip');
|
||||
$archivers[] = array(1, 'tar','/bin/tar cf %D --files-from "%LIST"', 'application/x-tar', 'tar');
|
||||
$archivers[] = array(0, 'rar', 'C:\Programfiler\WinRAR\rar.exe -m0 a %D "%F"', 'application/x-rar', 'rar');
|
||||
|
7
www/kplaylist/pkg-descr
Normal file
7
www/kplaylist/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
kPlaylist is a free PHP system that makes your music collection
|
||||
available via the Internet.
|
||||
kPlaylist is a music database that you manage via the web. With kPlaylist
|
||||
you can stream your music (ogg, mp3, wav, wma, etc.), you can upload,
|
||||
make playlists, share, search, download and a lot more.
|
||||
|
||||
WWW: http://www.kplaylist.net/
|
Loading…
Reference in a new issue