- Fix build with clang. Patch was not updated in r309135
and no longer seems neccessary. - Remove superfluous PORTVERSION and space - Remove COPYING from PORTDOCS since LICENSE is defined - Drop ABI version from LIB_DEPENDS - Tab -> space in pkg-descr WWW line - Remove FreeBSD keyword from pkg-plist
This commit is contained in:
parent
611afc10e7
commit
33bd5eb62c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=309174
4 changed files with 4 additions and 53 deletions
|
@ -1,10 +1,8 @@
|
|||
# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
|
||||
# Created by: Leo Vandewoestijne <freebsd@dns-lab.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= knot
|
||||
PORTVERSION= 1.1.3.r1
|
||||
DISTVERSION= 1.1.3-rc1
|
||||
|
||||
CATEGORIES= dns ipv6
|
||||
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
|
||||
http://www.dns-lab.com/downloads/knot-dns/
|
||||
|
@ -16,11 +14,7 @@ LICENSE= GPLv3
|
|||
|
||||
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
|
||||
flex>=2.5.35_1:${PORTSDIR}/textproc/flex
|
||||
LIB_DEPENDS= urcu.1:${PORTSDIR}/sysutils/userspace-rcu
|
||||
|
||||
.if ${CC} == "clang"
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-configure
|
||||
.endif
|
||||
LIB_DEPENDS= urcu:${PORTSDIR}/sysutils/userspace-rcu
|
||||
|
||||
CONFIGURE_ARGS= --sysconfdir=${ETCDIR}
|
||||
GNU_CONFIGURE= yes
|
||||
|
@ -39,7 +33,7 @@ MAN5= knot.conf.5
|
|||
|
||||
INFO= knot
|
||||
|
||||
PORTDOCS= AUTHORS ChangeLog CodingStyle COPYING \
|
||||
PORTDOCS= AUTHORS ChangeLog CodingStyle \
|
||||
INSTALL KNOWN_ISSUES NEWS README RELNOTES
|
||||
|
||||
post-install:
|
||||
|
|
|
@ -1,42 +0,0 @@
|
|||
--- ./configure.orig 2012-05-17 18:19:19.000000000 +0900
|
||||
+++ ./configure 2012-05-17 21:40:12.000000000 +0900
|
||||
@@ -13237,38 +13237,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-# Check for link time optimizations support and predictive commoning
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts \"-flto\"" >&5
|
||||
-$as_echo_n "checking whether C compiler accepts \"-flto\"... " >&6; }
|
||||
-ax_save_FLAGS=$CFLAGS
|
||||
- CFLAGS=""-flto""
|
||||
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-if ac_fn_c_try_compile "$LINENO"; then :
|
||||
- eval `$as_echo "ax_cv_c_flags_"-flto"" | $as_tr_sh`=yes
|
||||
-else
|
||||
- eval `$as_echo "ax_cv_c_flags_"-flto"" | $as_tr_sh`=no
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
- CFLAGS=$ax_save_FLAGS
|
||||
-eval ax_check_compiler_flags=$`$as_echo "ax_cv_c_flags_"-flto"" | $as_tr_sh`
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_check_compiler_flags" >&5
|
||||
-$as_echo "$ax_check_compiler_flags" >&6; }
|
||||
-if test "x$ax_check_compiler_flags" = xyes; then
|
||||
- CFLAGS="$CFLAGS -flto"
|
||||
-else
|
||||
- :
|
||||
-fi
|
||||
-
|
||||
+# Check for predictive commoning
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts \"-fpredictive-commoning\"" >&5
|
||||
$as_echo_n "checking whether C compiler accepts \"-fpredictive-commoning\"... " >&6; }
|
||||
ax_save_FLAGS=$CFLAGS
|
|
@ -17,4 +17,4 @@ Key features:
|
|||
- NSID
|
||||
|
||||
|
||||
WWW: http://www.knot-dns.cz/
|
||||
WWW: http://www.knot-dns.cz/
|
||||
|
|
|
@ -1,4 +1,3 @@
|
|||
@comment $FreeBSD$
|
||||
@stopdaemon knotd
|
||||
%%ETCDIR%%/example.com.zone
|
||||
@unexec if cmp -s %B/knot.min.conf %B/knot.conf; then rm -f %B/knot.conf; fi
|
||||
|
|
Loading…
Reference in a new issue