textproc/py-ocrmypdf: Update to 14.0.3
* Switch to PEP-517 build framework. Changelogs since 13.7.0: https://github.com/ocrmypdf/OCRmyPDF/blob/v14.0.3/docs/release_notes.rst MFH: No (PEP-517 support not present in 2023Q1 branch)
This commit is contained in:
parent
dfe31131fa
commit
34297ee65d
3 changed files with 25 additions and 21 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= ocrmypdf
|
||||
DISTVERSION= 13.7.0
|
||||
DISTVERSION= 14.0.3
|
||||
CATEGORIES= textproc python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -11,25 +11,27 @@ WWW= https://github.com/ocrmypdf/OCRmyPDF
|
|||
LICENSE= MPL20
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools_scm_git_archive>=0:devel/py-setuptools_scm_git_archive@${PY_FLAVOR}
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coloredlogs>=14.0:devel/py-coloredlogs@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}deprecation>=2.1.0:devel/py-deprecation@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}img2pdf>=0.3.0:graphics/py-img2pdf@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=20:devel/py-packaging@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pillow>=8.2.0:graphics/py-pillow@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}tqdm>=4:misc/py-tqdm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}reportlab>=3.5.66:print/py-reportlab@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pdfminer.six>=20191110:textproc/py-pdfminer.six@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pikepdf>=4.0.0:textproc/py-pikepdf@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pdfminer.six>=20201018:textproc/py-pdfminer.six@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pikepdf>=5.0.1:textproc/py-pikepdf@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pluggy>=0.13.0:devel/py-pluggy@${PY_FLAVOR} \
|
||||
tesseract:graphics/tesseract
|
||||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.4.1:devel/py-pytest@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=2.2.0:devel/py-pytest-xdist@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}python-xmp-toolkit>=2.0.1:textproc/py-python-xmp-toolkit@${PY_FLAVOR}
|
||||
|
||||
USES= ghostscript:run python:3.7+ shebangfix
|
||||
USES= ghostscript:run python:3.8+ shebangfix
|
||||
USE_LOCALE= en_US.UTF-8
|
||||
USE_PYTHON= autoplist concurrent distutils
|
||||
USE_PYTHON= autoplist concurrent pep517
|
||||
|
||||
SHEBANG_FILES= src/ocrmypdf/__main__.py \
|
||||
src/ocrmypdf/hocrtransform.py \
|
||||
|
@ -50,10 +52,6 @@ UNPAPER_RUN_DEPENDS= unpaper:graphics/unpaper
|
|||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PYTHON_REL} < 30800
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=4:devel/py-importlib-metadata@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
.if ${PYTHON_REL} < 30900
|
||||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=5:devel/py-importlib-resources@${PY_FLAVOR}
|
||||
.endif
|
||||
|
@ -62,13 +60,6 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=5:devel/py-importlib-r
|
|||
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}typing-extensions>=4:devel/py-typing-extensions@${PY_FLAVOR}
|
||||
.endif
|
||||
|
||||
# The "pyproject.toml" wants devel/py-setuptools_scm >= 7.0.5 which isn't in
|
||||
# the Ports tree, yet. Although py-ocrmypdf builds fine as the "setup.cfg" is
|
||||
# used during build instead the "pyproject.toml" move the latter one out of the
|
||||
# way to prevent surprises.
|
||||
post-extract:
|
||||
@${MV} ${WRKSRC}/pyproject.toml ${WRKSRC}/pyproject.toml.dist
|
||||
|
||||
post-install:
|
||||
# Install shell completion files
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d ${STAGEDIR}${PREFIX}/share/fish/vendor_completions.d/
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1665938750
|
||||
SHA256 (ocrmypdf-13.7.0.tar.gz) = 45fa226f6753f6e0be1e6304d3363a6d8047bb4cb0cf0d25728c3b9c9a0bff40
|
||||
SIZE (ocrmypdf-13.7.0.tar.gz) = 7911229
|
||||
TIMESTAMP = 1677178213
|
||||
SHA256 (ocrmypdf-14.0.3.tar.gz) = db03cdd1a5d277fa038b0420ba05fcf7b1f92729ba85431344844ebf01035160
|
||||
SIZE (ocrmypdf-14.0.3.tar.gz) = 6512083
|
||||
|
|
13
textproc/py-ocrmypdf/files/patch-pyproject.toml
Normal file
13
textproc/py-ocrmypdf/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,13 @@
|
|||
Allow build with older versions of devel/py-setuptools_scm .
|
||||
|
||||
--- pyproject.toml.orig 2023-02-23 20:43:57 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -3,7 +3,7 @@ requires = [
|
||||
[build-system]
|
||||
requires = [
|
||||
"setuptools >= 61",
|
||||
- "setuptools_scm[toml] >= 7.0.5",
|
||||
+ "setuptools_scm[toml]",
|
||||
"wheel"
|
||||
]
|
||||
build-backend = "setuptools.build_meta"
|
Loading…
Reference in a new issue