graphics/s2tc: add new port.
Add a port that implements a subset of the Color Cell Compression texture compression scheme.
This commit is contained in:
parent
4d373c85e5
commit
347c925ee5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=411515
6 changed files with 63 additions and 0 deletions
|
@ -959,6 +959,7 @@
|
|||
SUBDIR += rubygem-ruby-graphviz
|
||||
SUBDIR += rubygem-scruffy
|
||||
SUBDIR += s10sh
|
||||
SUBDIR += s2tc
|
||||
SUBDIR += sage
|
||||
SUBDIR += sam2p
|
||||
SUBDIR += sampleicc
|
||||
|
|
26
graphics/s2tc/Makefile
Normal file
26
graphics/s2tc/Makefile
Normal file
|
@ -0,0 +1,26 @@
|
|||
# Created by: David Naylor <dbn@FreeBSD.org>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= s2tc
|
||||
PORTVERSION= 1.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= graphics
|
||||
|
||||
MAINTAINER= dbn@FreeBSD.org
|
||||
COMMENT= S2TC is a subset of a wellknown texture compression scheme
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= autoreconf libtool
|
||||
USE_GL= gl
|
||||
USE_GITHUB= yes
|
||||
|
||||
GH_ACCOUNT= divVerent
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/s2tc/distinfo
Normal file
2
graphics/s2tc/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (divVerent-s2tc-v1.0_GH0.tar.gz) = a21c5babd3810af4f7d4e8099e830f545b4e5f5dc0aadf375ed09d23566c6e45
|
||||
SIZE (divVerent-s2tc-v1.0_GH0.tar.gz) = 1397232
|
11
graphics/s2tc/files/patch-Makefile.am
Normal file
11
graphics/s2tc/files/patch-Makefile.am
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.am.orig 2016-03-20 18:59:03 UTC
|
||||
+++ Makefile.am
|
||||
@@ -10,8 +10,6 @@ s2tc_from_s3tc_SOURCES = s2tc_from_s3tc.
|
||||
s2tc_compress_SOURCES = s2tc_compress.cpp txc_dxtn.h s2tc_license.h
|
||||
s2tc_decompress_SOURCES = s2tc_decompress.cpp txc_dxtn.h s2tc_license.h
|
||||
if ENABLE_RUNTIME_LINKING
|
||||
-s2tc_compress_LDADD = -ldl
|
||||
-s2tc_decompress_LDADD = -ldl
|
||||
else
|
||||
if ENABLE_LIB
|
||||
s2tc_compress_LDADD = libtxc_dxtn.la
|
14
graphics/s2tc/pkg-descr
Normal file
14
graphics/s2tc/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
S2TC's format specification is very easy to implement, so it is not hard to make
|
||||
a working compressor or decompressor for it. It is based on Color Cell
|
||||
Compression[1] from 1986, and decoding is done entirely using the methods from
|
||||
there. Encoding is done using a search and refinement method that is derived
|
||||
from the methods described in that paper.
|
||||
|
||||
This also makes this format a great platform for learning about texture
|
||||
compression and how to tune a compressor for best quality.
|
||||
|
||||
S2TC is especially well suited for runtime (on-load) compression of textures, as
|
||||
it is - in low quality settings - way faster than any other texture compressors
|
||||
out there.
|
||||
|
||||
WWW: https://github.com/divVerent/s2tc/wiki
|
9
graphics/s2tc/pkg-plist
Normal file
9
graphics/s2tc/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/s2tc_compress
|
||||
bin/s2tc_decompress
|
||||
bin/s2tc_from_s3tc
|
||||
include/txc_dxtn.h
|
||||
lib/libtxc_dxtn.a
|
||||
lib/libtxc_dxtn.so
|
||||
lib/libtxc_dxtn.so.0
|
||||
lib/libtxc_dxtn.so.0.0.0
|
||||
lib/pkgconfig/txc_dxtn.pc
|
Loading…
Reference in a new issue