- Update to 0.6.17
PR: 162886 Submitted by: Jase Thew <freebsd@beardz.net> (maintainer) Feature safe: yes
This commit is contained in:
parent
328bfe8471
commit
34ffef52be
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=286465
4 changed files with 40 additions and 19 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= duplicity
|
||||
PORTVERSION= 0.6.16
|
||||
PORTVERSION= 0.6.17
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= http://launchpad.net/duplicity/0.6-series/${PORTVERSION}/+download/
|
||||
|
||||
|
@ -25,7 +25,7 @@ FETCH_ARGS= -pRr
|
|||
|
||||
CONFLICTS= duplicity-0.5.* duplicity-devel-[0-9]*
|
||||
|
||||
USE_PYTHON= 2.4+
|
||||
USE_PYTHON= 2.5+
|
||||
USE_PYDISTUTILS=yes
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
|
@ -44,12 +44,13 @@ post-patch:
|
|||
|
||||
MAN1= duplicity.1 rdiffdir.1
|
||||
|
||||
DOCFILES= CHANGELOG \
|
||||
COPYING \
|
||||
REPO-README \
|
||||
LOG-README \
|
||||
DOCFILES= COPYING \
|
||||
README \
|
||||
tarfile-LICENSE
|
||||
README-REPO \
|
||||
README-LOG \
|
||||
tarfile-LICENSE \
|
||||
tarfile-CHANGES \
|
||||
CHANGELOG
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (duplicity-0.6.16.tar.gz) = 488c5de5ff0495409e2d92ee07e42a4daf336e2bc1dc934c3cd862ae4f41c358
|
||||
SIZE (duplicity-0.6.16.tar.gz) = 524358
|
||||
SHA256 (duplicity-0.6.17.tar.gz) = 891e56061ab15127e67c93b9b462760b055eb48636c177b56400925d0a77a458
|
||||
SIZE (duplicity-0.6.17.tar.gz) = 1119945
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- setup.py.orig 2009-01-09 16:05:11.000000000 +0200
|
||||
+++ setup.py 2009-01-10 16:06:40.000000000 +0200
|
||||
@@ -12,6 +12,10 @@
|
||||
--- setup.py.orig 2011-11-25 23:58:57.147597966 +0000
|
||||
+++ setup.py 2011-11-26 00:00:43.169721395 +0000
|
||||
@@ -31,6 +31,10 @@
|
||||
|
||||
incdir_list = libdir_list = None
|
||||
|
||||
|
@ -11,20 +11,21 @@
|
|||
if os.name == 'posix':
|
||||
LIBRSYNC_DIR = os.environ.get('LIBRSYNC_DIR', '')
|
||||
args = sys.argv[:]
|
||||
@@ -23,16 +27,9 @@
|
||||
@@ -42,17 +46,9 @@
|
||||
incdir_list = [os.path.join(LIBRSYNC_DIR, 'include')]
|
||||
libdir_list = [os.path.join(LIBRSYNC_DIR, 'lib')]
|
||||
|
||||
-data_files = [('share/man/man1',
|
||||
+data_files = [('man/man1',
|
||||
['duplicity.1',
|
||||
'rdiffdir.1']),
|
||||
['bin/duplicity.1',
|
||||
'bin/rdiffdir.1']),
|
||||
- ('share/doc/duplicity-%s' % version_string,
|
||||
- ['COPYING',
|
||||
- 'REPO-README',
|
||||
- 'LOG-README',
|
||||
- 'README',
|
||||
- 'README-REPO',
|
||||
- 'README-LOG',
|
||||
- 'tarfile-LICENSE',
|
||||
- 'tarfile-CHANGES',
|
||||
- 'CHANGELOG']),
|
||||
]
|
||||
|
||||
|
|
|
@ -16,6 +16,12 @@ bin/rdiffdir
|
|||
%%PYTHON_SITELIBDIR%%/duplicity/backends/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/__init__.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/__init__.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/_boto_multi.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/_boto_multi.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/_boto_multi.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/_boto_single.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/_boto_single.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/_boto_single.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/botobackend.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/botobackend.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/backends/botobackend.pyo
|
||||
|
@ -64,6 +70,9 @@ bin/rdiffdir
|
|||
%%PYTHON_SITELIBDIR%%/duplicity/commandline.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/commandline.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/commandline.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/compilec.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/compilec.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/compilec.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/diffdir.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/diffdir.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/diffdir.pyo
|
||||
|
@ -82,6 +91,9 @@ bin/rdiffdir
|
|||
%%PYTHON_SITELIBDIR%%/duplicity/file_naming.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/file_naming.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/file_naming.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/filechunkio.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/filechunkio.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/filechunkio.pyo
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/globals.py
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/globals.pyc
|
||||
%%PYTHON_SITELIBDIR%%/duplicity/globals.pyo
|
||||
|
@ -140,9 +152,10 @@ bin/rdiffdir
|
|||
@dirrm %%PYTHON_SITELIBDIR%%/duplicity
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
|
||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LOG-README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/REPO-README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README-LOG
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README-REPO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tarfile-CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tarfile-LICENSE
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%NLS%%share/locale/bg/LC_MESSAGES/duplicity.mo
|
||||
|
@ -154,6 +167,7 @@ bin/rdiffdir
|
|||
%%NLS%%share/locale/es/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/he/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/hu/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/id/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/io/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/it/LC_MESSAGES/duplicity.mo
|
||||
|
@ -164,6 +178,7 @@ bin/rdiffdir
|
|||
%%NLS%%share/locale/ru/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/sl/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/sq/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/sr/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/sv/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/tr/LC_MESSAGES/duplicity.mo
|
||||
%%NLS%%share/locale/ug/LC_MESSAGES/duplicity.mo
|
||||
|
@ -180,6 +195,8 @@ bin/rdiffdir
|
|||
%%NLS%%@dirrmtry share/locale/es
|
||||
%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/fr
|
||||
%%NLS%%@dirrmtry share/locale/hu/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/hu
|
||||
%%NLS%%@dirrmtry share/locale/id/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/id
|
||||
%%NLS%%@dirrmtry share/locale/io/LC_MESSAGES
|
||||
|
@ -198,6 +215,8 @@ bin/rdiffdir
|
|||
%%NLS%%@dirrmtry share/locale/ru
|
||||
%%NLS%%@dirrmtry share/locale/sl/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/sl
|
||||
%%NLS%%@dirrmtry share/locale/sr/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/sr
|
||||
%%NLS%%@dirrmtry share/locale/sv/LC_MESSAGES
|
||||
%%NLS%%@dirrmtry share/locale/sv
|
||||
%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
|
||||
|
|
Loading…
Reference in a new issue