add wxmozilla 0.5.3
Embedding Mozilla in wxWindows
This commit is contained in:
parent
dda3f4e27c
commit
350026a189
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=99782
7 changed files with 91 additions and 0 deletions
|
@ -204,6 +204,7 @@
|
|||
SUBDIR += wxgtk2-contrib
|
||||
SUBDIR += wxgtk2-unicode
|
||||
SUBDIR += wxgtk2-unicode-contrib
|
||||
SUBDIR += wxmozilla
|
||||
SUBDIR += xbae
|
||||
SUBDIR += xclasses
|
||||
SUBDIR += xenophilia
|
||||
|
|
31
x11-toolkits/wxmozilla/Makefile
Normal file
31
x11-toolkits/wxmozilla/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: wxmozilla
|
||||
# Date created: Oct 27, 2003
|
||||
# Whom: ijliao
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= wxmozilla
|
||||
PORTVERSION= 0.5.3
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Embedding Mozilla in wxWindows
|
||||
|
||||
BUILD_DEPENDS= ${X11BASE}/lib/firebird/lib/pkgconfig/mozilla-nspr.pc:${PORTSDIR}/www/mozilla-firebird \
|
||||
${PYTHON_SITELIBDIR}/wxPython/__init__.py:${PORTSDIR}/x11-toolkits/py-wxPython
|
||||
LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_GNOME= gnomehack
|
||||
WXGTK_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= PKG_CONFIG_PATH="${X11BASE}/lib/firebird/lib/pkgconfig"
|
||||
CONFIGURE_ARGS= --with-wx-config=${WXGTK_CONFIG} --enable-python
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
x11-toolkits/wxmozilla/distinfo
Normal file
1
x11-toolkits/wxmozilla/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (wxmozilla-0.5.3.tar.gz) = c353300bfd1f45e1fa3e413cdbdd48d2
|
20
x11-toolkits/wxmozilla/files/patch-configure
Normal file
20
x11-toolkits/wxmozilla/files/patch-configure
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- configure.orig Mon Feb 2 14:55:50 2004
|
||||
+++ configure Mon Feb 2 14:56:59 2004
|
||||
@@ -10135,7 +10135,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-if test "$build_python" == "yes" ; then
|
||||
+if test "$build_python" = "yes" ; then
|
||||
|
||||
|
||||
|
||||
@@ -10315,7 +10315,7 @@
|
||||
fi
|
||||
|
||||
|
||||
-if test $build_python == yes; then
|
||||
+if test $build_python = yes; then
|
||||
BUILD_PYTHON_TRUE=
|
||||
BUILD_PYTHON_FALSE='#'
|
||||
else
|
15
x11-toolkits/wxmozilla/files/patch-ltmain.sh
Normal file
15
x11-toolkits/wxmozilla/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- ltmain.sh.orig Mon Feb 2 14:01:02 2004
|
||||
+++ ltmain.sh Mon Feb 2 14:01:19 2004
|
||||
@@ -4394,10 +4394,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
7
x11-toolkits/wxmozilla/pkg-descr
Normal file
7
x11-toolkits/wxmozilla/pkg-descr
Normal file
|
@ -0,0 +1,7 @@
|
|||
wxMozilla is a project underway to develop a wxWindows component for embedding
|
||||
the Mozilla browser into any wxWindows application. The wxMozilla classes will
|
||||
utilize minimal, if any, platform dependant code and utilize directly the
|
||||
XPCOM (Cross Platrom COM) interface to instantate a html browser or editor
|
||||
within the application.
|
||||
|
||||
WWW: http://wxmozilla.sourceforge.net/
|
16
x11-toolkits/wxmozilla/pkg-plist
Normal file
16
x11-toolkits/wxmozilla/pkg-plist
Normal file
|
@ -0,0 +1,16 @@
|
|||
lib/libwxmozilla_gtk2-2.4.a
|
||||
lib/libwxmozilla_gtk2-2.4.so
|
||||
lib/libwxmozilla_gtk2-2.4.so.0
|
||||
include/wxmozilla/wxMozilla.h
|
||||
include/wxmozilla/wxMozillaBrowser.h
|
||||
include/wxmozilla/wxMozillaBrowserChrome.h
|
||||
include/wxmozilla/wxMozillaEvents.h
|
||||
include/wxmozilla/wxMozillaSettings.h
|
||||
include/wxmozilla/wxMozillaWindow.h
|
||||
@dirrm include/wxmozilla
|
||||
libdata/pkgconfig/wxmozilla.pc
|
||||
%%PYTHON_SITELIBDIR%%/wxPython/mozilla.py
|
||||
%%PYTHON_SITELIBDIR%%/wxPython/mozilla.pyc
|
||||
%%PYTHON_SITELIBDIR%%/wxPython/mozilla.pyo
|
||||
%%PYTHON_SITELIBDIR%%/wxPython/mozillac.a
|
||||
%%PYTHON_SITELIBDIR%%/wxPython/mozillac.so
|
Loading…
Reference in a new issue