games/ponscripter-sekai: update to 0.0.6.162 (snapshot)
Changes: https://github.com/sekaiproject/ponscripter-fork/compare/v0.0.6...4f887b8
This commit is contained in:
parent
9a99a5b05d
commit
3507e8bb40
4 changed files with 45 additions and 29 deletions
|
@ -1,16 +1,17 @@
|
|||
PORTNAME= ponscripter-sekai
|
||||
PORTVERSION= 0.0.6
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 7
|
||||
DISTVERSION= 0.0.6-162
|
||||
DISTVERSIONSUFFIX= -g4f887b8
|
||||
CATEGORIES= games
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES+= 101c68e22921.patch:-p1 4fb1180d2b54.patch:-p1 25e752f272d0.patch:-p1
|
||||
PATCHFILES+= 69068bf83653.patch:-p1 # https://github.com/sekaiproject/ponscripter-fork/pull/98
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= NScripter-like novel-game interpreter with Unicode support
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libsmpeg2.so:multimedia/smpeg2 \
|
||||
libfreetype.so:print/freetype2
|
||||
|
@ -31,12 +32,12 @@ CONFIGURE_ENV= CC_VER="4.8" CC="${CC} ${CFLAGS}" CXX="${CXX} ${CXXFLAGS}" \
|
|||
CPATH="${LOCALBASE}/include" LIBRARY_PATH="${LOCALBASE}/lib"
|
||||
CONFIGURE_ARGS= --prefix="${STAGEDIR}${PREFIX}" --unsupported-compiler
|
||||
LDFLAGS+= -Wl,--as-needed
|
||||
PORTDOCS= BUGS CHANGES MANUAL README TODO
|
||||
PORTDOCS= BUGS CHANGES MANUAL README.md TODO
|
||||
PLIST_FILES= bin/ponscr \
|
||||
share/emacs/site-lisp/ponscripter-mode.el
|
||||
|
||||
OPTIONS_DEFINE= DOCS MANPAGES TREMOR
|
||||
OPTIONS_DEFAULT=MANPAGES ${MACHINE_CPU:Msoftfp:C/.+/TREMOR/}
|
||||
OPTIONS_DEFINE= DOCS MANPAGES NOTIFY TREMOR
|
||||
OPTIONS_DEFAULT=MANPAGES NOTIFY ${MACHINE_CPU:Msoftfp:C/.+/TREMOR/}
|
||||
|
||||
MANPAGES_BUILD_DEPENDS= xmlto:textproc/xmlto
|
||||
MANPAGES_PLIST_FILES=\
|
||||
|
@ -45,6 +46,9 @@ MANPAGES_PLIST_FILES=\
|
|||
man/man7/ponscr-syntax.7.gz \
|
||||
man/man7/ponscripter.7.gz
|
||||
|
||||
NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
|
||||
NOTIFY_CONFIGURE_WITH= libnotify
|
||||
|
||||
TREMOR_LIB_DEPENDS= libvorbisidec.so:audio/libtremor
|
||||
TREMOR_CFLAGS= -DINTEGER_OGG_VORBIS
|
||||
TREMOR_LIB_DEPENDS_OFF= libvorbisfile.so:audio/libvorbis
|
||||
|
|
|
@ -1,9 +1,5 @@
|
|||
TIMESTAMP = 1395987047
|
||||
SHA256 (sekaiproject-ponscripter-fork-v0.0.6_GH0.tar.gz) = b1ac4f2c01aae1ca68420ea5274307e4c6b3eb1b85272ec41c7fbf07239c48d2
|
||||
SIZE (sekaiproject-ponscripter-fork-v0.0.6_GH0.tar.gz) = 30564899
|
||||
SHA256 (101c68e22921.patch) = 604a45559988096c2441881eaff9d6ea9cfc9bcba03097609086b8b679a12635
|
||||
SIZE (101c68e22921.patch) = 2325
|
||||
SHA256 (4fb1180d2b54.patch) = 921224b2e64a0d60efc6f00598210d96a4903b735e48c181bd902da3b7c8e6f9
|
||||
SIZE (4fb1180d2b54.patch) = 1207
|
||||
SHA256 (25e752f272d0.patch) = 263bad81a88b356d3cbd2de611df994c486f7a7ce4eb831cc36882ccdc4c6992
|
||||
SIZE (25e752f272d0.patch) = 2742
|
||||
TIMESTAMP = 1585653053
|
||||
SHA256 (sekaiproject-ponscripter-fork-v0.0.6-162-g4f887b8_GH0.tar.gz) = 44fc0c3699b356c38551d4291b19cf5b81869160ebf634ea5a10d6b404493e76
|
||||
SIZE (sekaiproject-ponscripter-fork-v0.0.6-162-g4f887b8_GH0.tar.gz) = 33478357
|
||||
SHA256 (69068bf83653.patch) = ab7ace6c01bff5690c58dcf7e824d1bed5211f52e5984510c114a78d01f62de7
|
||||
SIZE (69068bf83653.patch) = 826
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
--- configure.orig 2021-08-06 14:18:09 UTC
|
||||
--- configure.orig 2020-03-31 11:10:53 UTC
|
||||
+++ configure
|
||||
@@ -53,7 +53,7 @@ EXPLICIT_OGGLIBS=false
|
||||
@@ -60,7 +60,7 @@ LOCAL_SAVEDIR=false
|
||||
|
||||
SDL_CONFIG=sdl2-config
|
||||
SMPEG_CONFIG=smpeg2-config
|
||||
|
@ -9,7 +9,7 @@
|
|||
EXTLIB=./extlib
|
||||
SRC=src
|
||||
MAKEFILE=$SRC/Makefile
|
||||
@@ -606,7 +606,7 @@ then
|
||||
@@ -637,7 +637,7 @@ then
|
||||
_EOF
|
||||
INTERNAL_SDL_MIXER=true
|
||||
$CXX `$SDL_CONFIG --cflags` test.cc `$SDL_CONFIG --libs` -lSDL2_mixer -o mtest >/dev/null 2>&1
|
||||
|
@ -18,7 +18,7 @@
|
|||
case $? in
|
||||
0) echo "yes"; INTERNAL_SDL_MIXER=false ;;
|
||||
1) echo "no MP3" ;; 2) echo "no Ogg" ;; 3) echo "no Ogg or MP3" ;;
|
||||
@@ -694,7 +694,7 @@ then
|
||||
@@ -725,7 +725,7 @@ then
|
||||
FREETYPE_CONFIG=$EXTLIB/bin/freetype-config
|
||||
else
|
||||
$echo_n "Checking for system Freetype... ${nobr}"
|
||||
|
@ -27,3 +27,24 @@
|
|||
if [ -z "$VER" ]; then
|
||||
FREETYPE_CONFIG=freetype2-config
|
||||
VER=`($FREETYPE_CONFIG --ftversion) 2>/dev/null`
|
||||
@@ -780,7 +780,7 @@ fi
|
||||
|
||||
if $WITH_LIBNOTIFY; then
|
||||
$echo_n "Checking for system libnotify... ${nobr}"
|
||||
- if `pkg-config --exists libnotify` && `pkg-config --exists gtk+-2.0`; then
|
||||
+ if `pkg-config --exists libnotify`; then
|
||||
echo "yes"
|
||||
WITH_LIBNOTIFY=true
|
||||
else
|
||||
@@ -865,9 +865,8 @@ NOTIFYLIBS=
|
||||
GTKLIBS=
|
||||
if $WITH_LIBNOTIFY
|
||||
then
|
||||
- OURLIBS="$OURLIBS -lnotify"
|
||||
- OURLIBS="$OURLIBS `pkg-config --libs gtk+-2.0`"
|
||||
- OURINCS="$OURINCS `pkg-config --cflags gtk+-2.0`"
|
||||
+ OURINCS="$OURINCS `pkg-config --cflags libnotify`"
|
||||
+ OURLIBS="$OURLIBS `pkg-config --libs libnotify`"
|
||||
OURDEFS="$OURDEFS -DLIBNOTIFY"
|
||||
fi
|
||||
|
||||
|
|
|
@ -1,13 +1,8 @@
|
|||
Ponscripter is an interpreter for visual-novel-type games, derived from
|
||||
the NScripter design but modified significantly to improve support for
|
||||
Western languages (at the cost of diminished support for Japanese).
|
||||
Ponscripter was created as an NScripter-style visual novel game
|
||||
interpreter with an emphasis on supporting games in Western languages.
|
||||
|
||||
Ponscripter is a fork of ONScripter-En that drops any attempt to remain
|
||||
in synch with the upstream source code, and instead concentrates on
|
||||
providing the best possible support for Western languages. It is no
|
||||
longer fully NScripter-compatible, but remains an easy target to port
|
||||
NScripter games to when localising them.
|
||||
|
||||
This fork takes advantage of SDL2 and improves Steam integration.
|
||||
This fork is intended to provide additional features to Ponscripter
|
||||
that make it more suitable for releasing games on Steam. It, however,
|
||||
does not have qualms with breaking compatibility in minor ways.
|
||||
|
||||
WWW: https://github.com/sekaiproject/ponscripter-fork
|
||||
|
|
Loading…
Reference in a new issue