Remove lang/njs and ports that depends on it, njs has no more public distfile and no more upstream

the other aren't under development anymore

lang/ruby-js
textproc/ruby-xml-script
www/ruby-asp
2011-05-01 lang/njs: Upstream disapear and distfile is no more available
This commit is contained in:
Baptiste Daroussin 2011-06-09 15:45:58 +00:00
parent 09d53e77d5
commit 3517c5d5a9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=275278
23 changed files with 4 additions and 371 deletions

4
MOVED
View file

@ -2217,3 +2217,7 @@ net-p2p/qbittorrent27-nox11|net-p2p/qbittorrent28-nox11|2011-06-05|Old version n
www/pubcookie-login-server||2011-06-06|Has expired: Unused by maintiner, needs updates. www/pubcookie-login-server||2011-06-06|Has expired: Unused by maintiner, needs updates.
databases/mariadb||2011-06-06|Split into databases/mariadb-{client,scripts,server} databases/mariadb||2011-06-06|Split into databases/mariadb-{client,scripts,server}
devel/bugzilla2||2011-06-07|Removed: no longer under development devel/bugzilla2||2011-06-07|Removed: no longer under development
lang/ruby-js||2011-06-09|Removed, depends on expired port, seems abandonware itself
textproc/ruby-xml-script||2011-06-09|Removed, depends on expired port, seems abandonware itself
www/ruby-asp||2011-06-09|Removed, depends on expired port, seems abandonware itself
lang/njs||2011-06-09|Has expired: Upstream disapear and distfile is no more available

View file

@ -179,7 +179,6 @@
SUBDIR += newlisp SUBDIR += newlisp
SUBDIR += nhc98 SUBDIR += nhc98
SUBDIR += nickle SUBDIR += nickle
SUBDIR += njs
SUBDIR += nml SUBDIR += nml
SUBDIR += nqc SUBDIR += nqc
SUBDIR += nwcc SUBDIR += nwcc
@ -288,7 +287,6 @@
SUBDIR += rubinius SUBDIR += rubinius
SUBDIR += ruby-doc-stdlib SUBDIR += ruby-doc-stdlib
SUBDIR += ruby-extensions SUBDIR += ruby-extensions
SUBDIR += ruby-js
SUBDIR += ruby-lua SUBDIR += ruby-lua
SUBDIR += ruby-lua4 SUBDIR += ruby-lua4
SUBDIR += ruby-man SUBDIR += ruby-man

View file

@ -1,38 +0,0 @@
# New ports collection makefile for: NJS
# Date created: Fri Jan 11 20:45:26 GMT 2002
# Whom: Thierry Thomas <thierry@pompo.net>
#
# $FreeBSD$
#
PORTNAME= njs
PORTVERSION= 0.2.5
PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= arved
DISTNAME= js-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= NJS (NGS) is a standalone JavaScript/ECMAScript interpreter
DEPRECATED= Upstream disapear and distfile is no more available
EXPIRATION_DATE= 2011-05-01
CONFLICTS= js-1.5.*
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --enable-shared
MAN1= js.1 jsdas.1
INFO= js
post-extract:
@${RM} ${WRKSRC}/docs/js.info*
# Fix for GCC 4.2
@${REINPLACE_CMD} -E \
's,\((unsigned char) \*\) (ptr \+=),\2 sizeof(\1) *,' \
${WRKSRC}/src/iostream.c
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (js-0.2.5.tar.gz) = b299c678e388a170eea09b6e12375152
SHA256 (js-0.2.5.tar.gz) = bf72717cd6af07cfb3c91b74fbf55003742a41d052addf0555fcd293b3dda057
SIZE (js-0.2.5.tar.gz) = 689982

View file

@ -1,11 +0,0 @@
--- configure.orig Fri Jan 15 08:39:56 1999
+++ configure Sun Jul 7 14:04:03 2002
@@ -791,7 +791,7 @@
# an executable is not found, even if stderr is redirected.
# Redirect stdin to placate older versions of autoconf. Sigh.
if (makeinfo --version) < /dev/null > /dev/null 2>&1; then
- MAKEINFO=makeinfo
+ MAKEINFO="makeinfo --no-split"
echo "$ac_t""found" 1>&6
else
MAKEINFO="$missing_dir/missing makeinfo"

View file

@ -1,14 +0,0 @@
--- docs/Makefile.in.orig Fri Jan 15 08:40:27 1999
+++ docs/Makefile.in Sun Jan 13 16:07:07 2002
@@ -219,10 +219,7 @@
done
@$(POST_INSTALL)
@if $(SHELL) -c 'install-info --version | sed 1q | fgrep -s -v -i debian' >/dev/null 2>&1; then \
- for file in $(INFO_DEPS); do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
- done; \
+ echo " install-info will be done in POST-INSTALL."; \
else : ; fi
uninstall-info:

View file

@ -1,3 +0,0 @@
NJS is an independent implementation of the JavaScript language developed
by Netscape and standardized by ECMA. It is designed to be re-entrant,
extendible, fast, and programmable.

View file

@ -1,11 +0,0 @@
bin/js
bin/jsas
bin/jsdas
bin/jswrap
include/js.h
include/jsint.h
include/jsconfig.h
lib/libjs.a
lib/libjs.la
lib/libjs.so
lib/libjs.so.0

View file

@ -1,46 +0,0 @@
# New ports collection makefile for: Ruby/JS
# Date created: 25 February 2003
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= js
PORTVERSION= 0.0.4
CATEGORIES= lang ruby
MASTER_SITES= http://www.rubyist.net/~tamura/ruby/ruby-js/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby binding to NJS JavaScript Interpreter
LIB_DEPENDS= js.0:${PORTSDIR}/lang/njs
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/JS
INSTALL_TARGET= site-install
EXAMPLES= classtest.rb
DOCS_EN= README.rd
DOCS_JA= README.rd.ja
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
.endfor
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (ruby/rubyjs-0.0.4.tar.gz) = 08310c43de18fbd39defa048dd54ea80
SHA256 (ruby/rubyjs-0.0.4.tar.gz) = 9f92dc67f37ff02401a249f40ab59f6c2377708c27d7c6b5a15a3db66b0defbf
SIZE (ruby/rubyjs-0.0.4.tar.gz) = 4040

View file

@ -1,14 +0,0 @@
Index: js.c
@@ -112,9 +112,9 @@
static VALUE
rb_js_eval(VALUE obj, VALUE code)
{
- JSInterpPtr interp;
- Data_Get_Struct(obj, JSInterpPtr, (void *) interp);
- return rb_js_evalcode(interp, code);
+ void *interp;
+ Data_Get_Struct(obj, JSInterpPtr, interp);
+ return rb_js_evalcode((JSInterpPtr) interp, code);
}
void

View file

@ -1,4 +0,0 @@
Ruby/JS -- A Ruby binding to NJS JavaScript Interpreter
Author: TAMURA. Kenichi <tamura@ruby-lang.org>
WWW: http://raa.ruby-lang.org/list.rhtml?name=ruby-js

View file

@ -1,7 +0,0 @@
%%RUBY_SITEARCHLIBDIR%%/js.so
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.rd
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ja/README.rd.ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%/ja
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/classtest.rb
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%

View file

@ -1135,7 +1135,6 @@
SUBDIR += ruby-sablot SUBDIR += ruby-sablot
SUBDIR += ruby-sary SUBDIR += ruby-sary
SUBDIR += ruby-tempura SUBDIR += ruby-tempura
SUBDIR += ruby-xml-script
SUBDIR += ruby-xmlconfigfile SUBDIR += ruby-xmlconfigfile
SUBDIR += ruby-xmlparser SUBDIR += ruby-xmlparser
SUBDIR += ruby-xmlscan SUBDIR += ruby-xmlscan

View file

@ -1,48 +0,0 @@
# New ports collection makefile for: Ruby/XML/Script
# Date created: 26 December 2004
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= xml-script
PORTVERSION= 0.2.0
CATEGORIES= textproc ruby
MASTER_SITES= http://gregoire.lejeune.free.fr/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}_${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby module for scripting an XML stream using an ASP-like notation
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/js.so:${PORTSDIR}/lang/ruby-js
USE_LUA= 4.0
LUA_COMPS= ruby
USE_RUBY= yes
USE_RUBY_SETUP= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
DOCS= AUTHORS \
README
EXAMPLES= tests/*
post-patch:
@${REINPLACE_CMD} -Ee 's|(language/lua)|\1-${LUA_VER}|' \
${WRKSRC}/lib/xml/script/lua/compiler.rb
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
.endfor
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,3 +0,0 @@
MD5 (ruby/ruby-xml-script_0.2.0.tar.gz) = f958fc41c5cc87b29ee21205a868a093
SHA256 (ruby/ruby-xml-script_0.2.0.tar.gz) = 46358f8c47c2fb801ec7fb7a7a4fa065a66362b8e864f309c04ef6d4377dd529
SIZE (ruby/ruby-xml-script_0.2.0.tar.gz) = 19402

View file

@ -1,7 +0,0 @@
Ruby/XML/Script allows you to script a XML stream using an ASP-like
notation <% ... %>.
Supported scripting languages are JavaScript, Lua and Ruby.
Author: Gregoire Lejeune <greg@webtime-project.net>
WWW: http://gregoire.lejeune.free.fr/

View file

@ -1,22 +0,0 @@
%%RUBY_SITELIBDIR%%/XmlScriptError.rb
%%RUBY_SITELIBDIR%%/xml/script.rb
%%RUBY_SITELIBDIR%%/xml/script/base.rb
%%RUBY_SITELIBDIR%%/xml/script/javascript/compiler.rb
%%RUBY_SITELIBDIR%%/xml/script/lua/compiler.rb
%%RUBY_SITELIBDIR%%/xml/script/ruby/compiler.rb
@dirrm %%RUBY_SITELIBDIR%%/xml/script/ruby
@dirrm %%RUBY_SITELIBDIR%%/xml/script/lua
@dirrm %%RUBY_SITELIBDIR%%/xml/script/javascript
@dirrm %%RUBY_SITELIBDIR%%/xml/script
@dirrm %%RUBY_SITELIBDIR%%/xml
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/javascript-test.xml
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/languages.rb
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/lua-test.xml
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/raise.rb
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ruby-error.xml
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/ruby-test.xml
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test.rb
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/AUTHORS
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%

View file

@ -1610,7 +1610,6 @@
SUBDIR += rt38 SUBDIR += rt38
SUBDIR += ruboard SUBDIR += ruboard
SUBDIR += ruby-amazon SUBDIR += ruby-amazon
SUBDIR += ruby-asp
SUBDIR += ruby-aws SUBDIR += ruby-aws
SUBDIR += ruby-borges SUBDIR += ruby-borges
SUBDIR += ruby-cruisecontrolrb SUBDIR += ruby-cruisecontrolrb

View file

@ -1,44 +0,0 @@
# New ports collection makefile for: Ruby-ASP
# Date created: 23 August 2003
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= asp
PORTVERSION= 0.4.1
PORTREVISION= 2
CATEGORIES= www ruby
MASTER_SITES= http://gregoire.lejeune.free.fr/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}_${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= An Active Server Pages port to Apache with Ruby scripting
RUN_DEPENDS= rubygem-xslt>=0.9.8:${PORTSDIR}/textproc/rubygem-xslt \
${RUBY_SITELIBDIR}/xml/script.rb:${PORTSDIR}/textproc/ruby-xml-script
USE_RUBY= yes
USE_RUBY_SETUP= yes
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}
DOCS= AUTHORS \
README
EXAMPLES= tests tests-cgi
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
${CP} -R ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
.endfor
${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,2 +0,0 @@
SHA256 (ruby/ruby-asp_0.4.1.tar.gz) = 34a50c47a17ccab6a518a0fdd6187079d60afdf82cf7b83429a68e4ed065af58
SIZE (ruby/ruby-asp_0.4.1.tar.gz) = 69982

View file

@ -1,7 +0,0 @@
Ruby-ASP provides an Active Server Pages port to the Apache Web Server
with Ruby scripting only, and enables developing of dynamic web
applications with session management and embedded Ruby code.
Author: Gregoire Lejeune <glejeune.lejeune@free.fr>
WWW: http://www.rubyfr.net/

View file

@ -1,80 +0,0 @@
bin/ruby-asp.rb
%%RUBY_SITELIBDIR%%/apache/aspruby-run.rb
%%RUBY_SITELIBDIR%%/asp.rb
%%RUBY_SITELIBDIR%%/asp/application.rb
%%RUBY_SITELIBDIR%%/asp/asperror.rb
%%RUBY_SITELIBDIR%%/asp/common.rb
%%RUBY_SITELIBDIR%%/asp/compile.rb
%%RUBY_SITELIBDIR%%/asp/globalasa.rb
%%RUBY_SITELIBDIR%%/asp/goto.rb
%%RUBY_SITELIBDIR%%/asp/params.rb
%%RUBY_SITELIBDIR%%/asp/request.rb
%%RUBY_SITELIBDIR%%/asp/response.rb
%%RUBY_SITELIBDIR%%/asp/server.rb
%%RUBY_SITELIBDIR%%/asp/session.rb
%%RUBY_SITELIBDIR%%/asp/subsmatch.rb
@dirrm %%RUBY_SITELIBDIR%%/asp
@dirrm %%RUBY_SITELIBDIR%%/apache
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/.htaccess
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/asp.conf
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/cookie.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/default.css
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/error.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/error.html
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/examples.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/footer.inc
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/global-asa/global.asa
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/global-asa/test.rb
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/header.inc
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/image.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/index.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/index.html
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/load.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/mod_ruby.png
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/rubyasp-cgi-power.png
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/server_variables.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/session.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/simple.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/source.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/subsmatch.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/title.gif
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/transfer.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/upload.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/xmlrpc_client.txt
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/xmlrpc_server.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests-cgi/xslt.casp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/.htaccess
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/cookie.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/default.css
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/error.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/error.html
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/examples.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/footer.inc
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/global-asa/global.asa
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/global-asa/test.rb
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/header.inc
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/image.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/index.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/index.html
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/load.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/mod_ruby.png
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/rubyasp-power.png
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/server_variables.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/session.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/simple.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/source.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/subsmatch.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/title.gif
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/transfer.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/upload.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/xmlrpc_client.txt
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/xmlrpc_server.asp
%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/tests/xslt.asp
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%/tests/global-asa
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%/tests-cgi/global-asa
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%/tests-cgi
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%/tests
%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/AUTHORS
%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%