- Update to 3.8.9

- Add LICENSE
- Use @sample in plist
- While here, regenerate patches to silence portlint warnings

PR:		196668
Submitted by:	jyoung15 at gmail.com
Approved by:	Balazs Nagy <js at iksz.hu> (maintainer)
This commit is contained in:
Guido Falsi 2015-05-14 07:51:09 +00:00
parent 560aacfbfe
commit 3517ec8213
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=386301
8 changed files with 27 additions and 29 deletions

View file

@ -2,13 +2,15 @@
# $FreeBSD$
PORTNAME= logrotate
PORTVERSION= 3.8.8
PORTVERSION= 3.8.9
CATEGORIES= sysutils
MASTER_SITES= https://fedorahosted.org/releases/l/o/logrotate/
MAINTAINER= js@iksz.hu
COMMENT= Daemon to rotate, compress, remove, and mail system log files
LICENSE= GPLv2
LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
PATCH_STRIP= -p1
@ -17,9 +19,9 @@ MAKE_ENV= "BASEDIR=${PREFIX}"
CPP= ${CC} -E
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${SED} -e 's|__PREFIX__|${PREFIX}|' \
< ${FILESDIR}/logrotate.conf.sample > ${STAGEDIR}${PREFIX}/etc/logrotate.conf.sample
@${INSTALL_DATA} ${FILESDIR}/syslog.sample ${STAGEDIR}${EXAMPLESDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/syslog.sample ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (logrotate-3.8.8.tar.gz) = 46a1510ef4a1f4359edd5f361112cfd1523942e85ff28e6cbb0c81bad1829d0f
SIZE (logrotate-3.8.8.tar.gz) = 72014
SHA256 (logrotate-3.8.9.tar.gz) = 700ed7ce9072a1cca324779a74797dfaefdae37ac50a817134b947c4ded1dfa7
SIZE (logrotate-3.8.9.tar.gz) = 77408

View file

@ -1,6 +1,6 @@
--- Makefile.orig 2013-06-10 13:29:16.000000000 +0200
+++ Makefile 2014-01-10 15:03:37.479613407 +0100
@@ -81,6 +81,13 @@
--- Makefile.orig 2015-02-13 06:11:21 UTC
+++ Makefile
@@ -81,6 +81,13 @@ ifeq ($(OS_NAME),NetBSD)
LOADLIBES += -L$(BASEDIR)/lib -Wl,-R,$(BASEDIR)/lib
endif
@ -14,7 +14,7 @@
ifneq ($(POPT_DIR),)
CFLAGS += -I$(POPT_DIR)
LOADLIBES += -L$(POPT_DIR)
@@ -148,9 +155,9 @@
@@ -155,9 +162,9 @@ install:
$(INSTALL) $(MAN) $(PREFIX)$(MANDIR)/man`echo $(MAN) | sed "s/.*\.//"` 0644 bin bin; \
$(INSTALL) $(MAN5) $(PREFIX)$(MANDIR)/man`echo $(MAN5) | sed "s/.*\.//"` 0644 bin bin; \
else if [ "$(OS_NAME)" = FreeBSD ]; then \

View file

@ -1,7 +1,7 @@
--- config.c.orig 2012-11-09 18:58:51.756188812 +0800
+++ config.c 2012-11-09 19:00:23.064190229 +0800
--- config.c.orig 2015-02-13 06:11:21 UTC
+++ config.c
@@ -1,8 +1,4 @@
#include <sys/queue.h>
#include "queue.h"
-/* Alloca is defined in stdlib.h in NetBSD */
-#ifndef __NetBSD__
-#include <alloca.h>

View file

@ -1,8 +1,6 @@
diff --git a/config.h b/config.h
index ae7f308..7c0a2b3 100644
--- a/config.h
+++ b/config.h
@@ -16,6 +16,13 @@
--- config.h.orig 2015-02-13 06:11:21 UTC
+++ config.h
@@ -23,6 +23,13 @@
#define STATEFILE "/var/log/logrotate.status"
#endif

View file

@ -1,15 +1,15 @@
--- logrotate.8.orig 2012-11-09 19:10:08.054188039 +0800
+++ logrotate.8 2012-11-09 19:10:57.749187879 +0800
@@ -59,7 +59,7 @@
\fB-s, -\-state <statefile>\fR
--- logrotate.8.orig 2015-02-13 06:11:21 UTC
+++ logrotate.8
@@ -59,7 +59,7 @@ and mail it to the recipient. The defaul
\fB\-s\fR, \fB\-\-state <statefile>\fR
Tells \fBlogrotate\fR to use an alternate state file. This is useful
if logrotate is being run as a different user for various sets of
-log files. The default state file is \fI/var/lib/logrotate.status\fR.
+log files. The default state file is \fI/var/run/logrotate.status\fR.
.TP
\fB-\-usage\fR
@@ -507,10 +507,10 @@
\fB\-\-usage\fR
@@ -550,10 +550,10 @@ Log files are rotated if the current yea
.SH FILES
.PD 0
.TP 27

View file

@ -1,7 +1,7 @@
--- logrotate.c.orig 2012-11-09 19:00:58.744187984 +0800
+++ logrotate.c 2012-11-09 19:01:05.528189740 +0800
--- logrotate.c.orig 2015-02-13 06:11:21 UTC
+++ logrotate.c
@@ -1,8 +1,4 @@
#include <sys/queue.h>
#include "queue.h"
-/* alloca() is defined in stdlib.h in NetBSD */
-#ifndef __NetBSD__
-#include <alloca.h>

View file

@ -1,7 +1,5 @@
sbin/logrotate
@unexec if cmp -s %D/etc/logrotate.conf.sample %D/etc/logrotate.conf; then rm -f %D/etc/logrotate.conf; fi
etc/logrotate.conf.sample
@exec if [ ! -f %D/etc/logrotate.conf ]; then cp -p %D/%F %B/logrotate.conf; fi
@sample etc/logrotate.conf.sample
%%EXAMPLESDIR%%/syslog.sample
man/man5/logrotate.conf.5.gz
man/man8/logrotate.8.gz